summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarl Trygve Kalleberg <karltk@gentoo.org>2002-10-31 20:12:43 +0000
committerKarl Trygve Kalleberg <karltk@gentoo.org>2002-10-31 20:12:43 +0000
commit3526e013098bc832b9a6379b74e5a8bd05845011 (patch)
treee24458997b8dff51f6288b8e99b107470006be1d /net-www/horde-chora
parentFixes #6047. (diff)
downloadhistorical-3526e013098bc832b9a6379b74e5a8bd05845011.tar.gz
historical-3526e013098bc832b9a6379b74e5a8bd05845011.tar.bz2
historical-3526e013098bc832b9a6379b74e5a8bd05845011.zip
Fixes #6091.
Diffstat (limited to 'net-www/horde-chora')
-rw-r--r--net-www/horde-chora/ChangeLog8
-rw-r--r--net-www/horde-chora/files/digest-horde-chora-1.11
-rw-r--r--net-www/horde-chora/horde-chora-1.1.ebuild74
3 files changed, 83 insertions, 0 deletions
diff --git a/net-www/horde-chora/ChangeLog b/net-www/horde-chora/ChangeLog
new file mode 100644
index 000000000000..3ca48b133669
--- /dev/null
+++ b/net-www/horde-chora/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for net-mail/horde-imp
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/horde-chora/ChangeLog,v 1.1 2002/10/31 20:12:43 karltk Exp $
+
+*horde-chora-1.1 (31 Oct 2002)
+
+ 31 Oct 2002; Karl Trygve Kalleberg <karltk@gentoo.org> horde-chora-1.1.ebuild files/digest-horde-chora-1.1 :
+ Initial import. Ebuild submitted by Christophe GUILLOUX <cg@rootix.info>.
diff --git a/net-www/horde-chora/files/digest-horde-chora-1.1 b/net-www/horde-chora/files/digest-horde-chora-1.1
new file mode 100644
index 000000000000..add47dbc4c6d
--- /dev/null
+++ b/net-www/horde-chora/files/digest-horde-chora-1.1
@@ -0,0 +1 @@
+MD5 fffcdc04a6440ec42bdc62de79941a4a chora-1.1.tar.gz 124152
diff --git a/net-www/horde-chora/horde-chora-1.1.ebuild b/net-www/horde-chora/horde-chora-1.1.ebuild
new file mode 100644
index 000000000000..00c68d093fe5
--- /dev/null
+++ b/net-www/horde-chora/horde-chora-1.1.ebuild
@@ -0,0 +1,74 @@
+# Copyright 2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/horde-chora/horde-chora-1.1.ebuild,v 1.1 2002/10/31 20:12:43 karltk Exp $
+
+DESCRIPTION="Chora is the Horde CVS viewer."
+HOMEPAGE="http://www.horde.org"
+P=chora-1.1
+SRC_URI="ftp://ftp.horde.org/pub/chora/tarballs/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="1"
+KEYWORDS="~x86 ~ppc ~sparc ~sparc64 ~alpha"
+DEPEND=""
+RDEPEND=">=net-www/horde-2.1
+ >=app-text/rcs-5.7-r1
+ >=dev-util/cvs-1.11.2"
+IUSE=""
+
+find_http_root() {
+ HTTPD_ROOT=`grep apache /etc/passwd | cut -d: -f6`/htdocs
+ if [ -z "${HTTPD_ROOT}" ]; then
+ eerror "HTTPD_ROOT is null! Using defaults."
+ eerror "You probably want to check /etc/passwd"
+ HTTPD_ROOT="/home/httpd/htdocs"
+ fi
+
+ REGISTRY=${HTTPD_ROOT}/horde/config/registry.php
+ [ -f ${REGISTRY} ] || REGISTRY=${HTTPD_ROOT}/horde/config/registry.php.dist
+}
+
+src_compile() {
+ echo "Nothing to compile"
+}
+
+src_install () {
+ find_http_root
+
+ # detecting apache usergroup
+ GID=`grep apache /etc/group |cut -d: -f3`
+ if [ -z "${GID}" ]; then
+ einfo "Using default GID of 81 for Apache"
+ GID=81
+ fi
+
+ dodir ${HTTPD_ROOT}/horde/chora
+ cp -r . ${D}/${HTTPD_ROOT}/horde/chora
+
+ # protecting files
+ chown -R root.${GID} ${D}/${HTTPD_ROOT}/horde/chora
+ find ${D}/${HTTPD_ROOT}/horde/chora/ -type f -exec chmod 0640 {} \;
+ find ${D}/${HTTPD_ROOT}/horde/chora/ -type d -exec chmod 0750 {} \;
+}
+
+pkg_postinst() {
+ find_http_root
+ # add module in horde
+ sed -e "/^\/\/.*\(\$this->applications\['chora'\].*\)/ \
+ { : next ; N ; /\;/ { s/\/\///g ; b } ; b next }" \
+ < ${REGISTRY} > ${REGISTRY}.temp
+ cp ${REGISTRY}.temp ${REGISTRY}
+ rm ${REGISTRY}.temp
+
+ einfo "Please read ${HTTPD_ROOT}/horde/chora/docs/INSTALL !"
+}
+
+pkg_prerm() {
+ find_http_root
+ # rm module from horde
+ sed -e "/\(\$this->applications\['chora'\].*\)/ \
+ { s/\(.*\)/\/\/\1/g; : suite ; N ; /\;/ { s/\n/\n\/\//g ; b } ; \
+ b suite }" \
+ < ${REGISTRY} > ${REGISTRY}.temp
+ cp ${REGISTRY}.temp ${REGISTRY}
+ rm ${REGISTRY}.temp
+}