summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2003-01-17 10:08:34 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2003-01-17 10:08:34 +0000
commite6777008bb877c8f040bc6f89241b26881a77241 (patch)
treed3fc09599ae9ef8b6d8c13c4491316f6c388bdfc /net-www/fnord
parentremoving really old xemacs-packages-sumo ebuilds (diff)
downloadhistorical-e6777008bb877c8f040bc6f89241b26881a77241.tar.gz
historical-e6777008bb877c8f040bc6f89241b26881a77241.tar.bz2
historical-e6777008bb877c8f040bc6f89241b26881a77241.zip
Security update
Diffstat (limited to 'net-www/fnord')
-rw-r--r--net-www/fnord/ChangeLog7
-rw-r--r--net-www/fnord/files/digest-fnord-1.71
-rw-r--r--net-www/fnord/files/fnord-1.7-gentoo.diff31
-rw-r--r--net-www/fnord/fnord-1.7.ebuild54
4 files changed, 92 insertions, 1 deletions
diff --git a/net-www/fnord/ChangeLog b/net-www/fnord/ChangeLog
index e5b4df9a696e..db1503163317 100644
--- a/net-www/fnord/ChangeLog
+++ b/net-www/fnord/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-www/fnord
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-www/fnord/ChangeLog,v 1.8 2002/12/13 11:00:27 blizzy Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/fnord/ChangeLog,v 1.9 2003/01/17 10:08:34 aliz Exp $
+
+*fnord-1.7 (17 Jan 2003)
+
+ 17 Jan 2003; Daniel Ahlberg <aliz@gentoo.org> fnord-1.7.ebuild :
+ Security update.
06 Dec 2002; Rodney Rees <manson@gentoo.org> : changed sparc ~sparc keywords
diff --git a/net-www/fnord/files/digest-fnord-1.7 b/net-www/fnord/files/digest-fnord-1.7
new file mode 100644
index 000000000000..ce810ced552b
--- /dev/null
+++ b/net-www/fnord/files/digest-fnord-1.7
@@ -0,0 +1 @@
+MD5 1625fdff8323959ba7aa1bbba9772b01 fnord-1.7.tar.bz2 26325
diff --git a/net-www/fnord/files/fnord-1.7-gentoo.diff b/net-www/fnord/files/fnord-1.7-gentoo.diff
new file mode 100644
index 000000000000..d33d415217da
--- /dev/null
+++ b/net-www/fnord/files/fnord-1.7-gentoo.diff
@@ -0,0 +1,31 @@
+--- httpd.c.orig 2002-09-17 12:26:41.000000000 +0200
++++ httpd.c 2002-09-17 12:27:02.000000000 +0200
+@@ -23,7 +23,7 @@
+ #include "scan.h"
+
+ /* uncomment the following line to enable support for CGI */
+-// #define CGI
++#define CGI
+
+ #ifdef CGI
+ /* uncomment the following line to enable support for "index.cgi"
+@@ -37,7 +37,7 @@
+
+ /* uncomment the following line to enable support for autogenerated
+ * directory-listings for directories without index */
+-/* #define DIR_LIST */
++#define DIR_LIST
+
+ #ifdef DIR_LIST
+ /* uncomment the following line to enable support for system symlink
+--- fnord-conf.orig 2002-09-17 12:25:31.000000000 +0200
++++ fnord-conf 2002-09-17 12:25:46.000000000 +0200
+@@ -17,7 +17,7 @@
+ mkdir -p $dir
+ echo "#!/bin/sh" > $dir/run
+ echo "cd $webroot" >> $dir/run
+-echo "exec tcpserver -u $acct -RHl localhost ${myip:-0} 80 /command/fnord-httpd 2>&1" >> $dir/run
++echo "exec tcpserver -u $acct -RHl localhost ${myip:-0} 80 /usr/bin/fnord 2>&1" >> $dir/run
+ chmod 755 $dir/run
+
+ # tell old daemontools that it should spawn a log process, too
diff --git a/net-www/fnord/fnord-1.7.ebuild b/net-www/fnord/fnord-1.7.ebuild
new file mode 100644
index 000000000000..dbc013fd9a5e
--- /dev/null
+++ b/net-www/fnord/fnord-1.7.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/fnord/fnord-1.7.ebuild,v 1.1 2003/01/17 10:08:34 aliz Exp $
+
+S=${WORKDIR}/${P}
+
+DESCRIPTION="Yet another small httpd."
+SRC_URI="http://www.fefe.de/fnord/${P}.tar.bz2"
+HOMEPAGE="http://www.fefe.de/fnord/"
+
+KEYWORDS="x86 sparc "
+SLOT="0"
+LICENSE="GPL-2"
+
+DEPEND="dev-libs/dietlibc"
+RDEPEND="sys-apps/daemontools"
+
+pkg_setup() {
+
+ if ! grep -q ^fnord: /etc/passwd ; then
+ useradd -g nofiles -s /bin/false -d /etc/fnord -c "fnord" fnord\
+ || die "problem adding user fnord"
+ fi
+ if ! grep -q ^fnordlog: /etc/passwd ; then
+ useradd -g nofiles -s /bin/false -d /etc/fnord -c "fnordlog" fnordlog\
+ || die "problem adding user fnordlog"
+ fi
+}
+
+src_unpack() {
+
+ unpack ${A} ; cd ${S}
+ mv Makefile Makefile.orig
+ sed -e "s:^CFLAGS=-O.*:CFLAGS=${CFLAGS}:" \
+ Makefile.orig > Makefile
+
+ patch -p0 < ${FILESDIR}/${PF}-gentoo.diff
+
+}
+
+src_compile() {
+
+ emake || die
+
+}
+
+src_install () {
+
+ exeinto /usr/bin
+ doexe fnord-conf fnord
+
+ dodoc TODO README SPEED COPYING CHANGES
+
+}