summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Nelson <jnelson@gentoo.org>2002-04-09 02:00:31 +0000
committerJon Nelson <jnelson@gentoo.org>2002-04-09 02:00:31 +0000
commitde16dafffb6d805ffe11a253f4f6e6dd179a0010 (patch)
tree4056fabf8a1e0364f560372ad0acfe92b2aa5e30 /net-www/boa
parentfix problem with finding its data (diff)
downloadhistorical-de16dafffb6d805ffe11a253f4f6e6dd179a0010.tar.gz
historical-de16dafffb6d805ffe11a253f4f6e6dd179a0010.tar.bz2
historical-de16dafffb6d805ffe11a253f4f6e6dd179a0010.zip
update to new home for web stuff
Diffstat (limited to 'net-www/boa')
-rw-r--r--net-www/boa/ChangeLog8
-rw-r--r--net-www/boa/boa-0.94.11-r1.ebuild91
2 files changed, 98 insertions, 1 deletions
diff --git a/net-www/boa/ChangeLog b/net-www/boa/ChangeLog
index 8e5da31870b6..97eaa46794ac 100644
--- a/net-www/boa/ChangeLog
+++ b/net-www/boa/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-www/boa
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-www/boa/ChangeLog,v 1.1 2002/02/01 21:53:36 gbevin Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/boa/ChangeLog,v 1.2 2002/04/09 02:00:31 jnelson Exp $
+
+*boa-0.94.11-r1 (8 Apr 2002)
+
+ 8 Apr 2002; Jon Nelson <jnelson@gentoo.org> boa-0.94.11-r1.ebuild
+
+ Move files to new location of /home/httpd/{cgi-bin,htdocs,icons}
*boa-0.94.11 (1 Feb 2002)
diff --git a/net-www/boa/boa-0.94.11-r1.ebuild b/net-www/boa/boa-0.94.11-r1.ebuild
new file mode 100644
index 000000000000..9140fdd7246f
--- /dev/null
+++ b/net-www/boa/boa-0.94.11-r1.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Jon Nelson <jnelson@boa.org>
+# /home/cvsroot/gentoo-x86/skel.build,v 1.7 2001/08/25 21:15:08 chadh Exp
+
+#Source directory; the dir where the sources can be found (automatically
+# unpacked) inside ${WORKDIR}
+S=${WORKDIR}/${P}
+
+#Short one-line description
+DESCRIPTION="Boa - A very small and very fast http daemon."
+
+#Point to any required sources; these will be automatically downloaded
+# by Portage
+SRC_URI="http://www.boa.org/${P}.tar.gz"
+
+#Homepage, not used by Portage directly but handy for developer reference
+HOMEPAGE="http://www.boa.org/"
+
+#build-time dependencies
+DEPEND="virtual/glibc
+ sys-devel/flex
+ sys-devel/bison
+ sys-apps/texinfo
+ tex? ( app-text/tetex )"
+
+#run-time dependencies, same as DEPEND if RDEPEND isn't defined:
+RDEPEND="virtual/glibc"
+
+src_compile() {
+ cd src
+ ./configure --infodir=/usr/share/info --mandir=/usr/share/man --prefix=/usr --host=${CHOST} || die
+ #Note the use of --infodir and --mandir, above. This is to make
+ # this package FHS 2.2-compliant
+ #(/usr/share is used for info and man now).
+
+ emake || die
+ cd ../docs
+ make boa.html boa.info || die
+ echo "`use tex`"
+ if [ ! -z "`use tex`" ]; then
+ make boa.dvi || die
+ fi
+}
+
+src_install () {
+ # make prefix=${D}/usr install
+ dosbin src/boa || die
+ doman docs/boa.8 || die
+ dodoc docs/boa.html || die
+ dodoc docs/boa_banner.png || die
+ doinfo docs/boa.info || die
+ if [ ! -z "`use tex`" ]; then
+ dodoc docs/boa.dvi || die
+ fi
+
+ dodir /var/log/boa || die
+ dodir /home/httpd/htdocs || die
+ dodir /home/httpd/cgi-bin || die
+ dodir /home/httpd/icons || die
+
+ exeinto /usr/lib/boa
+ doexe src/boa_indexer || die
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/boa.rc6 boa || die
+
+ insinto /etc/boa
+ insopts -m700
+ insopts -m600
+ doins ${FILESDIR}/boa.conf || die
+ doins ${FILESDIR}/mime.types || die
+
+ # make DESTDIR=${D} install || die
+}
+
+pkg_prerm() {
+
+ if [ "$ROOT" = "/" ] && [ -e /dev/shm/.init.d/started/boa ] ; then
+ /etc/init.d/boa stop
+ fi
+ return # dont fail
+}
+
+pkg_preinst() {
+
+ if [ "$ROOT" = "/" ] && [ -e /dev/shm/.init.d/started/boa ] ; then
+ /etc/init.d/boa stop
+ fi
+ return # dont fail
+}