summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2006-04-02 10:19:59 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2006-04-02 10:19:59 +0000
commitf35579787691463b6cd788385002e8335900e9d1 (patch)
tree88c19f22eb1e6a18b76f6e961b232a112f9bff49 /net-wireless
parentA new revision with support for pci, plx and pcmcia drivers removed. (diff)
downloadhistorical-f35579787691463b6cd788385002e8335900e9d1.tar.gz
historical-f35579787691463b6cd788385002e8335900e9d1.tar.bz2
historical-f35579787691463b6cd788385002e8335900e9d1.zip
Removed pcmcia support in favor of better alternatives like hostap and orinoco drivers.
Package-Manager: portage-2.1_pre7-r3
Diffstat (limited to 'net-wireless')
-rw-r--r--net-wireless/linux-wlan-ng/ChangeLog9
-rw-r--r--net-wireless/linux-wlan-ng/files/digest-linux-wlan-ng-0.2.3-r13
-rw-r--r--net-wireless/linux-wlan-ng/linux-wlan-ng-0.2.3-r1.ebuild158
3 files changed, 169 insertions, 1 deletions
diff --git a/net-wireless/linux-wlan-ng/ChangeLog b/net-wireless/linux-wlan-ng/ChangeLog
index 90da77d7c07b..41f6b088da24 100644
--- a/net-wireless/linux-wlan-ng/ChangeLog
+++ b/net-wireless/linux-wlan-ng/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-wireless/linux-wlan-ng
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/linux-wlan-ng/ChangeLog,v 1.54 2006/02/12 19:53:42 betelgeuse Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/linux-wlan-ng/ChangeLog,v 1.55 2006/04/02 10:19:59 betelgeuse Exp $
+
+*linux-wlan-ng-0.2.3-r1 (02 Apr 2006)
+
+ 02 Apr 2006; Petteri Räty <betelgeuse@gentoo.org>
+ +linux-wlan-ng-0.2.3-r1.ebuild:
+ Removed pcmcia support in favor of better alternatives like hostap and
+ orinoco drivers.
12 Feb 2006; Petteri Räty <betelgeuse@gentoo.org>
-linux-wlan-ng-0.2.2.ebuild:
diff --git a/net-wireless/linux-wlan-ng/files/digest-linux-wlan-ng-0.2.3-r1 b/net-wireless/linux-wlan-ng/files/digest-linux-wlan-ng-0.2.3-r1
new file mode 100644
index 000000000000..0680fd82180a
--- /dev/null
+++ b/net-wireless/linux-wlan-ng/files/digest-linux-wlan-ng-0.2.3-r1
@@ -0,0 +1,3 @@
+MD5 f26e41336a2838d69a366ab3a2d93ea0 linux-wlan-ng-0.2.3.tar.bz2 454053
+RMD160 a39a6f17dd8a745992a557605d3f5734d8b7de95 linux-wlan-ng-0.2.3.tar.bz2 454053
+SHA256 97004d6cefd1b5c5f37efc1603e4103f9a809d79f8cc0faf2397fa882cdd6ee6 linux-wlan-ng-0.2.3.tar.bz2 454053
diff --git a/net-wireless/linux-wlan-ng/linux-wlan-ng-0.2.3-r1.ebuild b/net-wireless/linux-wlan-ng/linux-wlan-ng-0.2.3-r1.ebuild
new file mode 100644
index 000000000000..12457f669747
--- /dev/null
+++ b/net-wireless/linux-wlan-ng/linux-wlan-ng-0.2.3-r1.ebuild
@@ -0,0 +1,158 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/linux-wlan-ng/linux-wlan-ng-0.2.3-r1.ebuild,v 1.1 2006/04/02 10:19:59 betelgeuse Exp $
+
+#The configure script needs prepared sources.
+inherit linux-mod
+
+DESCRIPTION="Programs/files needed for Prism2/2.5/3 based USB wireless LAN products"
+HOMEPAGE="http://linux-wlan.org"
+SRC_URI="ftp://ftp.linux-wlan.org/pub/linux-wlan-ng/${P}.tar.bz2"
+
+# includes dual licensed files but also stuff only under MPL-1.1
+LICENSE="|| ( GPL-2 MPL-1.1 ) MPL-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE="debug doc"
+
+DEPEND="~net-wireless/linux-wlan-ng-modules-${PV}
+ ~net-wireless/linux-wlan-ng-utils-0.2.2
+ ~net-wireless/linux-wlan-ng-firmware-0.2.2"
+
+RDEPEND=${DEPEND}
+
+#relative to src/
+COMPILE_DIRS="mkmeta wlanctl wland nwepgen wlancfg prism2/download"
+INSTALL_DIRS="${COMPILE_DIRS} ../etc"
+
+CONFIG_FILE="${S}/default.config"
+CONFIG_DIR="/etc/conf.d"
+
+config_by_usevar() {
+ local config=${3}
+ [[ -z ${config} ]] && config=${CONFIG_FILE}
+
+ if use ${2}; then
+ echo "${1}=y" >> ${config}
+ else
+ echo "${1}=n" >> ${config}
+ fi
+}
+
+set_option() {
+ local config=${3}
+ [[ -z ${config} ]] && config=${CONFIG_FILE}
+
+ echo "${1}=${2}" >> ${config}
+}
+
+src_unpack() {
+ local config=${CONFIG_FILE}
+
+ unpack ${A}
+
+ rm ${S}/doc/rh71notes
+
+ cd ${S}/etc
+ mv rc.wlan rc.wlan.orig
+ cp ${FILESDIR}/${PN}-gentoo-init rc.wlan
+
+ #IMHO this should not be done but better to not upset users at this point
+ sed -i -e "s:/etc/wlan:/etc/conf.d:g" ${S}/etc/wlan/Makefile
+ sed -i -e "s:/etc/wlan/wlan.conf:/etc/conf.d/wlan.conf:g" \
+ -e "s:/etc/wlan/wlancfg:/etc/conf.d/wlancfg:g" \
+ ${S}/etc/wlan/shared
+
+ cp ${S}/config.in ${config}
+
+ set_option TARGET_ROOT_ON_HOST ${D}
+ set_option LINUX_SRC ${KERNEL_DIR}
+ set_option PRISM2_USB n
+ set_option PRISM2_PCI n
+ set_option PRISM2_PLX n
+ set_option PRISM2_PCMCIA n
+
+ if kernel_is gt 2 4; then
+ set_option KERN_25 y
+ fi
+
+ config_by_usevar WLAN_DEBUG debug
+}
+
+src_compile() {
+ set_arch_to_kernel
+ emake default_config || die "emake default_config failed"
+ set_arch_to_portage
+
+ CONFIG_FILE="config.mk"
+
+ set_option FIRMWARE_DIR "/lib/firmware"
+ set_option PRISM2_PCMCIA n
+
+ #For the scripts that go to /etc
+ set_option TARGET_PCMCIA_DIR ${D}/etc/pcmcia
+
+ cd ${S}/src/
+ for dir in ${COMPILE_DIRS}; do
+ pushd ${dir}
+ make || die "make in ${dir} failed"
+ popd
+ done
+}
+
+src_install() {
+ cd ${S}/man
+ doman *.1
+
+ # Does not install hotplug rules if /etc/hotplug
+ # does not exist in ${D}
+ # Needs to be patch because expects stuff to be in /etc/wlan
+ # dodir /etc/hotplug
+
+ for dir in ${INSTALL_DIRS}; do
+ pushd ${S}/src/${dir}
+ make install || die "make install in ${dir} failed"
+ popd
+ done
+
+ cd ${S}
+
+ dodir etc/wlan
+ mv ${D}/etc/conf.d/shared ${D}/etc/wlan/
+
+ if use doc; then
+ insinto /usr/share/doc/${PF}/
+ pushd ${S}/doc
+ for file in $(ls); do
+ [[ "${file}" != "Makefile" ]] && doins -r ${file}
+ done
+ popd
+ fi
+
+ dodoc CHANGES FAQ README THANKS TODO
+}
+
+pkg_postinst() {
+ einfo "/etc/init.d/wlan is used to control startup and shutdown of the"
+ einfo "driver."
+ einfo ""
+ einfo "Modify ${CONFIG_DIR}/wlan.conf to set global parameters."
+ einfo "Modify ${CONFIG_DIR}/wlancfg-* to set individual card parameters."
+ einfo "There are detailed instructions in these config files."
+ einfo ""
+ einfo "Three keygen programs are included: nwepgen, keygen, and lwepgen."
+ einfo "keygen seems provide more usable keys at the moment."
+ einfo "You can change the keygen in your wlancfg-* files."
+ einfo ""
+ einfo "Be sure to add iface_wlan0 parameters to /etc/conf.d/net."
+ einfo ""
+ einfo ""
+ einfo "Support for pci, plx and pcmcia drivers has been removed in"
+ einfo "revision. For pci, plx and pcmcia drivers try for example"
+ einfo "the hostap-driver or orinoco drivers. They both work with the"
+ einfo "standard wireless tools."
+ einfo ""
+ einfo "If they do not work, please report this to betelgeuse@gentoo.org."
+}
+