summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonny Davies <woodchip@gentoo.org>2002-01-08 07:29:44 +0000
committerDonny Davies <woodchip@gentoo.org>2002-01-08 07:29:44 +0000
commitec6615ebf4fa97f4b70b2178a070e5712a400eaa (patch)
tree50b577b41ab161aea733c433e3ff38ef02589f5f /net-print
parentUpdated version to latest available. Removed couple of older ebuilds. (diff)
downloadhistorical-ec6615ebf4fa97f4b70b2178a070e5712a400eaa.tar.gz
historical-ec6615ebf4fa97f4b70b2178a070e5712a400eaa.tar.bz2
historical-ec6615ebf4fa97f4b70b2178a070e5712a400eaa.zip
Updated to latest available version.
Tidy up sample printcap, remove two references to the same manpage. Delete some old ebuilds, and the old rc5 initscript. Now installs the config files in /etc/lprng without the .sample extension.
Diffstat (limited to 'net-print')
-rw-r--r--net-print/LPRng/LPRng-3.8.4.ebuild57
-rw-r--r--net-print/LPRng/files/digest-LPRng-3.8.41
-rw-r--r--net-print/LPRng/files/printcap8
3 files changed, 62 insertions, 4 deletions
diff --git a/net-print/LPRng/LPRng-3.8.4.ebuild b/net-print/LPRng/LPRng-3.8.4.ebuild
new file mode 100644
index 000000000000..108db5030e15
--- /dev/null
+++ b/net-print/LPRng/LPRng-3.8.4.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: System Team <system@gentoo.org>
+# Author: Donny Davies <woodchip@gentoo.org>
+# $Header $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Extended implementation of the Berkley LPR print spooler"
+HOMEPAGE="http://www.lprng.com/"
+SRC_URI="ftp://ftp.lprng.com/pub/LPRng/LPRng/${P}.tgz"
+
+PROVIDE="virtual/lpr"
+DEPEND="virtual/glibc nls? ( sys-devel/gettext ) !net-print/cups"
+RDEPEND="virtual/glibc"
+
+src_compile() {
+
+ local myconf
+ use nls && myconf="--enable-nls"
+
+ # wont compile with -O3, needs -O2
+ export CFLAGS="${CFLAGS/-O[3456789]/-O2}"
+
+ ./configure \
+ --prefix=/usr \
+ --disable-setuid \
+ --with-userid=lp \
+ --with-groupid=lp \
+ --libexecdir=/usr/lib \
+ --sysconfdir=/etc/lprng \
+ --mandir=/usr/share/man \
+ --host=${CHOST} ${myconf} || die
+
+ make || die "printer on fire!"
+}
+
+src_install() {
+
+ dodir /var/spool/lpd
+ diropts -m 700 -o lp -g lp ; dodir /var/spool/lpd/lp
+
+ make \
+ DESTDIR=${D} \
+ POSTINSTALL="NO" \
+ gnulocaledir=${D}/usr/share/locale \
+ install || die
+
+ exeinto /usr/bin ; doexe ${FILESDIR}/lpdomatic
+
+ dodoc CHANGES COPYRIGHT LICENSE README VERSION HOWTO/LPRng-HOWTO.pdf
+ dodoc ${FILESDIR}/printcap lpd.conf lpd.perms
+ docinto html ; dodoc HOWTO/{LPRng-HOWTO.html,*.jpg}
+
+ insinto /etc/lprng
+ doins ${FILESDIR}/printcap lpd.conf lpd.perms
+ exeinto /etc/init.d ; newexe ${FILESDIR}/lprng.rc6 lprng
+}
diff --git a/net-print/LPRng/files/digest-LPRng-3.8.4 b/net-print/LPRng/files/digest-LPRng-3.8.4
new file mode 100644
index 000000000000..25ddea0fa588
--- /dev/null
+++ b/net-print/LPRng/files/digest-LPRng-3.8.4
@@ -0,0 +1 @@
+MD5 f38cb82e3e5a55f9f676aab61c2fe91e LPRng-3.8.4.tgz 5042176
diff --git a/net-print/LPRng/files/printcap b/net-print/LPRng/files/printcap
index 4eb85ca78bb3..c851e8e2e826 100644
--- a/net-print/LPRng/files/printcap
+++ b/net-print/LPRng/files/printcap
@@ -1,7 +1,7 @@
-# /etc/printcap: printer capability database. See printcap(5).
-# You can use the filter entries df, tf, cf, gf etc. for
-# your own filters. See the printcap(5) manual page for further
-# details.
+# /etc/printcap: printer capability database.
+#
+# You can use the filter entries df, tf, cf, gf etc. for your
+# own filters. See the printcap(5) manpage for more details.
lp|Generic dot-matrix printer entry
:lp=/dev/lp1