summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHeinrich Wendel <lanius@gentoo.org>2003-10-04 20:11:21 +0000
committerHeinrich Wendel <lanius@gentoo.org>2003-10-04 20:11:21 +0000
commite75d4fc025b1c5d2e8faf07db6444b60b750c15f (patch)
treec6db8d628996f8927020bbfa9665f26e1d8bec0e /net-print/gtklp/gtklp-0.9p.ebuild
parentchangelog:p (diff)
downloadhistorical-e75d4fc025b1c5d2e8faf07db6444b60b750c15f.tar.gz
historical-e75d4fc025b1c5d2e8faf07db6444b60b750c15f.tar.bz2
historical-e75d4fc025b1c5d2e8faf07db6444b60b750c15f.zip
changelog:p
Diffstat (limited to 'net-print/gtklp/gtklp-0.9p.ebuild')
-rw-r--r--net-print/gtklp/gtklp-0.9p.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/net-print/gtklp/gtklp-0.9p.ebuild b/net-print/gtklp/gtklp-0.9p.ebuild
new file mode 100644
index 000000000000..cfdfdc450aca
--- /dev/null
+++ b/net-print/gtklp/gtklp-0.9p.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-print/gtklp/gtklp-0.9p.ebuild,v 1.1 2003/10/04 20:11:16 lanius Exp $
+
+inherit libtool
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A GUI for cupsd"
+SRC_URI="mirror://sourceforge/gtklp/${P}.src.tar.gz"
+HOMEPAGE="http://gtklp.sourceforge.net"
+
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+LICENSE="GPL-2"
+
+DEPEND="=x11-libs/gtk+-1.2*
+ >=net-print/cups-1.1.7
+ nls? ( sys-devel/gettext )
+ ssl? ( dev-libs/openssl )"
+
+src_compile() {
+ elibtoolize
+
+ local myconf
+
+ # nls fix
+ sed -i -e "s:#include <cups/language.h>:#ifndef _LOCALE_H\n#define _LOCALE_H\n#endif\n#include <cups/language.h>:" libgtklp/libgtklp.h
+
+ use nls \
+ && myconf="${myconf} --enable-nls" \
+ || myconf="${myconf} --disable-nls"
+
+ use ssl \
+ && myconf="${myconf} --enable-ssl" \
+ || myconf="${myconf} --disable-ssl"
+
+ econf ${myconf} || die "configure failed"
+ emake || die "parallel make failed"
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS COPYING ChangeLog README NEWS TODO KNOWN_BUGS
+
+ use nls || rm -rf ${D}/usr/share/locale
+}