summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <rhill@gentoo.org>2012-03-10 06:00:57 +0000
committerRyan Hill <rhill@gentoo.org>2012-03-10 06:00:57 +0000
commit4cffa5fdfc93b7e2b9720a3eca215a1520c25796 (patch)
tree5781f997ca24d158e73738ff91f46c1bade2b7b1 /net-p2p
parentversion bump (bug #407515) (diff)
downloadhistorical-4cffa5fdfc93b7e2b9720a3eca215a1520c25796.tar.gz
historical-4cffa5fdfc93b7e2b9720a3eca215a1520c25796.tar.bz2
historical-4cffa5fdfc93b7e2b9720a3eca215a1520c25796.zip
Version bump (bug #406725). Add myself to metatdata.xml.
Package-Manager: portage-2.2.0_alpha90/cvs/Linux x86_64
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/vuze-coreplugins/ChangeLog10
-rw-r--r--net-p2p/vuze-coreplugins/metadata.xml4
-rw-r--r--net-p2p/vuze-coreplugins/vuze-coreplugins-4.7.0.2.ebuild67
-rw-r--r--net-p2p/vuze/ChangeLog10
-rw-r--r--net-p2p/vuze/metadata.xml4
-rw-r--r--net-p2p/vuze/vuze-4.7.0.2.ebuild (renamed from net-p2p/vuze/vuze-4.7.0.0.ebuild)12
6 files changed, 97 insertions, 10 deletions
diff --git a/net-p2p/vuze-coreplugins/ChangeLog b/net-p2p/vuze-coreplugins/ChangeLog
index 9ebbac3aa370..d6837fb40d48 100644
--- a/net-p2p/vuze-coreplugins/ChangeLog
+++ b/net-p2p/vuze-coreplugins/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-p2p/vuze-coreplugins
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/vuze-coreplugins/ChangeLog,v 1.38 2011/11/17 23:27:07 caster Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/vuze-coreplugins/ChangeLog,v 1.39 2012/03/10 05:59:46 dirtyepic Exp $
+
+*vuze-coreplugins-4.7.0.2 (10 Mar 2012)
+
+ 10 Mar 2012; Ryan Hill <dirtyepic@gentoo.org>
+ +vuze-coreplugins-4.7.0.2.ebuild, metadata.xml:
+ Version bump (bug #406725). Add myself to metatdata.xml.
*vuze-coreplugins-4.7.0.0 (17 Nov 2011)
diff --git a/net-p2p/vuze-coreplugins/metadata.xml b/net-p2p/vuze-coreplugins/metadata.xml
index 7303cef96964..63574c2755c6 100644
--- a/net-p2p/vuze-coreplugins/metadata.xml
+++ b/net-p2p/vuze-coreplugins/metadata.xml
@@ -2,4 +2,8 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>java</herd>
+ <maintainer>
+ <email>dirtyepic@gentoo.org</email>
+ <name>Ryan Hill</name>
+ </maintainer>
</pkgmetadata>
diff --git a/net-p2p/vuze-coreplugins/vuze-coreplugins-4.7.0.2.ebuild b/net-p2p/vuze-coreplugins/vuze-coreplugins-4.7.0.2.ebuild
new file mode 100644
index 000000000000..be2451a28df0
--- /dev/null
+++ b/net-p2p/vuze-coreplugins/vuze-coreplugins-4.7.0.2.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/vuze-coreplugins/vuze-coreplugins-4.7.0.2.ebuild,v 1.1 2012/03/10 05:59:46 dirtyepic Exp $
+
+# eventually this should be built from source...
+
+EAPI=2
+
+inherit eutils
+
+PLUGINS_N=azplugins
+RATING_N=azrating
+UPDATER_N=azupdater
+UPNPAV_N=azupnpav
+PLUGINS_V=2.1.6
+RATING_V=1.3.1
+UPDATER_V=1.8.17
+UPNPAV_V=0.3.9
+PLUGINS_DIST=${PLUGINS_N}_${PLUGINS_V}.jar
+RATING_DIST=${RATING_N}_${RATING_V}.jar
+UPDATER_DIST=${UPDATER_N}_${UPDATER_V}.zip
+UPNPAV_DIST=${UPNPAV_N}_${UPNPAV_V}.zip
+
+ALLPLUGINS_URL="http://azureus.sourceforge.net/plugins"
+
+DESCRIPTION="Core plugins for Vuze that are included in upstream distribution"
+HOMEPAGE="http://www.vuze.com/"
+SRC_URI="
+ ${ALLPLUGINS_URL}/${PLUGINS_DIST}
+ ${ALLPLUGINS_URL}/${RATING_DIST}
+ ${ALLPLUGINS_URL}/${UPDATER_DIST}
+ ${ALLPLUGINS_URL}/${UPNPAV_DIST}"
+LICENSE="GPL-2 BSD"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND="~net-p2p/vuze-${PV}"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ mkdir -p plugins/{${PLUGINS_N},${RATING_N},${UPDATER_N},${UPNPAV_N}} || die
+ cp "${DISTDIR}/${PLUGINS_DIST}" plugins/${PLUGINS_N} || die
+ cp "${DISTDIR}/${RATING_DIST}" plugins/${RATING_N} || die
+ cd "${WORKDIR}/plugins/${UPDATER_N}" && unpack ${UPDATER_DIST} || die
+ cd "${WORKDIR}/plugins/${UPNPAV_N}" && unpack ${UPNPAV_DIST} || die
+}
+
+src_compile() { :; }
+
+src_install() {
+ insinto /usr/share/vuze/
+ doins -r "${WORKDIR}/plugins"
+}
+
+pkg_postinst() {
+ elog "Since version 4.0.0.2, plugins that are normally bundled by upstream"
+ elog "(and auto-installed in each user's ~/.azureus if not bundled)"
+ elog "are now installed into shared plugin directory by the ebuild."
+ elog "Vuze may warn that shared plugin dir is not writable, that's fine."
+ elog "Users are recommended to delete the following plugin copies:"
+ elog "~/.azureus/plugins/{${PLUGINS_N},${RATING_N},${UPDATER_N},${UPNPAV_N}}"
+}
diff --git a/net-p2p/vuze/ChangeLog b/net-p2p/vuze/ChangeLog
index 257a1ddb955b..3403873f203b 100644
--- a/net-p2p/vuze/ChangeLog
+++ b/net-p2p/vuze/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-p2p/vuze
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/vuze/ChangeLog,v 1.51 2011/12/27 17:04:28 caster Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/vuze/ChangeLog,v 1.52 2012/03/10 06:00:57 dirtyepic Exp $
+
+*vuze-4.7.0.2 (10 Mar 2012)
+
+ 10 Mar 2012; Ryan Hill <dirtyepic@gentoo.org> -vuze-4.7.0.0.ebuild,
+ +vuze-4.7.0.2.ebuild, metadata.xml:
+ Version bump (bug #406725). Add myself to metatdata.xml.
*vuze-4.7.0.0-r1 (27 Dec 2011)
diff --git a/net-p2p/vuze/metadata.xml b/net-p2p/vuze/metadata.xml
index 7303cef96964..63574c2755c6 100644
--- a/net-p2p/vuze/metadata.xml
+++ b/net-p2p/vuze/metadata.xml
@@ -2,4 +2,8 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>java</herd>
+ <maintainer>
+ <email>dirtyepic@gentoo.org</email>
+ <name>Ryan Hill</name>
+ </maintainer>
</pkgmetadata>
diff --git a/net-p2p/vuze/vuze-4.7.0.0.ebuild b/net-p2p/vuze/vuze-4.7.0.2.ebuild
index 03bc10746964..3538b4ddb584 100644
--- a/net-p2p/vuze/vuze-4.7.0.0.ebuild
+++ b/net-p2p/vuze/vuze-4.7.0.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/vuze/vuze-4.7.0.0.ebuild,v 1.1 2011/11/17 23:27:43 caster Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/vuze/vuze-4.7.0.2.ebuild,v 1.1 2012/03/10 06:00:57 dirtyepic Exp $
EAPI=2
@@ -83,7 +83,7 @@ java_prepare() {
}
JAVA_ANT_REWRITE_CLASSPATH="true"
-EANT_GENTOO_CLASSPATH="swt-3.6,bcprov-1.3,json-simple,log4j,commons-cli-1"
+EANT_GENTOO_CLASSPATH="swt-3.7,bcprov-1.3,json-simple,log4j,commons-cli-1"
src_compile() {
local mem
@@ -130,10 +130,10 @@ pkg_postinst() {
elog "Using this config file you can start the console UI."
elog
- if ! has_version dev-java/swt:3.6[xulrunner]; then
+ if ! has_version dev-java/swt:3.7[webkit]; then
elog
- elog "Your dev-java/swt:3.6 was built without xulrunner support. Features such as Vuze HD Network will not work."
- elog "Rebuild swt with USE=xulrunner (needs xulrunner-1.9) to use these features."
+ elog "Your dev-java/swt:3.7 was built without xulrunner support. Features such as Vuze HD Network will not work."
+ elog "Rebuild swt with USE=webkit (needs net-libs/webkit-gtk:2) to use these features."
fi
fdo-mime_desktop_database_update