summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDon Seiler <rizzo@gentoo.org>2004-01-22 02:55:45 +0000
committerDon Seiler <rizzo@gentoo.org>2004-01-22 02:55:45 +0000
commit22a436b86c88386f69c52444ee567366452c0d9d (patch)
tree735c6522f45229d5d9a6be52270e18cb1d2de892 /net-p2p
parentRe-adding from scratch. Thanks Anders Bruun Olsen for submitting. Takes car... (diff)
downloadhistorical-22a436b86c88386f69c52444ee567366452c0d9d.tar.gz
historical-22a436b86c88386f69c52444ee567366452c0d9d.tar.bz2
historical-22a436b86c88386f69c52444ee567366452c0d9d.zip
Re-adding from scratch. Thanks Anders Bruun Olsen for submitting. Takes care of Bug 36112
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/bittorrent-theshadow/Manifest4
-rw-r--r--net-p2p/bittorrent-theshadow/bittorrent-theshadow-5.8.7.ebuild52
-rw-r--r--net-p2p/bittorrent-theshadow/files/digest-bittorrent-theshadow-5.8.71
-rw-r--r--net-p2p/bittorrent-theshadow/metadata.xml11
4 files changed, 67 insertions, 1 deletions
diff --git a/net-p2p/bittorrent-theshadow/Manifest b/net-p2p/bittorrent-theshadow/Manifest
index 61b4fede2763..eb5066f55a94 100644
--- a/net-p2p/bittorrent-theshadow/Manifest
+++ b/net-p2p/bittorrent-theshadow/Manifest
@@ -1,2 +1,4 @@
-MD5 a757804042d13d736a51bdcae3f8ea64 bittorrent-theshadow-5.8.7.ebuild 1449
+MD5 4827e5eb0d6c917ac73d11c91c06bf20 bittorrent-theshadow-5.8.7.ebuild 1453
+MD5 3e1fb0f4bd15ff421c19c9c6e5f324ed ChangeLog 473
+MD5 3c53581479f854cac3dc99747a5b031a metadata.xml 443
MD5 db4a09fef61cd98de535b4148d661d86 files/digest-bittorrent-theshadow-5.8.7 83
diff --git a/net-p2p/bittorrent-theshadow/bittorrent-theshadow-5.8.7.ebuild b/net-p2p/bittorrent-theshadow/bittorrent-theshadow-5.8.7.ebuild
new file mode 100644
index 000000000000..fe50ca886be6
--- /dev/null
+++ b/net-p2p/bittorrent-theshadow/bittorrent-theshadow-5.8.7.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bittorrent-theshadow/bittorrent-theshadow-5.8.7.ebuild,v 1.5 2004/01/22 02:55:38 rizzo Exp $
+
+inherit distutils
+
+DESCRIPTION="TheShad0w's experimental BitTorrent client"
+HOMEPAGE="http://bt.degreez.net/"
+SRC_URI="http://home.elp.rr.com/tur/BitTorrent-experimental-S-${PV}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+
+KEYWORDS="~x86"
+IUSE="X"
+
+RDEPEND="X? ( >=dev-python/wxPython-2.2 )
+ >=dev-lang/python-2.1
+ !virtual/bittorrent"
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4.0.5"
+PROVIDE="virtual/bittorrent"
+
+S="${WORKDIR}/bittorrent-CVS-shadowsclient"
+
+src_install() {
+ distutils_src_install
+
+ if ! use X; then
+ rm ${D}/usr/bin/*gui.py
+ fi
+
+ dodir etc
+ cp -a /etc/mailcap ${D}/etc/
+
+ MAILCAP_STRING="application/x-bittorrent; /usr/bin/btdownloadgui.py '%s'; test=test -n \"\$DISPLAY\""
+
+ if use X; then
+ if [ -n "`grep 'application/x-bittorrent' ${D}/etc/mailcap`" ]; then
+ # replace bittorrent entry if it already exists
+ einfo "updating bittorrent mime info"
+ sed -i "s,application/x-bittorrent;.*,${MAILCAP_STRING}," ${D}/etc/mailcap
+ else
+ # add bittorrent entry if it doesn't exist
+ einfo "adding bittorrent mime info"
+ echo "${MAILCAP_STRING}" >> ${D}/etc/mailcap
+ fi
+ else
+ # get rid of any reference to the not-installed gui version
+ sed -i '/btdownloadgui/d' ${D}/etc/mailcap
+ fi
+}
+
diff --git a/net-p2p/bittorrent-theshadow/files/digest-bittorrent-theshadow-5.8.7 b/net-p2p/bittorrent-theshadow/files/digest-bittorrent-theshadow-5.8.7
new file mode 100644
index 000000000000..302f4b7d5d26
--- /dev/null
+++ b/net-p2p/bittorrent-theshadow/files/digest-bittorrent-theshadow-5.8.7
@@ -0,0 +1 @@
+MD5 6ce8a2ba83e9b10c10a791d9f3ce6aa7 BitTorrent-experimental-S-5.8.7.tar.gz 144887
diff --git a/net-p2p/bittorrent-theshadow/metadata.xml b/net-p2p/bittorrent-theshadow/metadata.xml
new file mode 100644
index 000000000000..cf75d413c9ad
--- /dev/null
+++ b/net-p2p/bittorrent-theshadow/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>net-p2p</herd>
+<maintainer>
+ <email>rizzo@gentoo.org</email>
+ <name>Don Seiler</name>
+ <description>seemant asked to put this back in since it was taken out after the Luke-Jr unpleasantness.</description>
+</maintainer>
+<!-- <longdescription>Long description of the package</longdescription> -->
+</pkgmetadata>