summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRob Cakebread <pythonhead@gentoo.org>2004-08-16 16:57:18 +0000
committerRob Cakebread <pythonhead@gentoo.org>2004-08-16 16:57:18 +0000
commit18b4c220269b57c6c97bf63871a92fa196714a8b (patch)
tree6391a8c7682ba0cc3a62c2b902dfca7a61f86f0a /net-p2p
parentrerefix #60439 (diff)
downloadhistorical-18b4c220269b57c6c97bf63871a92fa196714a8b.tar.gz
historical-18b4c220269b57c6c97bf63871a92fa196714a8b.tar.bz2
historical-18b4c220269b57c6c97bf63871a92fa196714a8b.zip
Modified to use new wxwidgets eclass. Fixes bug# 60529
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/xmule/ChangeLog6
-rw-r--r--net-p2p/xmule/Manifest8
-rw-r--r--net-p2p/xmule/xmule-1.8.2-r3.ebuild27
-rw-r--r--net-p2p/xmule/xmule-1.8.4.ebuild27
4 files changed, 32 insertions, 36 deletions
diff --git a/net-p2p/xmule/ChangeLog b/net-p2p/xmule/ChangeLog
index d1207749d732..42cdda3ff72a 100644
--- a/net-p2p/xmule/ChangeLog
+++ b/net-p2p/xmule/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-p2p/xmule
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/xmule/ChangeLog,v 1.44 2004/08/16 03:27:52 squinky86 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/xmule/ChangeLog,v 1.45 2004/08/16 16:57:18 pythonhead Exp $
+
+ 16 Aug 2004; Rob Cakebread <pythonhead@gentoo.org> xmule-1.8.2-r3.ebuild,
+ xmule-1.8.4.ebuild:
+ Modified to use new wxwidgets eclass. Fixes bug# 60529
15 Aug 2004; Jon Hood <squinky86@gentoo.org> -files/rehash.patch,
-xmule-1.6.0a-r1.ebuild, -xmule-1.8.1.ebuild, xmule-1.8.4.ebuild:
diff --git a/net-p2p/xmule/Manifest b/net-p2p/xmule/Manifest
index 051e842055ef..c4f81d4c57b9 100644
--- a/net-p2p/xmule/Manifest
+++ b/net-p2p/xmule/Manifest
@@ -1,7 +1,7 @@
-MD5 3e30ecc7788769d47d983a42cc0eede6 xmule-1.8.2-r3.ebuild 1599
-MD5 60f55bee7b67c7d23362e711c3933272 xmule-1.8.4.ebuild 1460
-MD5 23f66e46649b06fbce03ec41062ace2b ChangeLog 6063
+MD5 deca455e7175ceeefd29898d598757a9 ChangeLog 6220
MD5 8aefbc0e49db723ca1ad02d0c409cd49 metadata.xml 160
+MD5 0ee034371af2a4fa353ce32cfbefc749 xmule-1.8.4.ebuild 1241
+MD5 f45149d50428ff7ea569b311badbbceb xmule-1.8.2-r3.ebuild 1371
MD5 7af93e9c27cecc95812aaf13b2579dc9 files/digest-xmule-1.8.4 65
-MD5 8b1e8db7ffe51b7a0cebee62f5c116ba files/xmule.sh 567
MD5 975033c3b074bc4843c273182226a745 files/digest-xmule-1.8.2-r3 132
+MD5 8b1e8db7ffe51b7a0cebee62f5c116ba files/xmule.sh 567
diff --git a/net-p2p/xmule/xmule-1.8.2-r3.ebuild b/net-p2p/xmule/xmule-1.8.2-r3.ebuild
index b5654e10b825..498f3fed6eef 100644
--- a/net-p2p/xmule/xmule-1.8.2-r3.ebuild
+++ b/net-p2p/xmule/xmule-1.8.2-r3.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/xmule/xmule-1.8.2-r3.ebuild,v 1.6 2004/07/23 20:31:07 squinky86 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/xmule/xmule-1.8.2-r3.ebuild,v 1.7 2004/08/16 16:57:18 pythonhead Exp $
-inherit eutils
+inherit eutils wxwidgets
MY_P=${P}c
S=${WORKDIR}/${PN}
-DESCRIPTION="wxWindows based client for the eDonkey/eMule/lMule network"
+DESCRIPTION="wxWidgets based client for the eDonkey/eMule/lMule network"
HOMEPAGE="http://xmule.ws/"
SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz
http://dev.gentoo.org/~squinky86/files/${P}-gcc34.patch"
@@ -16,23 +16,12 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86 ~amd64 ~ppc"
-IUSE="nls"
+IUSE="nls gtk2"
-DEPEND=">=x11-libs/wxGTK-2.4.2
+DEPEND=">=x11-libs/wxGTK-2.4.2-r2
nls? ( sys-devel/gettext )
>=sys-libs/zlib-1.2.1"
-pkg_setup() {
- # FIXME: Is this really how we want to do this ?
- GREP=`grep ' unicode' /var/db/pkg/x11-libs/wxGTK*/USE`
- if [ "${GREP}" != "" ]; then
- eerror "This package doesn't work with wxGTK"
- eerror "compiled with gtk2 and unicode in USE"
- eerror "Please re-compile wxGTK with -unicode"
- die "aborting..."
- fi
-}
-
src_unpack() {
unpack ${A}
cd ${S}
@@ -43,6 +32,12 @@ src_unpack() {
src_compile () {
local myconf=
+ if ! use gtk2 ; then
+ need-wxwidgets gtk
+ else
+ need-wxwidgets gtk2
+ fi
+
use nls \
|| myconf="${myconf} --disable-nls"
diff --git a/net-p2p/xmule/xmule-1.8.4.ebuild b/net-p2p/xmule/xmule-1.8.4.ebuild
index c1a50c61873d..994aa089c668 100644
--- a/net-p2p/xmule/xmule-1.8.4.ebuild
+++ b/net-p2p/xmule/xmule-1.8.4.ebuild
@@ -1,8 +1,10 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/xmule/xmule-1.8.4.ebuild,v 1.2 2004/08/16 03:27:53 squinky86 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/xmule/xmule-1.8.4.ebuild,v 1.3 2004/08/16 16:57:18 pythonhead Exp $
-DESCRIPTION="wxWindows based client for the eDonkey/eMule/lMule network"
+inherit wxwidgets
+
+DESCRIPTION="wxWidgets based client for the eDonkey/eMule/lMule network"
HOMEPAGE="http://xmule.ws/"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
@@ -10,23 +12,12 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86 ~amd64 ~ppc"
-IUSE="nls"
+IUSE="nls gtk2"
-DEPEND=">=x11-libs/wxGTK-2.4.2
+DEPEND=">=x11-libs/wxGTK-2.4.2-r2
nls? ( sys-devel/gettext )
>=sys-libs/zlib-1.2.1"
-pkg_setup() {
- # FIXME: Is this really how we want to do this ?
- GREP=`grep ' unicode' /var/db/pkg/x11-libs/wxGTK*/USE`
- if [ "${GREP}" != "" ]; then
- eerror "This package doesn't work with wxGTK"
- eerror "compiled with gtk2 and unicode in USE"
- eerror "Please re-compile wxGTK with -unicode"
- die "aborting..."
- fi
-}
-
src_unpack() {
unpack ${A}
cd ${S}
@@ -36,6 +27,12 @@ src_unpack() {
src_compile () {
local myconf=
+ if ! use gtk2 ; then
+ need-wxwidgets gtk
+ else
+ need-wxwidgets gtk2
+ fi
+
use nls \
|| myconf="${myconf} --disable-nls"