summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2003-03-28 23:34:59 +0000
committerAlastair Tse <liquidx@gentoo.org>2003-03-28 23:34:59 +0000
commitcdd1427c08ca559ea7940452f1f2bd44769ecc86 (patch)
tree51309cd8e4225ed158a85b0451811cb514c2325b /net-p2p/pysoulseek
parentAdded hppa to KEYWORDS. (diff)
downloadhistorical-cdd1427c08ca559ea7940452f1f2bd44769ecc86.tar.gz
historical-cdd1427c08ca559ea7940452f1f2bd44769ecc86.tar.bz2
historical-cdd1427c08ca559ea7940452f1f2bd44769ecc86.zip
version bump
Diffstat (limited to 'net-p2p/pysoulseek')
-rw-r--r--net-p2p/pysoulseek/ChangeLog7
-rw-r--r--net-p2p/pysoulseek/files/digest-pysoulseek-1.0.4.132
-rw-r--r--net-p2p/pysoulseek/pysoulseek-1.0.4.13.ebuild37
3 files changed, 45 insertions, 1 deletions
diff --git a/net-p2p/pysoulseek/ChangeLog b/net-p2p/pysoulseek/ChangeLog
index 683a6b1c27f9..471e2e5e65e6 100644
--- a/net-p2p/pysoulseek/ChangeLog
+++ b/net-p2p/pysoulseek/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-p2p/pysoulseek
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/pysoulseek/ChangeLog,v 1.13 2003/03/26 01:45:33 liquidx Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/pysoulseek/ChangeLog,v 1.14 2003/03/28 23:34:59 liquidx Exp $
+
+*pysoulseek-1.0.4.13 (28 Mar 2003)
+
+ 28 Mar 2003; Alastair Tse <liquidx@gentoo.org> pysoulseek-1.0.4.13.ebuild:
+ version bump, more robust version checking, uses distutils now
*pysoulseek-1.0.3.12.7 (24 Mar 2003)
diff --git a/net-p2p/pysoulseek/files/digest-pysoulseek-1.0.4.13 b/net-p2p/pysoulseek/files/digest-pysoulseek-1.0.4.13
new file mode 100644
index 000000000000..0022334df41f
--- /dev/null
+++ b/net-p2p/pysoulseek/files/digest-pysoulseek-1.0.4.13
@@ -0,0 +1,2 @@
+MD5 6ffee23b618a04152718ba43f4cf90a2 pyslsk-1.0.4.tar.gz 92802
+MD5 53b6de78551388d2b08cbd545d3d8f92 pyslsk-1.0.4-hyriand-13.patch 60748
diff --git a/net-p2p/pysoulseek/pysoulseek-1.0.4.13.ebuild b/net-p2p/pysoulseek/pysoulseek-1.0.4.13.ebuild
new file mode 100644
index 000000000000..d4daddf204a8
--- /dev/null
+++ b/net-p2p/pysoulseek/pysoulseek-1.0.4.13.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/pysoulseek/pysoulseek-1.0.4.13.ebuild,v 1.1 2003/03/28 23:34:59 liquidx Exp $
+
+IUSE="oggvorbis"
+
+inherit eutils distutils
+
+MY_PN="${PN/soulseek/slsk}"
+
+# Hyriand Patch Version (skip first 3 version numbers)
+MY_HV=${PV#*.*.*.}
+# Main pysoulseek Package-Version (remove trailing MY_HV)
+MY_P=${MY_PN}-${PV%.${MY_HV}}
+
+DESCRIPTION="client for SoulSeek filesharing"
+HOMEPAGE="http://www.sensi.org/~ak/pyslsk/ http://thegraveyard.org/pyslsk/index-1.0.0.html"
+SRC_URI="http://www.sensi.org/~ak/pyslsk/${MY_P}.tar.gz
+ http://thegraveyard.org/pyslsk/${MY_P}-hyriand-${MY_HV}.patch"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc"
+
+DEPEND=">=dev-lang/python-2.1
+ >=dev-python/wxPython-2.4.0.1
+ ~x11-libs/wxGTK-2.4.0
+ oggvorbis? ( media-libs/pyvorbis media-libs/pyogg )"
+
+RDEPEND=${DEPEND}
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${MY_P}.tar.gz
+ epatch ${DISTDIR}/${MY_P}-hyriand-${MY_HV}.patch
+}