summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Hood <squinky86@gentoo.org>2004-06-29 01:51:38 +0000
committerJon Hood <squinky86@gentoo.org>2004-06-29 01:51:38 +0000
commit576b6b47a3e83ca91832124775c65977ea026030 (patch)
tree03e4f7d482833516e7e9b5e0d77a239c5a185373 /net-p2p/gnunet
parentversion bump (diff)
downloadhistorical-576b6b47a3e83ca91832124775c65977ea026030.tar.gz
historical-576b6b47a3e83ca91832124775c65977ea026030.tar.bz2
historical-576b6b47a3e83ca91832124775c65977ea026030.zip
fix rc script
Diffstat (limited to 'net-p2p/gnunet')
-rw-r--r--net-p2p/gnunet/Manifest4
-rw-r--r--net-p2p/gnunet/files/gnunet19
-rw-r--r--net-p2p/gnunet/gnunet-0.6.2b.ebuild4
3 files changed, 16 insertions, 11 deletions
diff --git a/net-p2p/gnunet/Manifest b/net-p2p/gnunet/Manifest
index 95841bed7432..2a87c63cf03e 100644
--- a/net-p2p/gnunet/Manifest
+++ b/net-p2p/gnunet/Manifest
@@ -1,10 +1,10 @@
-MD5 d8547873fbd49ad45897ca40132f3bc3 gnunet-0.6.2b.ebuild 1565
+MD5 71ebce7bfa11f5deebed8212b5308833 gnunet-0.6.2b.ebuild 1612
MD5 4f9226f4408ff37f868a8367513e9c56 gnunet-0.5.4-r1.ebuild 1260
MD5 500fc294171beffbf73777ef1454bea9 gnunet-0.6.2a.ebuild 1466
MD5 3632610cc93f576326a8d3e36236c32a ChangeLog 4285
MD5 8aefbc0e49db723ca1ad02d0c409cd49 metadata.xml 160
MD5 974a5b99dd02348e2111e88749e1e580 files/digest-gnunet-0.6.2a 67
MD5 d4a748c8e3536c6691b63794f7c17639 files/digest-gnunet-0.6.2b 66
-MD5 d628356df7b12ee797cbd14ac6918610 files/gnunet 947
+MD5 5b8909be0006d37ce3aeb2465b8e8e6b files/gnunet 813
MD5 12b0bdd38d4a838fcc6d4e8b970870f5 files/digest-gnunet-0.5.4-r1 65
MD5 7e0bb86547b0ad5e7744374d32c124f8 files/gnunet-download-manager.scm 13338
diff --git a/net-p2p/gnunet/files/gnunet b/net-p2p/gnunet/files/gnunet
index e6302a25f997..6e071441c347 100644
--- a/net-p2p/gnunet/files/gnunet
+++ b/net-p2p/gnunet/files/gnunet
@@ -11,18 +11,21 @@ depend() {
}
start() {
- ebegin "Starting gnunetd"
+ ebegin "Starting GNUnet"
# -u username, -c path to gnunet.conf file
start-stop-daemon --start --quiet --background --exec /usr/bin/gnunetd \
-- -u gnunet -c /var/lib/GNUnet/gnunet.conf
- eend $? "Failed to start gnunetd"
+ eend $? "Failed to start GNUnet"
}
stop() {
- ebegin "Stopping gnunetd"
- # pointing file descriptors to /dev/null, because start-stop-daemon
- # prints warnings that it cannot kill process forks,
- # but they are already dead
- start-stop-daemon --stop --quiet --user gnunet &>/dev/null
- eend $? "Failed to stop gnunetd"
+ ebegin "Stopping GNUnet"
+ killall gnunetd
+ eend $? "Failed to stop GNUnet"
+}
+
+restart() {
+ svc_stop
+ sleep 3
+ svc_start
}
diff --git a/net-p2p/gnunet/gnunet-0.6.2b.ebuild b/net-p2p/gnunet/gnunet-0.6.2b.ebuild
index 5722ac9181d6..5b3f3bf95875 100644
--- a/net-p2p/gnunet/gnunet-0.6.2b.ebuild
+++ b/net-p2p/gnunet/gnunet-0.6.2b.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/gnunet/gnunet-0.6.2b.ebuild,v 1.1 2004/06/29 01:25:10 squinky86 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/gnunet/gnunet-0.6.2b.ebuild,v 1.2 2004/06/29 01:51:38 squinky86 Exp $
inherit libtool
@@ -58,6 +58,8 @@ src_install() {
newins contrib/gnunet.root gnunet.conf
docinto contrib
dodoc contrib/*
+ exeinto /etc/init.d
+ doexe ${FILESDIR}/gnunet
}
pkg_postinst() {