summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2007-02-22 20:19:53 +0000
committerSven Wegener <swegener@gentoo.org>2007-02-22 20:19:53 +0000
commitd34d2b282bed39fdaac3cbcda8fa43cf50bc2272 (patch)
tree00292b6c4c6a77781e741bd2e825198078a532f7 /net-nntp/pan/pan-0.125.ebuild
parentManifest2 fix. (diff)
downloadhistorical-d34d2b282bed39fdaac3cbcda8fa43cf50bc2272.tar.gz
historical-d34d2b282bed39fdaac3cbcda8fa43cf50bc2272.tar.bz2
historical-d34d2b282bed39fdaac3cbcda8fa43cf50bc2272.zip
Version bump.
Package-Manager: portage-2.1.2-r9
Diffstat (limited to 'net-nntp/pan/pan-0.125.ebuild')
-rw-r--r--net-nntp/pan/pan-0.125.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/net-nntp/pan/pan-0.125.ebuild b/net-nntp/pan/pan-0.125.ebuild
new file mode 100644
index 000000000000..10c3fbab1135
--- /dev/null
+++ b/net-nntp/pan/pan-0.125.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-nntp/pan/pan-0.125.ebuild,v 1.1 2007/02/22 20:19:53 swegener Exp $
+
+inherit eutils
+
+DESCRIPTION="A newsreader for the Gnome2 desktop"
+HOMEPAGE="http://pan.rebelbase.com/"
+SRC_URI="http://pan.rebelbase.com/download/releases/${PV}/source/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="spell"
+
+RDEPEND=">=dev-libs/glib-2.4.0
+ >=x11-libs/gtk+-2.4.0
+ >=dev-libs/libpcre-5.0
+ >=dev-libs/gmime-2.1.0
+ spell? ( >=app-text/gtkspell-2.0.7 )"
+
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.21
+ dev-util/pkgconfig
+ sys-devel/gettext"
+
+src_compile() {
+ econf $(use_with spell gtkspell) || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die "make install failed"
+ dodoc AUTHORS ChangeLog NEWS README TODO || die "dodoc failed"
+}