summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-07-18 23:26:51 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-07-18 23:26:51 +0000
commit8a974089e00ada886085579a0b26ace1526bd00a (patch)
treea4b564930bff3c66cdcc5e9d807b0e5807a32111 /net-nds
parentrepoman'd (diff)
downloadhistorical-8a974089e00ada886085579a0b26ace1526bd00a.tar.gz
historical-8a974089e00ada886085579a0b26ace1526bd00a.tar.bz2
historical-8a974089e00ada886085579a0b26ace1526bd00a.zip
nls fixes
Diffstat (limited to 'net-nds')
-rw-r--r--net-nds/yp-tools/ChangeLog9
-rw-r--r--net-nds/yp-tools/files/digest-yp-tools-2.7-r11
-rw-r--r--net-nds/yp-tools/yp-tools-2.7-r1.ebuild43
3 files changed, 52 insertions, 1 deletions
diff --git a/net-nds/yp-tools/ChangeLog b/net-nds/yp-tools/ChangeLog
index 5f12c9704a90..99b58efa2cfc 100644
--- a/net-nds/yp-tools/ChangeLog
+++ b/net-nds/yp-tools/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-nds/yp-tools
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-nds/yp-tools/ChangeLog,v 1.4 2002/05/28 00:15:35 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-nds/yp-tools/ChangeLog,v 1.5 2002/07/18 23:26:51 seemant Exp $
+
+*yp-tools-2.7-r1 (18 Jul 2002)
+
+ 18 Jul 2002; Seemant Kulleen <seemant@gentoo.orG> yp-tools-2.7-r1.ebuild
+ files/digest-yp-tools-2.7-r1 :
+
+ NLS fixes.
*yp-tools-2.7 (27 May 2002)
diff --git a/net-nds/yp-tools/files/digest-yp-tools-2.7-r1 b/net-nds/yp-tools/files/digest-yp-tools-2.7-r1
new file mode 100644
index 000000000000..c0890568710e
--- /dev/null
+++ b/net-nds/yp-tools/files/digest-yp-tools-2.7-r1
@@ -0,0 +1 @@
+MD5 8d8d2c1c8b4a7e2027215aebe086f651 yp-tools-2.7.tar.bz2 153742
diff --git a/net-nds/yp-tools/yp-tools-2.7-r1.ebuild b/net-nds/yp-tools/yp-tools-2.7-r1.ebuild
new file mode 100644
index 000000000000..bd8e6bc03972
--- /dev/null
+++ b/net-nds/yp-tools/yp-tools-2.7-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-nds/yp-tools/yp-tools-2.7-r1.ebuild,v 1.1 2002/07/18 23:26:51 seemant Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="NIS Tools"
+SRC_URI="ftp://ftp.kernel.org/pub/linux/utils/net/NIS/${P}.tar.bz2"
+HOMEPAGE="http://www.linux-nis.org/nis"
+
+DEPEND="virtual/glibc"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86"
+
+src_compile() {
+ local myconf="--sysconfdir=/etc/yp"
+ use nls || ( \
+ myconf="${myconf} --disable-nls"
+ mkdir intl
+ touch intl/libintl.h
+ export CPPFLAGS="${CPPFLAGS} -I${S}"
+
+ for i in lib/nicknames.c src/*.c
+ do
+ cp ${i} ${i}.orig
+ sed 's:<libintl.h>:<intl/libintl.h>:' \
+ ${i}.orig > ${i}
+ done
+ )
+ econf ${myconf} || die
+ make || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS ChangeLog COPYING NEWS README THANKS TODO
+ insinto /etc/yp ; doins etc/nicknames
+ # This messes up boot so we remove it
+ rm -d ${D}/bin/ypdomainname
+ rm -d ${D}/bin/nisdomainname
+ rm -d ${D}/bin/domainname
+}