summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Hadaway <raker@gentoo.org>2002-11-26 03:33:01 +0000
committerNick Hadaway <raker@gentoo.org>2002-11-26 03:33:01 +0000
commit44450a3fd1313199659285d2065b217fa6bb6789 (patch)
treeb362c09e3ee4f60b340be03e987074cbd2825793 /net-nds
parentAdded missing odbc use variable (diff)
downloadhistorical-44450a3fd1313199659285d2065b217fa6bb6789.tar.gz
historical-44450a3fd1313199659285d2065b217fa6bb6789.tar.bz2
historical-44450a3fd1313199659285d2065b217fa6bb6789.zip
Updated stable ebuild of openldap.
Diffstat (limited to 'net-nds')
-rw-r--r--net-nds/openldap/files/digest-openldap-2.0.271
-rw-r--r--net-nds/openldap/openldap-2.0.27.ebuild97
2 files changed, 98 insertions, 0 deletions
diff --git a/net-nds/openldap/files/digest-openldap-2.0.27 b/net-nds/openldap/files/digest-openldap-2.0.27
new file mode 100644
index 000000000000..06cad419992d
--- /dev/null
+++ b/net-nds/openldap/files/digest-openldap-2.0.27
@@ -0,0 +1 @@
+MD5 a1e6508c471dd47205a3492cf57110a6 openldap-2.0.27.tgz 1305050
diff --git a/net-nds/openldap/openldap-2.0.27.ebuild b/net-nds/openldap/openldap-2.0.27.ebuild
new file mode 100644
index 000000000000..f20051f8a0bc
--- /dev/null
+++ b/net-nds/openldap/openldap-2.0.27.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-nds/openldap/openldap-2.0.27.ebuild,v 1.1 2002/11/26 03:33:01 raker Exp $
+
+IUSE="ssl tcpd readline ipv6 gdbm ldap kerberos odbc"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="LDAP suite of application and development tools"
+SRC_URI="ftp://ftp.OpenLDAP.org/pub/OpenLDAP/openldap-release/${P}.tgz"
+HOMEPAGE="http://www.OpenLDAP.org/"
+
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+LICENSE="OPENLDAP"
+
+DEPEND="virtual/glibc
+ >=sys-libs/ncurses-5.1
+ >=sys-libs/readline-4.2a
+ >=sys-libs/db-4.0.14
+ tcpd? ( >=sys-apps/tcp-wrappers-7.6 )
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ readline? ( >=sys-libs/readline-4.1 )
+ gdbm? ( >=sys-libs/gdbm-1.8.0 )
+ kerberos? ( >=app-crypt/krb5-1.2.6 )
+ odbc? ( >=dev-db/unixODBC )"
+
+RDEPEND="virtual/glibc
+ >=sys-libs/ncurses-5.1
+ gdbm? ( >=sys-libs/gdbm-1.8.0 )"
+
+src_compile() {
+ local myconf
+
+ if [ -n "$DEBUG" ]; then
+ myconf="--enable-debug"
+ else
+ myconf="--disable-debug"
+ fi
+
+ use kerberos \
+ && myconf="${myconf} --with-kerberos --enable-kpasswd" \
+ || myconf="${myconf} --without-kerberos --disable-kpasswd"
+
+ use readline \
+ && myconf="${myconf} --with-readline" \
+ || myconf="${myconf} --without-readline"
+
+ use ssl \
+ && myconf="${myconf} --with-tls" \
+ || myconf="${myconf} --without-tls"
+
+ use tcpd \
+ && myconf="${myconf} --enable-wrappers" \
+ || myconf="${myconf} --disable-wrappers"
+
+ use ipv6 && myconf="${myconf} --enable-ipv6" \
+ || myconf="${myconf} --disable-ipv6"
+
+ use odbc && myconf="${myconf} --enable-sql" \
+ || myconf="${myconf} --disable-sql"
+
+ econf \
+ --libexecdir=/usr/lib/openldap \
+ --enable-crypt \
+ --enable-modules \
+ --enable-phonetic \
+ --enable-dynamic \
+ --enable-ldap \
+ --disable-sasl \
+ --disable-spasswd \
+ --enable-passwd \
+ --enable-shell \
+ --enable-slurpd \
+ --enable-ldbm \
+ --with-ldbm-api=auto \
+ ${myconf} || die "configure failed"
+
+ make depend || die "make depend failed"
+
+ make || die "make failed"
+
+ cd tests ; make || die "make tests failed"
+
+}
+
+src_install() {
+
+ make DESTDIR=${D} install || die "make install failed"
+
+ dodoc ANNOUNCEMENT CHANGES COPYRIGHT README LICENSE
+ docinto rfc ; dodoc doc/rfc/*.txt
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/slapd.rc6 slapd
+ newexe ${FILESDIR}/slurpd.rc6 slurpd
+
+}