summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2011-06-17 03:12:18 +0000
committerJeroen Roovers <jer@gentoo.org>2011-06-17 03:12:18 +0000
commit4b2d98d3a03b1d31c31a62db5946c347ed5a7f5d (patch)
treee59c1c7a6be81cf8f6b16609b81ef816f7000b32 /net-nds/ypbind
parentGenerate the man pages rather than relying on docbook. (diff)
downloadhistorical-4b2d98d3a03b1d31c31a62db5946c347ed5a7f5d.tar.gz
historical-4b2d98d3a03b1d31c31a62db5946c347ed5a7f5d.tar.bz2
historical-4b2d98d3a03b1d31c31a62db5946c347ed5a7f5d.zip
Version bump.
Package-Manager: portage-2.2.0_alpha41/cvs/Linux x86_64
Diffstat (limited to 'net-nds/ypbind')
-rw-r--r--net-nds/ypbind/ChangeLog7
-rw-r--r--net-nds/ypbind/ypbind-1.33.ebuild59
2 files changed, 65 insertions, 1 deletions
diff --git a/net-nds/ypbind/ChangeLog b/net-nds/ypbind/ChangeLog
index b90a7646e262..00437710d867 100644
--- a/net-nds/ypbind/ChangeLog
+++ b/net-nds/ypbind/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-nds/ypbind
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-nds/ypbind/ChangeLog,v 1.67 2011/05/20 19:17:57 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-nds/ypbind/ChangeLog,v 1.68 2011/06/17 03:12:18 jer Exp $
+
+*ypbind-1.33 (17 Jun 2011)
+
+ 17 Jun 2011; Jeroen Roovers <jer@gentoo.org> +ypbind-1.33.ebuild:
+ Version bump.
20 May 2011; Kacper Kowalik <xarthisius@gentoo.org> -ypbind-1.31.ebuild:
Drop old
diff --git a/net-nds/ypbind/ypbind-1.33.ebuild b/net-nds/ypbind/ypbind-1.33.ebuild
new file mode 100644
index 000000000000..b19922348cca
--- /dev/null
+++ b/net-nds/ypbind/ypbind-1.33.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-nds/ypbind/ypbind-1.33.ebuild,v 1.1 2011/06/17 03:12:18 jer Exp $
+
+EAPI="2"
+
+inherit eutils
+
+MY_P=${PN}-mt-${PV}
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="Multithreaded NIS bind service (ypbind-mt)"
+HOMEPAGE="http://www.linux-nis.org/nis/ypbind-mt/index.html"
+SRC_URI="ftp://ftp.kernel.org/pub/linux/utils/net/NIS/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug dbus nls slp"
+
+RDEPEND="
+ net-nds/yp-tools
+ debug? ( dev-libs/dmalloc )
+ dbus? ( dev-libs/dbus-glib )
+ slp? ( net-libs/openslp )
+ || ( net-nds/portmap net-nds/rpcbind )"
+DEPEND="
+ ${RDEPEND}
+ nls? ( sys-devel/gettext )
+"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-1.31-man-port.patch" # bug #77810
+}
+
+src_configure() {
+ econf \
+ $(use_enable nls) $(use_enable slp) \
+ $(use_with debug dmalloc) $(use_enable dbus dbus-nm)
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+
+ dodoc AUTHORS ChangeLog README THANKS TODO
+
+ insinto /etc
+ newins etc/yp.conf yp.conf.example
+
+ newconfd "${FILESDIR}/ypbind.confd-r1" ypbind
+ newinitd "${FILESDIR}/ypbind.initd" ypbind
+}
+
+pkg_postinst() {
+ einfo "To complete setup, you will need to edit /etc/conf.d/ypbind."
+ einfo "If you are using dhcpcd, be sure to add the -Y option to"
+ einfo "dhcpcd_eth0 (or eth1, etc.) to keep dhcpcd from clobbering"
+ einfo "/etc/yp.conf."
+}