summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2000-09-21 04:23:27 +0000
committerAchim Gottinger <achim@gentoo.org>2000-09-21 04:23:27 +0000
commit8093be4652eeb9982d3bb0025455a43cd13fb00e (patch)
tree17d66b5f76da465cc254656fbabd794b10621806 /net-nds/openldap
parent*** empty log message *** (diff)
downloadhistorical-8093be4652eeb9982d3bb0025455a43cd13fb00e.tar.gz
historical-8093be4652eeb9982d3bb0025455a43cd13fb00e.tar.bz2
historical-8093be4652eeb9982d3bb0025455a43cd13fb00e.zip
*** empty log message ***
Diffstat (limited to 'net-nds/openldap')
-rw-r--r--net-nds/openldap/openldap-1.2.11-r1.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/net-nds/openldap/openldap-1.2.11-r1.ebuild b/net-nds/openldap/openldap-1.2.11-r1.ebuild
new file mode 100644
index 000000000000..78e69a086c47
--- /dev/null
+++ b/net-nds/openldap/openldap-1.2.11-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-nds/openldap/openldap-1.2.11-r1.ebuild,v 1.4 2000/09/21 04:23:27 achim Exp $
+
+P=openldap-1.2.11
+A=${P}.tgz
+S=${WORKDIR}/${P}
+DESCRIPTION="LDAP suite of application and development tools"
+SRC_URI="ftp://ftp.OpenLDAP.org/pub/OpenLDAP/openldap-release/"${A}
+HOMEPAGE="http://www.OpenLDAP.org/"
+
+src_compile() {
+ cd ${S}
+ ./configure --host=${CHOST} --enable-wrappers --enable-passwd \
+ --enable-shell --enable-shared --enable-static \
+ --prefix=/usr --sysconfdir=/etc --localstatedir=/var/state
+ make depend
+ make
+ cd tests
+ make
+}
+
+src_install() {
+ cd ${S}
+ make prefix=${D}/usr sysconfdir=${D}/etc/openldap localstatedir=${D}/var/state install
+ prepman
+
+ dodoc ANNOUNCEMENT CHANGES COPYRIGHT README LICENSE
+ docinto rfc
+ dodoc doc/rfc/*.txt
+ docinto devel
+ dodoc doc/devel/*
+
+ dodir /etc/rc.d/init.d
+ cp ${O}/files/slapd ${D}/etc/rc.d/init.d
+ cp ${O}/files/slurpd ${D}/etc/rc.d/init.d
+
+ cd ${D}/etc/openldap
+
+ for i in *
+ do
+ cp $i $i.orig
+ sed -e "s:${D}::" $i.orig > $i
+ rm $i.orig
+ done
+}
+
+
+
+
+