summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2003-09-01 12:26:35 +0000
committerMamoru Komachi <usata@gentoo.org>2003-09-01 12:26:35 +0000
commitfee6e0512f6eaa695c909771f2ac9cd55a965ec6 (patch)
treee5a6cde3cdc188287c1fb3bdb8b5b58abd9342f3 /net-misc
parentnew ebuild (diff)
downloadhistorical-fee6e0512f6eaa695c909771f2ac9cd55a965ec6.tar.gz
historical-fee6e0512f6eaa695c909771f2ac9cd55a965ec6.tar.bz2
historical-fee6e0512f6eaa695c909771f2ac9cd55a965ec6.zip
new ebuild
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/ndtpd/Manifest5
-rw-r--r--net-misc/ndtpd/files/digest-ndtpd-3.1.51
-rw-r--r--net-misc/ndtpd/files/ndtpd.initd30
-rw-r--r--net-misc/ndtpd/ndtpd-3.1.5.ebuild64
4 files changed, 98 insertions, 2 deletions
diff --git a/net-misc/ndtpd/Manifest b/net-misc/ndtpd/Manifest
index 9a7f4f3028bd..9e5242626361 100644
--- a/net-misc/ndtpd/Manifest
+++ b/net-misc/ndtpd/Manifest
@@ -1,3 +1,4 @@
-MD5 e49a490451384eded60241170914bebc ndtpd-3.1.5.ebuild 1430
-MD5 fa24ad84fecba69ce647c3f8d98234d1 files/ndtpd.initd 586
+MD5 6d6e942c1c37795d9e2b6d684d330105 ndtpd-3.1.5.ebuild 1525
+MD5 ba4c2b2355d6f7d6dd875d507baf98c1 ChangeLog 390
+MD5 5c6f54ce028093ee75384ec41ae5e8a3 files/ndtpd.initd 680
MD5 c50d3bad7e4228c971eeb2507f0de06f files/digest-ndtpd-3.1.5 63
diff --git a/net-misc/ndtpd/files/digest-ndtpd-3.1.5 b/net-misc/ndtpd/files/digest-ndtpd-3.1.5
new file mode 100644
index 000000000000..bc7acb0eb4fa
--- /dev/null
+++ b/net-misc/ndtpd/files/digest-ndtpd-3.1.5
@@ -0,0 +1 @@
+MD5 ccfd4f2f539802b1abe6d922e7cfa374 ndtpd-3.1.5.tar.gz 558367
diff --git a/net-misc/ndtpd/files/ndtpd.initd b/net-misc/ndtpd/files/ndtpd.initd
new file mode 100644
index 000000000000..2785f2aa2e8e
--- /dev/null
+++ b/net-misc/ndtpd/files/ndtpd.initd
@@ -0,0 +1,30 @@
+#!/sbin/runscript
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-misc/ndtpd/files/ndtpd.initd,v 1.1 2003/09/01 12:26:25 usata Exp $
+
+opts="${opts} reload"
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting NDTPD"
+ start-stop-daemon --start --quiet --exec /usr/sbin/ndtpd
+ result=$?
+ eend $result
+}
+
+stop() {
+ ebegin "Stopping NDTPD"
+ start-stop-daemon --start --quiet --exec /usr/sbin/ndtpcontrol terminate
+ result=$?
+ eend $result
+}
+
+reload() {
+ ebegin "Reloading NDTPD"
+ start-stop-daemon --start --quiet --exec /usr/sbin/ndtpcontrol restart
+ eend $result
+}
diff --git a/net-misc/ndtpd/ndtpd-3.1.5.ebuild b/net-misc/ndtpd/ndtpd-3.1.5.ebuild
new file mode 100644
index 000000000000..cbc3f1f0efb8
--- /dev/null
+++ b/net-misc/ndtpd/ndtpd-3.1.5.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/ndtpd/ndtpd-3.1.5.ebuild,v 1.1 2003/09/01 12:26:25 usata Exp $
+
+inherit eutils
+
+IUSE=""
+
+DESCRIPTION="A server for accessing CD-ROM books with NDTP(Network Directory Transfer Protocol)"
+HOMEPAGE="http://www.sra.co.jp/people/m-kasahr/ndtpd/"
+SRC_URI="ftp://ftp.sra.co.jp/pub/net/ndtp/ndtpd/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND=">=dev-libs/eb-3
+ >=sys-libs/zlib-1.1.3-r2"
+
+S="${WORKDIR}/${P}"
+
+src_compile() {
+
+ econf --with-eb-conf=/etc/eb.conf || die
+ emake || die
+}
+
+src_install() {
+
+ einstall || die
+
+ # getent doesn't exist on FreeBSD system
+ if ! $(cut -d':' -f3 /etc/group | grep 2010 >/dev/null 2>&1) ; then
+ enewgroup ndtpgrp 2010
+ else
+ enewgroup ndtpgrp
+ fi
+
+ if ! $(cut -d':' -f3 /etc/passwd | grep 2010 >/dev/null 2>&1) ; then
+ enewuser ndtpuser 2010 /bin/false /usr/share/dict ndtpgrp
+ else
+ enewuser ndtpuser -1 /bin/false /usr/share/dict ndtpgrp
+ fi
+
+ if ! $(grep 2010/tcp /etc/services >/dev/null 2>&1) ; then
+ cp /etc/services ${T}/services
+ cat >>${T}/services<<-EOF
+ ndtp 2010/tcp # Network Dictionary Transfer Protocol
+ EOF
+ doins ${T}/services
+ fi
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/ndtpd.initd ndtpd
+
+ insinto /etc
+ newins ndtpd.conf{.sample,}
+
+ keepdir /var/lib/ndtpd
+ fowners ndtpuser.ndtpgrp /var/lib/ndtpd
+ fperms 4710 /var/lib/ndtpd
+
+ dodoc AUTHORS ChangeLog* INSTALL* NEWS README* UPGRADE*
+}