summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJim Ramsay <lack@gentoo.org>2008-09-29 14:16:45 +0000
committerJim Ramsay <lack@gentoo.org>2008-09-29 14:16:45 +0000
commitcd553af5a3828ed19710ff4201ddeb4266ff57a2 (patch)
tree415346e44c96620367e193c6c66646d846078d83 /net-misc
parentVersion bump. (diff)
downloadhistorical-cd553af5a3828ed19710ff4201ddeb4266ff57a2.tar.gz
historical-cd553af5a3828ed19710ff4201ddeb4266ff57a2.tar.bz2
historical-cd553af5a3828ed19710ff4201ddeb4266ff57a2.zip
Adding library compatibility package for net-misc/amazonmp3
Package-Manager: portage-2.2_rc8/cvs/Linux 2.6.26-gentoo-r1 i686
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/amazonmp3-libcompat/ChangeLog10
-rw-r--r--net-misc/amazonmp3-libcompat/Manifest5
-rw-r--r--net-misc/amazonmp3-libcompat/amazonmp3-libcompat-0.1.ebuild71
-rw-r--r--net-misc/amazonmp3-libcompat/metadata.xml9
-rw-r--r--net-misc/amazonmp3/Manifest4
5 files changed, 97 insertions, 2 deletions
diff --git a/net-misc/amazonmp3-libcompat/ChangeLog b/net-misc/amazonmp3-libcompat/ChangeLog
new file mode 100644
index 000000000000..e062996633f0
--- /dev/null
+++ b/net-misc/amazonmp3-libcompat/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for net-misc/amazonmp3-libcompat
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/amazonmp3-libcompat/ChangeLog,v 1.1 2008/09/29 14:16:45 lack Exp $
+
+*amazonmp3-libcompat-0.1 (29 Sep 2008)
+
+ 29 Sep 2008; Jim Ramsay <lack@gentoo.org> +metadata.xml,
+ +amazonmp3-libcompat-0.1.ebuild:
+ Adding library compatibility package for net-misc/amazonmp3
+
diff --git a/net-misc/amazonmp3-libcompat/Manifest b/net-misc/amazonmp3-libcompat/Manifest
new file mode 100644
index 000000000000..c89463d14d9e
--- /dev/null
+++ b/net-misc/amazonmp3-libcompat/Manifest
@@ -0,0 +1,5 @@
+DIST amazonmp3-boost-1.34.1-7.fc8.i386.tar.bz2 66991 RMD160 262052b231762a2829f1f1a12af7498f9f101afb SHA1 199d58682db0de48fffe4c94cf827058d0d92574 SHA256 90becb7755c83204588d0d77cdfbf9b0c1c4492661646e71c79de30329fbcbd6
+DIST amazonmp3-libcompat-0.1.tar.bz2 1367468 RMD160 5d67ff5068deae1f567e8fbbd6bf212080245d8a SHA1 94c4bc1adcbb6222c078c9f435739174d25076f9 SHA256 485b46d1b0f53ee67213c0bb795a7109da73bcc5f6d8585662e534faee2cf15b
+EBUILD amazonmp3-libcompat-0.1.ebuild 1925 RMD160 8ea2f42e99a2c44dab65c6709a7135bb5029f01d SHA1 d97bbaac3cf8c640f9d496cd915928fb8b8e9406 SHA256 94341ee7b97f6a38d9106f7f0b52c5941a4e8c2e219ad61351b9d61413c8c010
+MISC ChangeLog 424 RMD160 bfc9790a1aef7a11e4e7e3cde7541a8870d205b5 SHA1 9abaec9959bde8cd78e0d873afb2ddfe6bb13266 SHA256 c0b13ac325456e0985d1a4997d4a8cd48517bdfe4f3bd3782fb19fda1af96e63
+MISC metadata.xml 254 RMD160 1f5a6322e4956b30592a1e0caf7edc67613ecc43 SHA1 f0813ac26740fae9e0f0899b5dad74b5a6fd5b3c SHA256 740784d71bef88214e4d8508e351a376d8908f4c4b6175d98b6b77e107799f12
diff --git a/net-misc/amazonmp3-libcompat/amazonmp3-libcompat-0.1.ebuild b/net-misc/amazonmp3-libcompat/amazonmp3-libcompat-0.1.ebuild
new file mode 100644
index 000000000000..3f47fbc8423f
--- /dev/null
+++ b/net-misc/amazonmp3-libcompat/amazonmp3-libcompat-0.1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/amazonmp3-libcompat/amazonmp3-libcompat-0.1.ebuild,v 1.1 2008/09/29 14:16:45 lack Exp $
+
+EAPI="1"
+
+inherit multilib eutils
+
+BOOST_VERSION="1.34.1-7.fc8.i386"
+
+DESCRIPTION="Support dependencies for net-misc/amazonmp3"
+HOMEPAGE="http://gentoo.org/proj/en/desktop"
+SRC_URI="mirrors://gentoo/amazonmp3-boost-${BOOST_VERSION}.tar.bz2
+ amd64? ( mirrors://gentoo/${P}.tar.bz2 )"
+RESTRICT="strip"
+
+LICENSE="GPL-2"
+SLOT="0"
+# There are still problems with amd64 support, research on-going.
+KEYWORDS="~x86 -amd64 -*"
+IUSE=""
+
+DEPEND=""
+RDEPEND="x86? (
+ dev-cpp/gtkmm:2.4
+ net-misc/curl
+ dev-libs/openssl
+ )
+ amd64? (
+ app-emulation/emul-linux-x86-gtklibs
+ )"
+
+S="${WORKDIR}/amazonmp3-boost-${BOOST_VERSION}"
+
+pkg_setup() {
+ if use x86 && ! built_with_use dev-cpp/gtkmm accessibility; then
+ eerror "Please recompile dev-cpp/gtkmm with USE=\"accessibility\""
+ die "dev-cpp/gtkmm needs accessibility USE flag"
+ fi
+
+ # 32-bit binary libs
+ has_multilib_profile && ABI="x86"
+}
+
+src_install() {
+ local OPTDIR="/opt/${PN}"
+ exeinto "${OPTDIR}"
+
+ # The amazonmp3 binary, compiled for Fedora 8, needs boost-1.34, so we provide a
+ # set of the libs, ripped right out of their boost-1.34.1-7.fc8.i386.rpm
+ doexe *
+
+ if use amd64; then
+ # gtkmm (and its deps) and libcurl are not yet available in any
+ # emul-linux-x86 packages, so we rolled our own, based partially on FC8
+ # gtkmm rpms.
+
+ # TODO: Fix libcurl problems.
+ pushd "${WORKDIR}/${P}"
+ doexe *
+ popd
+ fi
+
+ # They also need some local libraries named a bit funny:
+ # TODO: Maybe put a copy of these in /opt/amazonmp3-libcompat?
+ dosym "libcrypto.so" "/usr/$(get_libdir)/libcrypto.so.6"
+ dosym "libssl.so" "/usr/$(get_libdir)/libssl.so.6"
+
+ echo "LDPATH=\"${OPTDIR}\"" > 99amazonmp3-libcompat
+ doenvd 99amazonmp3-libcompat
+}
diff --git a/net-misc/amazonmp3-libcompat/metadata.xml b/net-misc/amazonmp3-libcompat/metadata.xml
new file mode 100644
index 000000000000..24f1e9f83097
--- /dev/null
+++ b/net-misc/amazonmp3-libcompat/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>desktop-misc</herd>
+ <maintainer>
+ <email>lack@gentoo.org</email>
+ <name>Jim Ramsay</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/net-misc/amazonmp3/Manifest b/net-misc/amazonmp3/Manifest
index 4862538af1bb..c085f2481d3f 100644
--- a/net-misc/amazonmp3/Manifest
+++ b/net-misc/amazonmp3/Manifest
@@ -1,4 +1,4 @@
DIST amazonmp3.rpm 263118 RMD160 bbab77a662be7ff45ba1126c83955c4e087e61c4 SHA1 8ad87e8f9c391b72e23fcc0bcd5409124a05dbcc SHA256 d71b07646d6063cae35198eb77af481c159c87e6f38bceed204f9919676788c9
-EBUILD amazonmp3-1.0.3.ebuild 2161 RMD160 ce51ed82c8c3b91929b8f69cbc745317b693b52f SHA1 ec771b276dd945fec15cc755eb9df30e3472f781 SHA256 83ebc379ef31094f39fecc3533bf5a355636a17fffb621bfe960347df0e7fc2b
-MISC ChangeLog 665 RMD160 35e3dd1713ef2c025fa7e3902b26f17c410fca4f SHA1 40e37c485ddc119e6ac9f33d9695963d2f9cbe2f SHA256 a4673729b5717fb05a992dc91799f59647f211dcb2014ee251cd65d872fcbaa8
+EBUILD amazonmp3-1.0.3-r1.ebuild 1739 RMD160 c53ee4dc1fc755e9de0a9901ae4394bd9cfb7349 SHA1 a1c7badfbb03a14245ba4705d4ad9501e068203b SHA256 84f52f066286635e2b51b5e13817dcb140e00ecc17d295ad3ef0a1b114467759
+MISC ChangeLog 868 RMD160 908448d4097939aa88bb127952519cc891d6610a SHA1 959b2c2ae2622de6d4492015e08d233f95329b28 SHA256 a3c667efc7eff73a2d8c589ef10fc90415fbb3eaa14cfa826e2f0081c4b22ef4
MISC metadata.xml 254 RMD160 1f5a6322e4956b30592a1e0caf7edc67613ecc43 SHA1 f0813ac26740fae9e0f0899b5dad74b5a6fd5b3c SHA256 740784d71bef88214e4d8508e351a376d8908f4c4b6175d98b6b77e107799f12