summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarsten Lohrke <carlo@gentoo.org>2006-04-01 11:42:25 +0000
committerCarsten Lohrke <carlo@gentoo.org>2006-04-01 11:42:25 +0000
commitb6756bb352cf79d6a66b4dba71a8d559d7439ed9 (patch)
tree5cd4708946703f8e14dd81bb95625a4b18fca0b1 /net-misc
parentarts DEPEND thanks to jakub, bug 127609 (diff)
downloadhistorical-b6756bb352cf79d6a66b4dba71a8d559d7439ed9.tar.gz
historical-b6756bb352cf79d6a66b4dba71a8d559d7439ed9.tar.bz2
historical-b6756bb352cf79d6a66b4dba71a8d559d7439ed9.zip
gcc 4.1 patch, thanks to Robert Marmorstein, bug #128319.
Package-Manager: portage-2.0.54
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/kphone/ChangeLog8
-rw-r--r--net-misc/kphone/Manifest17
-rw-r--r--net-misc/kphone/files/kphone-4.2-gcc4.diff24
-rw-r--r--net-misc/kphone/kphone-4.2.ebuild13
4 files changed, 48 insertions, 14 deletions
diff --git a/net-misc/kphone/ChangeLog b/net-misc/kphone/ChangeLog
index 6fa73fb551d4..1f167602883d 100644
--- a/net-misc/kphone/ChangeLog
+++ b/net-misc/kphone/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-misc/kphone
-# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/kphone/ChangeLog,v 1.35 2005/09/24 12:13:51 hansmi Exp $
+# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/kphone/ChangeLog,v 1.36 2006/04/01 11:42:25 carlo Exp $
+
+ 01 Apr 2006; Carsten Lohrke <carlo@gentoo.org>
+ +files/kphone-4.2-gcc4.diff, kphone-4.2.ebuild:
+ gcc 4.1 patch, thanks to Robert Marmorstein, bug #128319.
24 Sep 2005; Michael Hanselmann <hansmi@gentoo.org> kphone-4.2.ebuild:
Stable on ppc.
diff --git a/net-misc/kphone/Manifest b/net-misc/kphone/Manifest
index 97ada4cdb3ba..8cd8aa4d7c16 100644
--- a/net-misc/kphone/Manifest
+++ b/net-misc/kphone/Manifest
@@ -1,10 +1,11 @@
-MD5 79a9d63d5116f9fd85489f5b0464cfdb kphone-4.1.0.ebuild 933
-MD5 70f06600556327dcfbc31fa03f610042 metadata.xml 155
-MD5 a0c1f0bb71a405c0f4d58e5f97ac12eb ChangeLog 4590
-MD5 ec9bc0dda04a943050ddd61534b705ab kphone-4.2.ebuild 959
-MD5 34e862915786f759ee014aa4aab3d0b9 kphone-4.1.1.ebuild 1031
-MD5 ce59ccd7de9e3fb78d4ab5bb40b0d283 files/kphone-4.1.1-gcc34.patch 456
+MD5 52458db945543cd97f6d5404801b00a1 ChangeLog 4749
+MD5 2ac98b4c3bd182f4d422edead25c56d9 files/digest-kphone-4.1.0 64
MD5 c96af639b76079a8a65e634df2154fb8 files/digest-kphone-4.1.1 64
-MD5 13744936b73f480a658795a553dd7efe files/kphone-4.1.0-Makefiles.patch 461
MD5 021fac998cd116c8390408634abaf994 files/digest-kphone-4.2 62
-MD5 2ac98b4c3bd182f4d422edead25c56d9 files/digest-kphone-4.1.0 64
+MD5 13744936b73f480a658795a553dd7efe files/kphone-4.1.0-Makefiles.patch 461
+MD5 ce59ccd7de9e3fb78d4ab5bb40b0d283 files/kphone-4.1.1-gcc34.patch 456
+MD5 aa1742f0c810c439d129b6e2d08a2f42 files/kphone-4.2-gcc4.diff 960
+MD5 79a9d63d5116f9fd85489f5b0464cfdb kphone-4.1.0.ebuild 933
+MD5 34e862915786f759ee014aa4aab3d0b9 kphone-4.1.1.ebuild 1031
+MD5 03289f6ce6e46e7f300863bce4850f1c kphone-4.2.ebuild 1040
+MD5 70f06600556327dcfbc31fa03f610042 metadata.xml 155
diff --git a/net-misc/kphone/files/kphone-4.2-gcc4.diff b/net-misc/kphone/files/kphone-4.2-gcc4.diff
new file mode 100644
index 000000000000..cf3b76763dca
--- /dev/null
+++ b/net-misc/kphone/files/kphone-4.2-gcc4.diff
@@ -0,0 +1,24 @@
+diff -Naur kphone.old/kphone/kcallwidget.h kphone/kphone/kcallwidget.h
+--- kphone.old/kphone/kcallwidget.h 2006-03-31 20:00:14.000000000 -0500
++++ kphone/kphone/kcallwidget.h 2006-03-31 20:00:54.000000000 -0500
+@@ -67,7 +67,7 @@
+ void clickHangup( void );
+ void setHide( void );
+ bool isHided( void ) const { return hided; }
+- void KCallWidget::setDTMFSender( QString &s );
++ void setDTMFSender( QString &s );
+
+ public slots:
+ void pleaseDial( const SipUri &dialuri );
+diff -Naur kphone.old/kphone/kphoneview.h kphone/kphone/kphoneview.h
+--- kphone.old/kphone/kphoneview.h 2006-03-31 20:00:14.000000000 -0500
++++ kphone/kphone/kphoneview.h 2006-03-31 20:00:43.000000000 -0500
+@@ -54,7 +54,7 @@
+ QString getStunSrv( void );
+ void kphoneQuit( void );
+ bool getState( void );
+- KCallWidget *KPhoneView::DoCall( QString num, SipCall::CallType ctype );
++ KCallWidget *DoCall( QString num, SipCall::CallType ctype );
+
+ signals:
+ void stateChanged( void );
diff --git a/net-misc/kphone/kphone-4.2.ebuild b/net-misc/kphone/kphone-4.2.ebuild
index b8629512f599..320fa45de89b 100644
--- a/net-misc/kphone/kphone-4.2.ebuild
+++ b/net-misc/kphone/kphone-4.2.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/kphone/kphone-4.2.ebuild,v 1.4 2005/09/24 12:13:51 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/kphone/kphone-4.2.ebuild,v 1.5 2006/04/01 11:42:25 carlo Exp $
-inherit qt3
+inherit qt3 eutils
DESCRIPTION="A SIP user agent for Linux, with which you can initiate VoIP connections over the Internet."
HOMEPAGE="http://www.wirlab.net/kphone/index.html"
@@ -10,7 +10,7 @@ SRC_URI="http://www.wirlab.net/kphone/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ppc sparc x86"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
IUSE="alsa debug jack"
S=${WORKDIR}/${PN}
@@ -22,6 +22,11 @@ DEPEND="=x11-libs/qt-3*
# TODO: support for Secure RTP, needs libSRTP in portage
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/kphone-4.2-gcc4.diff
+}
+
src_compile() {
local myconf="$(use_enable alsa) $(use_enable jack)
$(use_enable debug) --disable-srtp"