summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Hadaway <raker@gentoo.org>2002-08-12 15:17:47 +0000
committerNick Hadaway <raker@gentoo.org>2002-08-12 15:17:47 +0000
commit9a3fdc3887508e717d809aba7344e90dc3f5512e (patch)
treebbe77e368330d3f9c465a7eb04aa13ce440db2ab /net-misc
parentAdded mask for hylafax-4.1.3 as I am currently testing the build on my (diff)
downloadhistorical-9a3fdc3887508e717d809aba7344e90dc3f5512e.tar.gz
historical-9a3fdc3887508e717d809aba7344e90dc3f5512e.tar.bz2
historical-9a3fdc3887508e717d809aba7344e90dc3f5512e.zip
Version bump. Currently testing. Fixes for string vulnerabilities and buffer overflows.
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/hylafax/ChangeLog17
-rw-r--r--net-misc/hylafax/files/digest-hylafax-4.1.31
-rw-r--r--net-misc/hylafax/hylafax-4.1.3.ebuild81
3 files changed, 98 insertions, 1 deletions
diff --git a/net-misc/hylafax/ChangeLog b/net-misc/hylafax/ChangeLog
index 529114413b16..fa62c3490552 100644
--- a/net-misc/hylafax/ChangeLog
+++ b/net-misc/hylafax/ChangeLog
@@ -1,6 +1,21 @@
# ChangeLog for net-misc/hylafax
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-misc/hylafax/ChangeLog,v 1.4 2002/07/07 08:06:20 phoenix Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/hylafax/ChangeLog,v 1.5 2002/08/12 15:17:47 raker Exp $
+
+*hylafax-4.1.3 (12 Aug 2002)
+
+ 12 Aug 2002; Nick Hadaway <raker@gentoo.org> hylafax-4.1.3.ebuild,
+ files/digest-hylafax-4.1.3 :
+ Version bump. I have removed previous patches from the ebuild
+ temporarily until I can figure out which patches are still needed.
+ Taken from the release notes:
+ 4.1.3 includes fixes for a remote format string vulnerability
+ which could be abused in a denial of service attack. Also fixed
+ is a buffer overflow condition when receiving fax image data
+ which potentially could be exploited to execute arbitrary code as
+ root. Also present in 4.1.3 are fixes for several other local remote
+ format string vulnerabilities which, in some installations, could
+ lead to elevated privileges by abuse. Everyone is advised to upgrade.
*hylafax-4.1.2-r1 (24 Apr 2002)
diff --git a/net-misc/hylafax/files/digest-hylafax-4.1.3 b/net-misc/hylafax/files/digest-hylafax-4.1.3
new file mode 100644
index 000000000000..608464f1129c
--- /dev/null
+++ b/net-misc/hylafax/files/digest-hylafax-4.1.3
@@ -0,0 +1 @@
+MD5 b3e95810a7fc99685f92faa8ff59114e hylafax-4.1.3.tar.gz 1269098
diff --git a/net-misc/hylafax/hylafax-4.1.3.ebuild b/net-misc/hylafax/hylafax-4.1.3.ebuild
new file mode 100644
index 000000000000..c22524cae69c
--- /dev/null
+++ b/net-misc/hylafax/hylafax-4.1.3.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-misc/hylafax/hylafax-4.1.3.ebuild,v 1.1 2002/08/12 15:17:47 raker Exp $
+
+S=${WORKDIR}/${P}
+MYSED=sed-3.02
+PATCHES=${WORKDIR}/patches
+DESCRIPTION="Fax package for class 1 and 2 fax modems."
+SRC_URI="ftp://ftp.hylafax.org/source/${P}.tar.gz"
+HOMEPAGE="http://www.hylafax.org"
+KEYWORDS="x86 -ppc -sparc -sparc64"
+LICENSE="hylafax"
+SLOT="0"
+
+DEPEND="net-dialup/mgetty
+ sys-libs/zlib
+ app-text/ghostscript
+ media-libs/tiff
+ jpeg? ( media-libs/jpeg )"
+
+#src_unpack() {
+#
+# unpack ${P}.tar.gz
+# mkdir patches
+# cd patches
+# tar jxvf ${FILESDIR}/${P}-gentoo-diffs.tar.bz2
+# cd ${S}
+# patch -p1 < ${PATCHES}/${P}-dso.chris.patch
+# patch -p1 < ${PATCHES}/${P}-shlib-pic.chris.patch
+# patch -p1 < ${PATCHES}/${P}-gentoo.patch
+# patch -p1 < ${PATCHES}/${P}-topmargin.patch
+# patch < ${PATCHES}/${P}-configure.patch
+#
+#}
+
+src_compile() {
+
+ ./configure \
+ --with-DIR_BIN=/usr/bin \
+ --with-DIR_SBIN=/usr/sbin \
+ --with-DIR_LIB=/usr/lib \
+ --with-DIR_LIBEXEC=/usr/sbin \
+ --with-DIR_LIBDATA=/usr/lib/fax \
+ --with-DIR_LOCKS=/var/lock \
+ --with-DIR_MAN=/usr/share/man \
+ --with-DIR_SPOOL=/var/spool/fax \
+ --with-AFM=no \
+ --with-AWK=/usr/bin/gawk \
+ --with-PATH_VGETTY=/sbin/vgetty \
+ --with-PATH_GETTY=/sbin/agetty \
+ --with-HTML=no \
+ --with-PATH_DPSRIP=/var/spool/fax/bin/ps2fax \
+ --with-PATH_IMPRIP=/usr/share/fax/psrip \
+ --with-SYSVINIT=/etc/init.d \
+ --with-INTERACTIVE=no || die
+
+ make \
+ OPTIMIZER="${CFLAGS}" || die
+}
+
+src_install() {
+
+ dodir /usr/{bin,sbin} /usr/lib/fax /usr/share/man /var/spool/fax
+
+ make \
+ BIN=${D}/usr/bin \
+ SBIN=${D}/usr/sbin \
+ LIBDIR=${D}/usr/lib \
+ LIB=${D}/usr/lib \
+ LIBEXEC=${D}/usr/sbin \
+ LIBDATA=${D}/usr/lib/fax \
+ MAN=${D}/usr/share/man \
+ SPOOL=${D}/var/spool/fax \
+ install || die
+
+ insinto /etc/init.d
+ doins etc/hylafax
+
+ dodoc COPYRIGHT README TODO VERSION
+ dohtml -r .
+}