summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-08-03 03:47:04 +0000
committerMike Frysinger <vapier@gentoo.org>2003-08-03 03:47:04 +0000
commit8e85af10f6bf1199422de6cf169181736573b7cb (patch)
treee5cc880a8f6f4e5f09c1fcc3e54aa10d742f2dc5 /net-misc
parent$DEBUG -> use debug (diff)
downloadhistorical-8e85af10f6bf1199422de6cf169181736573b7cb.tar.gz
historical-8e85af10f6bf1199422de6cf169181736573b7cb.tar.bz2
historical-8e85af10f6bf1199422de6cf169181736573b7cb.zip
$DEBUG -> use debug
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/axel/axel-1.0a.ebuild23
1 files changed, 13 insertions, 10 deletions
diff --git a/net-misc/axel/axel-1.0a.ebuild b/net-misc/axel/axel-1.0a.ebuild
index c18450e395b7..4777d8f90d2f 100644
--- a/net-misc/axel/axel-1.0a.ebuild
+++ b/net-misc/axel/axel-1.0a.ebuild
@@ -1,25 +1,28 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/axel/axel-1.0a.ebuild,v 1.8 2003/02/13 14:45:28 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/axel/axel-1.0a.ebuild,v 1.9 2003/08/03 03:47:04 vapier Exp $
-S=${WORKDIR}/${P}
-DESCRIPTION="Axel: A light Unix download accelerator"
+DESCRIPTION="light Unix download accelerator"
HOMEPAGE="http://www.lintux.cx/axel.html"
SRC_URI="http://www.lintux.cx/downloads/${P}.tar.gz"
-SLOT="0"
+
LICENSE="GPL-2"
-KEYWORDS="x86 sparc "
+SLOT="0"
+KEYWORDS="x86 sparc"
+IUSE="debug"
DEPEND="virtual/glibc"
src_compile() {
- local mconf
cd work/${P}
- ( [ -n "$DEBUG" ] || [ -n "$DEBUGBUILD" ] ) && \
- myconf="${myconf} --debug=1 --strip=0"
- ./configure --prefix=/usr \
+ local myconf
+ [ `use debug` ] && myconf="--debug=1 --strip=0"
+ ./configure \
+ --prefix=/usr \
--etcdir=/etc \
- --mandir=/usr/share/man $myconf || die
+ --mandir=/usr/share/man \
+ ${myconf} \
+ || die
emake || die
}