summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2011-07-27 20:08:52 +0000
committerMichał Górny <mgorny@gentoo.org>2011-07-27 20:08:52 +0000
commit6dfbc2a20761dbbb9b1eeb0911d5098aea33d858 (patch)
treeb0864cb40b0ded3aecd52239adcc5569f5fc0611 /net-misc
parentNew library, dependency of digikam-2 (diff)
downloadhistorical-6dfbc2a20761dbbb9b1eeb0911d5098aea33d858.tar.gz
historical-6dfbc2a20761dbbb9b1eeb0911d5098aea33d858.tar.bz2
historical-6dfbc2a20761dbbb9b1eeb0911d5098aea33d858.zip
Introduce an ebuild for autoupnp, automatic UPnP port forwarder (bug #322057).
Package-Manager: portage-2.2.0_alpha47_p5/cvs/Linux x86_64
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/autoupnp/ChangeLog11
-rw-r--r--net-misc/autoupnp/Manifest16
-rw-r--r--net-misc/autoupnp/autoupnp-0.4.5.ebuild33
-rw-r--r--net-misc/autoupnp/metadata.xml16
4 files changed, 76 insertions, 0 deletions
diff --git a/net-misc/autoupnp/ChangeLog b/net-misc/autoupnp/ChangeLog
new file mode 100644
index 000000000000..bf46690dd1a4
--- /dev/null
+++ b/net-misc/autoupnp/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for net-misc/autoupnp
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/autoupnp/ChangeLog,v 1.1 2011/07/27 20:08:52 mgorny Exp $
+
+*autoupnp-0.4.5 (27 Jul 2011)
+
+ 27 Jul 2011; Michał Górny <mgorny@gentoo.org> +autoupnp-0.4.5.ebuild,
+ +metadata.xml:
+ Introduce an ebuild for autoupnp, automatic UPnP port forwarder (bug
+ #322057).
+
diff --git a/net-misc/autoupnp/Manifest b/net-misc/autoupnp/Manifest
new file mode 100644
index 000000000000..345c270abb1c
--- /dev/null
+++ b/net-misc/autoupnp/Manifest
@@ -0,0 +1,16 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA256
+
+DIST autoupnp-0.4.5.tar.bz2 237200 RMD160 d8db91acdb48dd885b8002ebc0dfae9825fd878e SHA1 4f1d017be08c8ae6bc2a4510bd76ba42f944f764 SHA256 1f2c2bf6938dc18351cf661b2f7a20c3b0be2140c224bde5244d679cecfed2d8
+EBUILD autoupnp-0.4.5.ebuild 796 RMD160 0d84921bb8dbac8a0cfebe9ba211c84a92bc46f1 SHA1 4e5a090bd4fa3f4d05b71b8c3c4553cba2dda804 SHA256 5c1e92aa7e66464eeff1de54f4b347063100d57ee43ee7f635352127bf967835
+MISC ChangeLog 413 RMD160 a8bad8bd7f4024a17e7f5ada85779b5c9ab27ff1 SHA1 6f30ce017b98190e77f1b2a54580db381e3cf832 SHA256 80041eed37106938a63092f2ad541d64f9dfaac93f80e2605367731c7dd2e649
+MISC metadata.xml 539 RMD160 3c6e22ccb9af265d63f9d40b8cfe6fb9d2bdd0aa SHA1 2f8730c12bc15f243483bf044a239b80efce4a2b SHA256 eb121bcefb309db28901da9a89fc598df902f1394be709863019830814b67970
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.17 (GNU/Linux)
+
+iJwEAQEIAAYFAk4wcKcACgkQfXuS5UK5QB21FgP/RsNYAnuf/jHKoxba/iwdIuZd
+XiUQ7IuOJwVymxdWW5sYJty/KUASlm4AZP6kfUkE3N4PfTJvyWrv5nOOtO/b/7K0
+LMp3g95CE51IATBSUns4CZeJ8EZIyBTeLeTay5lBdikUwhBxyeURNxnwe5jpfv6e
+Wtyg3me3m2ZEHrgUsAk=
+=59RW
+-----END PGP SIGNATURE-----
diff --git a/net-misc/autoupnp/autoupnp-0.4.5.ebuild b/net-misc/autoupnp/autoupnp-0.4.5.ebuild
new file mode 100644
index 000000000000..fb032f04e949
--- /dev/null
+++ b/net-misc/autoupnp/autoupnp-0.4.5.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/autoupnp/autoupnp-0.4.5.ebuild,v 1.1 2011/07/27 20:08:52 mgorny Exp $
+
+EAPI=4
+inherit autotools-utils
+
+DESCRIPTION="Automatic open port forwarder using UPnP"
+HOMEPAGE="https://github.com/mgorny/autoupnp/"
+SRC_URI="http://cloud.github.com/downloads/mgorny/${PN}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# libnotify RDEP forced due to missing pthreads in this version,
+# and libnotify pulls it in indirectly.
+
+RDEPEND="net-libs/miniupnpc
+ x11-libs/libnotify"
+DEPEND="${RDEPEND}"
+
+DOCS=( README )
+
+src_prepare() {
+ autotools-utils_src_prepare
+}
+
+src_install() {
+ autotools-utils_src_install
+ remove_libtool_files all
+}
diff --git a/net-misc/autoupnp/metadata.xml b/net-misc/autoupnp/metadata.xml
new file mode 100644
index 000000000000..c5bf6c1e937e
--- /dev/null
+++ b/net-misc/autoupnp/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+ <maintainer>
+ <email>mgorny@gentoo.org</email>
+ <name>Michał Górny</name>
+ </maintainer>
+ <upstream>
+ <maintainer status="active">
+ <email>mgorny@gentoo.org</email>
+ <name>Michał Górny</name>
+ </maintainer>
+ <bugs-to>http://bugs.gentoo.org/enter_bug.cgi?product=Gentoo%20Linux&amp;component=Applications&amp;short_desc=net-misc/autoupnp:%20</bugs-to>
+ </upstream>
+</pkgmetadata>