summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-02-15 16:41:32 +0000
committerAchim Gottinger <achim@gentoo.org>2001-02-15 16:41:32 +0000
commit6bd5236135a27f6d14b1dd134bd89139a3e43fcc (patch)
tree4a407eee8133bae205d4ff36de4742684eee4066 /net-misc
parentzapping things -> media-libs (diff)
downloadhistorical-6bd5236135a27f6d14b1dd134bd89139a3e43fcc.tar.gz
historical-6bd5236135a27f6d14b1dd134bd89139a3e43fcc.tar.bz2
historical-6bd5236135a27f6d14b1dd134bd89139a3e43fcc.zip
*** empty log message ***
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/bind/bind-8.2.3.ebuild99
-rw-r--r--net-misc/bind/files/bind-8.1.2-fds.patch43
-rw-r--r--net-misc/bind/files/digest-bind-8.2.32
3 files changed, 144 insertions, 0 deletions
diff --git a/net-misc/bind/bind-8.2.3.ebuild b/net-misc/bind/bind-8.2.3.ebuild
new file mode 100644
index 000000000000..6ade11798e1a
--- /dev/null
+++ b/net-misc/bind/bind-8.2.3.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-misc/bind/bind-8.2.3.ebuild,v 1.1 2001/02/15 16:41:32 achim Exp $
+
+A="bind-src.tar.gz bind-doc.tar.gz"
+S=${WORKDIR}/src
+DESCRIPTION="Name Server"
+SRC_URI="ftp://ftp.isc.org/isc/bind/src/8.2.3/bind-src.tar.gz
+ ftp://ftp.isc.org/isc/bind/src/8.2.3/bind-doc.tar.gz"
+HOMEPAGE="http://www.isc.org/products/BIND"
+
+DEPEND=">=sys-apps/bash-2.04
+ >=sys-libs/glibc-2.1.3"
+
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ patch -p2 < ${FILESDIR}/bind-8.1.2-fds.patch
+
+ cd ${S}/port/linux
+ cp Makefile.set Makefile.set.orig
+ sed -e "s:^'CC=.*:'CC=gcc':" \
+ -e "s:^'YACC=.*:'YACC=bison -y':" Makefile.set.orig > Makefile.set
+# sed -e "s:CDEBUG=-O -g:CDEBUG=${CFLAGS}:" Makefile.set.orig > Makefile.set
+}
+
+src_compile() {
+
+ try make clean depend
+# cd lib
+# for i in bsd dst isc irs inet dnssafe nameser cylink resolv .
+# do
+# cp $i/Makefile $i/Makefile.orig
+# sed -e "s:SYSTYPE= bsdos:SYSTYPE= linux:" $i/Makefile.orig > $i/Makefile
+# done
+# cd ..
+ try make SYSTYPE=linux
+}
+
+src_install() {
+ into /usr
+ for x in addr dig dnsquery host mkservdb nslookup nsupdate
+ do
+ dobin bin/${x}/${x}
+ done
+
+ for x in dnskeygen irpd named named-bootconf named-xfer ndc
+ do
+ dosbin bin/${x}/${x}
+ done
+
+ dodoc CHANGES DNSSEC SUPPORT README LICENSE* TODO
+ docinto conf
+ dodoc conf/README
+ docinto conf/recursive
+ dodoc conf/recursive/*
+ docinto conf/recursive/pri
+ dodoc conf/recursive/pri/*
+ docinto conf/workstation
+ dodoc conf/workstation/*
+ docinto conf/workstation/pri
+ dodoc conf/workstation/pri/*
+ dodir /etc/rc.d/init.d
+ cp ${O}/files/named ${D}/etc/rc.d/init.d
+ cp ${O}/files/named.conf ${D}/usr/doc/${PF}/conf/workstation/named.conf.gentoolinux
+ dodir /etc/bind
+ dodir /var/bind
+
+ cd ${WORKDIR}/doc/html
+ docinto html
+ dodoc *
+
+ cd ${WORKDIR}/doc/man
+ for i in *.1 *.3 *.5 *.7 *.8
+ do
+ doman $i
+ done
+}
+
+pkg_config() {
+ . ${ROOT}/etc/rc.d/config/functions
+
+ if [ -e ${ROOT}/etc/bind/named.conf ]; then
+ echo "You already have a named.conf in ${ROOT}/etc/bind/named.conf, not creating one."
+ else
+ install -m0644 ${ROOT}/usr/doc/${PF}/conf/workstation/named.conf.gentoolinux ${ROOT}/etc/bind/named.conf
+ mkdir ${ROOT}/var/bind/pri
+ gzip -d ${ROOT}/usr/doc/${PF}/conf/workstation/root.cache.gz
+ gzip -d ${ROOT}/usr/doc/${PF}/conf/workstation/pri/*.gz
+ install -m0644 ${ROOT}/usr/doc/${PF}/conf/workstation/root.cache ${ROOT}/var/bind/root.cache
+ install -m0644 ${ROOT}/usr/doc/${PF}/conf/workstation/pri/* ${ROOT}/var/bind/pri/
+ fi
+ echo;
+
+ ${ROOT}/usr/sbin/rc-update add named
+ echo; einfo "BIND enabled."
+}
diff --git a/net-misc/bind/files/bind-8.1.2-fds.patch b/net-misc/bind/files/bind-8.1.2-fds.patch
new file mode 100644
index 000000000000..54a3404d2d9f
--- /dev/null
+++ b/net-misc/bind/files/bind-8.1.2-fds.patch
@@ -0,0 +1,43 @@
+--- bind-8.1.2/src/lib/isc/eventlib.c~ Fri Mar 20 18:26:24 1998
++++ bind-8.1.2/src/lib/isc/eventlib.c Wed Jan 6 17:44:03 1999
+@@ -290,9 +290,9 @@
+ evPrintf(ctx, 4,
+ "pselect(%d, 0x%lx, 0x%lx, 0x%lx, %d.%09ld)\n",
+ ctx->fdMax+1,
+- (u_long)ctx->rdLast.fds_bits[0],
+- (u_long)ctx->wrLast.fds_bits[0],
+- (u_long)ctx->exLast.fds_bits[0],
++ __FDS_BITS(&ctx->rdLast)[0],
++ __FDS_BITS(&ctx->wrLast)[0],
++ __FDS_BITS(&ctx->exLast)[0],
+ tp ? tp->tv_sec : -1,
+ tp ? tp->tv_nsec : -1);
+
+--- bind-8.1.2/src/lib/isc/ev_files.c~ Thu Feb 5 20:53:52 1998
++++ bind-8.1.2/src/lib/isc/ev_files.c Wed Jan 6 17:46:18 1999
+@@ -139,9 +139,9 @@
+ evPrintf(ctx, 5,
+ "evSelectFD(fd %d, mask 0x%x): new masks: 0x%lx 0x%lx 0x%lx\n",
+ fd, eventmask,
+- (u_long)ctx->rdNext.fds_bits[0],
+- (u_long)ctx->wrNext.fds_bits[0],
+- (u_long)ctx->exNext.fds_bits[0]);
++ __FDS_BITS(&ctx->rdNext)[0],
++ __FDS_BITS(&ctx->wrNext)[0],
++ __FDS_BITS(&ctx->exNext)[0]);
+
+ return (0);
+ }
+@@ -250,9 +250,9 @@
+ evPrintf(ctx, 5,
+ "evDeselectFD(fd %d, mask 0x%x): new masks: 0x%lx 0x%lx 0x%lx\n",
+ del->fd, eventmask,
+- (u_long)ctx->rdNext.fds_bits[0],
+- (u_long)ctx->wrNext.fds_bits[0],
+- (u_long)ctx->exNext.fds_bits[0]);
++ __FDS_BITS(&ctx->rdNext)[0],
++ __FDS_BITS(&ctx->wrNext)[0],
++ __FDS_BITS(&ctx->exNext)[0]);
+
+ /* Couldn't free it before now since we were using fields out of it. */
+ FREE(del);
diff --git a/net-misc/bind/files/digest-bind-8.2.3 b/net-misc/bind/files/digest-bind-8.2.3
new file mode 100644
index 000000000000..7b0a58e5632f
--- /dev/null
+++ b/net-misc/bind/files/digest-bind-8.2.3
@@ -0,0 +1,2 @@
+MD5 fd8ab0befccc3546531904eac12cf6f7 bind-src.tar.gz
+MD5 c26474bb791552cc0cbc5af72190a772 bind-doc.tar.gz