summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2005-01-13 10:03:15 +0000
committerDaniel Black <dragonheart@gentoo.org>2005-01-13 10:03:15 +0000
commit43eabe804fc26ad9a0e5c4da58276d110e169fd1 (patch)
tree401c377997ad1527bfb436bad954109d9fd90a58 /net-misc
parentMoving emul-linux-x86 from STAGE1_USE to USE as we don't need it to build sta... (diff)
downloadhistorical-43eabe804fc26ad9a0e5c4da58276d110e169fd1.tar.gz
historical-43eabe804fc26ad9a0e5c4da58276d110e169fd1.tar.bz2
historical-43eabe804fc26ad9a0e5c4da58276d110e169fd1.zip
Initial import as per bug #72959
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/netpipes/ChangeLog11
-rw-r--r--net-misc/netpipes/Manifest14
-rw-r--r--net-misc/netpipes/files/digest-netpipes-4.20
-rw-r--r--net-misc/netpipes/metadata.xml9
-rw-r--r--net-misc/netpipes/netpipes-4.2.ebuild26
5 files changed, 60 insertions, 0 deletions
diff --git a/net-misc/netpipes/ChangeLog b/net-misc/netpipes/ChangeLog
new file mode 100644
index 000000000000..f66f80e3e3ca
--- /dev/null
+++ b/net-misc/netpipes/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for net-misc/netpipes
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/netpipes/ChangeLog,v 1.1 2005/01/13 10:03:15 dragonheart Exp $
+
+*netpipes-4.2 (13 Jan 2005)
+
+ 13 Jan 2005; Daniel Black <dragonheart@gentoo.org> +netpipes-4.2.ebuild,
+ metadata.xml:
+ Initial import as per bug #72959. Thanks to the author thoth@purplefrog.com
+ for the program and ebuild
+
diff --git a/net-misc/netpipes/Manifest b/net-misc/netpipes/Manifest
new file mode 100644
index 000000000000..7a4210f5bfe8
--- /dev/null
+++ b/net-misc/netpipes/Manifest
@@ -0,0 +1,14 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+MD5 14edcd83976a5b10a78f7980019c704c netpipes-4.2.ebuild 761
+MD5 c260f5cd9a68c0965120f9244b5df4ef metadata.xml 284
+MD5 d7904adbbfef9b38da5b1d95d2b1770f ChangeLog 440
+MD5 d41d8cd98f00b204e9800998ecf8427e files/digest-netpipes-4.2 0
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.0 (GNU/Linux)
+
+iD8DBQFB5kdpmdTrptrqvGERAsM3AKCWLmjQw717vLkVl+paI4QqxNXKmwCfaFjr
+3GylTh10Dq5Muy6n9MpNyw4=
+=8hXi
+-----END PGP SIGNATURE-----
diff --git a/net-misc/netpipes/files/digest-netpipes-4.2 b/net-misc/netpipes/files/digest-netpipes-4.2
new file mode 100644
index 000000000000..e69de29bb2d1
--- /dev/null
+++ b/net-misc/netpipes/files/digest-netpipes-4.2
diff --git a/net-misc/netpipes/metadata.xml b/net-misc/netpipes/metadata.xml
new file mode 100644
index 000000000000..dbbf4a490e09
--- /dev/null
+++ b/net-misc/netpipes/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>netmon</herd>
+<maintainer>
+ <email>vapier@gentoo.org</email>
+</maintainer>
+<longdescription>the network swiss army knife</longdescription>
+</pkgmetadata>
diff --git a/net-misc/netpipes/netpipes-4.2.ebuild b/net-misc/netpipes/netpipes-4.2.ebuild
new file mode 100644
index 000000000000..2e9653721d8e
--- /dev/null
+++ b/net-misc/netpipes/netpipes-4.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/netpipes/netpipes-4.2.ebuild,v 1.1 2005/01/13 10:03:15 dragonheart Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="netpipes - a package to manipulate BSD TCP/IP stream sockets"
+HOMEPAGE="http://web.purplefrog.com/~thoth/netpipes/"
+SRC_URI="http://web.purplefrog.com/~thoth/netpipes/ftp/${P}-export.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+# theoretically you should be able to build netpipes on ANY architecture
+KEYWORDS="x86"
+IUSE=""
+
+S=${WORKDIR}
+
+src_compile () {
+ emake CC=$(tc-getCC) || die
+}
+
+src_install() {
+ mkdir -p ${D}/usr/share/man || die
+ emake INSTROOT=${D}/usr INSTMAN=${D}/usr/share/man install || die
+}