summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-10-19 03:15:26 +0000
committerMike Frysinger <vapier@gentoo.org>2003-10-19 03:15:26 +0000
commit36f86dcc03f72186e85f59fb04e1e0dfba878151 (patch)
tree41db17c3e949199889062042b0cef9b28d543241 /net-misc
parentold (diff)
downloadhistorical-36f86dcc03f72186e85f59fb04e1e0dfba878151.tar.gz
historical-36f86dcc03f72186e85f59fb04e1e0dfba878151.tar.bz2
historical-36f86dcc03f72186e85f59fb04e1e0dfba878151.zip
set default rsh cmd #30521
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/rsync/ChangeLog11
-rw-r--r--net-misc/rsync/files/digest-rsync-2.5.6-r42
-rw-r--r--net-misc/rsync/rsync-2.5.6-r4.ebuild69
3 files changed, 79 insertions, 3 deletions
diff --git a/net-misc/rsync/ChangeLog b/net-misc/rsync/ChangeLog
index bb8c42266d90..e1768533c216 100644
--- a/net-misc/rsync/ChangeLog
+++ b/net-misc/rsync/ChangeLog
@@ -1,12 +1,17 @@
# ChangeLog for net-misc/rsync
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/rsync/ChangeLog,v 1.32 2003/08/26 09:17:34 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/rsync/ChangeLog,v 1.33 2003/10/19 03:15:26 vapier Exp $
- 26 Aug 2003; Daniel Ahlberg <aliz@gentoo.org> rsync-2.5.6-r3.ebuild :
- Don't try to unpack the patch.
+*rsync-2.5.6-r4 (18 Oct 2003)
+
+ 18 Oct 2003; Mike Frysinger <vapier@gentoo.org> :
+ Set default rsh cmd to ssh instead of rsh #30521.
*rsync-2.5.6-r3 (25 Aug 2003)
+ 26 Aug 2003; Daniel Ahlberg <aliz@gentoo.org> rsync-2.5.6-r3.ebuild :
+ Don't try to unpack the patch.
+
25 Aug 2003; Mike Frysinger <vapier@gentoo.org> :
Add default rsyncd.conf file so that the init.d script will find pid file #27277.
diff --git a/net-misc/rsync/files/digest-rsync-2.5.6-r4 b/net-misc/rsync/files/digest-rsync-2.5.6-r4
new file mode 100644
index 000000000000..de97f912b933
--- /dev/null
+++ b/net-misc/rsync/files/digest-rsync-2.5.6-r4
@@ -0,0 +1,2 @@
+MD5 ec39fcea433df4d6a3a4e0896c655535 rsync-2.5.6.tar.gz 584678
+MD5 a399e227a18ea3f2eb5aa2b401006d2d rsync-2.5.6-proxy-auth-1.patch 4353
diff --git a/net-misc/rsync/rsync-2.5.6-r4.ebuild b/net-misc/rsync/rsync-2.5.6-r4.ebuild
new file mode 100644
index 000000000000..bac8851d78d9
--- /dev/null
+++ b/net-misc/rsync/rsync-2.5.6-r4.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/rsync/rsync-2.5.6-r4.ebuild,v 1.1 2003/10/19 03:15:26 vapier Exp $
+
+inherit eutils
+
+DESCRIPTION="File transfer program to keep remote files into sync"
+HOMEPAGE="http://rsync.samba.org/"
+SRC_URI="http://rsync.samba.org/ftp/rsync/${P}.tar.gz
+ http://www.imada.sdu.dk/~bardur/personal/patches/${PN}-proxy-auth/${P}-proxy-auth-1.patch"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~mips ~alpha ~arm ~hppa ~amd64 ~ia64"
+
+DEPEND="virtual/glibc
+ >=sys-apps/sed-4
+ !build? ( >=dev-libs/popt-1.5 )"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ epatch ${DISTDIR}/${P}-proxy-auth-1.patch
+ cd ${S}
+
+ # change confdir to /etc/rsync rather than just /etc (the --sysconfdir
+ # configure option doesn't work
+ sed -i 's|/etc/rsyncd.conf|/etc/rsync/rsyncd.conf|g' rsync.h
+ # yes, updating the man page is very important.
+ sed -i 's|/etc/rsyncd|/etc/rsync/rsyncd|g' rsyncd.conf.5
+}
+
+src_compile() {
+ [ -n "$(use build)" ] \
+ && POPTSETTING="--with-included-popt" \
+ || POPTSETTING=""
+ [ -z "${CC}" ] && CC=gcc
+ if [ "`${CC} -dumpversion | cut -d. -f1,2`" = "2.95" ] ; then
+ export LDFLAGS="${LDFLAGS} -lpthread"
+ fi
+ econf \
+ ${POPTSETTING} \
+ --with-rsh=ssh \
+ || die
+ use static && export LDFLAGS="${LDFLAGS} -static"
+ emake || die
+}
+
+src_install() {
+ einstall || die
+ insinto /etc/conf.d && newins ${FILESDIR}/rsyncd.conf.d rsyncd
+ exeinto /etc/init.d && newexe ${FILESDIR}/rsyncd.init.d rsyncd
+ if [ -z "`use build`" ] ; then
+ dodir /etc/rsync
+ dodoc COPYING NEWS OLDNEWS README TODO tech_report.tex
+ if [ ! -e /etc/rsync/rsyncd.conf ] ; then
+ insinto /etc/rsync
+ doins ${FILESDIR}/rsyncd.conf
+ fi
+ else
+ rm -rf ${D}/usr/share
+ fi
+}
+
+pkg_postinst() {
+ einfo 'This patch enables usage of user:pass@proxy.foo:port'
+ einfo 'in the RSYNC_PROXY environment variable to support'
+ einfo 'the "Basic" proxy authentication scheme if you are'
+ einfo 'behind a password protected HTTP proxy.'
+}