summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2003-12-07 15:59:50 +0000
committerMartin Holzer <mholzer@gentoo.org>2003-12-07 15:59:50 +0000
commit379e69de415bc76715e9aaac5595662a72ec789b (patch)
treeac351dd1b950c62450733e4f53c44cd090d54af3 /net-misc/whois/whois-4.6.9.ebuild
parentVersion bumped. (diff)
downloadhistorical-379e69de415bc76715e9aaac5595662a72ec789b.tar.gz
historical-379e69de415bc76715e9aaac5595662a72ec789b.tar.bz2
historical-379e69de415bc76715e9aaac5595662a72ec789b.zip
Version bumped.
Diffstat (limited to 'net-misc/whois/whois-4.6.9.ebuild')
-rw-r--r--net-misc/whois/whois-4.6.9.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/net-misc/whois/whois-4.6.9.ebuild b/net-misc/whois/whois-4.6.9.ebuild
new file mode 100644
index 000000000000..08b6d5ff99ae
--- /dev/null
+++ b/net-misc/whois/whois-4.6.9.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/whois/whois-4.6.9.ebuild,v 1.1 2003/12/07 15:59:45 mholzer Exp $
+
+IUSE="nls"
+MY_P=${P/-/_}
+DESCRIPTION="improved Whois Client"
+SRC_URI="http://www.linux.it/~md/software/${MY_P}.tar.gz"
+HOMEPAGE="http://www.linux.it/~md/software/"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~mips ~hppa ~arm ~ia64 ~alpha ~amd64"
+
+DEPEND=">=sys-apps/sed-4
+ >=dev-lang/perl-5"
+RDEPEND="virtual/glibc"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -i -e "s/-O2/$CFLAGS/" Makefile
+
+ use nls && ( \
+ cd po
+ sed -i -e "s:/usr/bin/install:/bin/install:" Makefile
+ ) || ( \
+ sed -i -e "s:cd po.*::" Makefile
+ )
+
+ epatch ${FILESDIR}/${P}-gentoo-security.patch || die
+}
+
+src_compile() {
+ make || die
+ make mkpasswd || die
+}
+
+src_install() {
+ dodir /usr/bin
+ dodir /usr/share/man/man1
+ use nls && dodir /usr/share/locale
+ make BASEDIR=${D} prefix=/usr mandir=/usr/share/man install || die
+
+ dobin mkpasswd
+ doman mkpasswd.1
+ dodoc README whois.conf debian/changelog debian/copyright
+
+ einfo ""
+ einfo "The example whois.conf is located in /usr/doc/${P}"
+ einfo ""
+}