summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2005-02-07 02:19:59 +0000
committerRyan Phillips <rphillips@gentoo.org>2005-02-07 02:19:59 +0000
commit474a76dc602abb8380d41df8f0329898c1dfc5ef (patch)
tree33cdd374951ab93d4c63634e5da076eeed5ec5a5 /net-misc/vde/vde-1.5.7.ebuild
parentMarked stable on mips. (diff)
downloadhistorical-474a76dc602abb8380d41df8f0329898c1dfc5ef.tar.gz
historical-474a76dc602abb8380d41df8f0329898c1dfc5ef.tar.bz2
historical-474a76dc602abb8380d41df8f0329898c1dfc5ef.zip
Initial Commit. Thanks to Nico Baggus. Fixes #65359
Diffstat (limited to 'net-misc/vde/vde-1.5.7.ebuild')
-rw-r--r--net-misc/vde/vde-1.5.7.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/net-misc/vde/vde-1.5.7.ebuild b/net-misc/vde/vde-1.5.7.ebuild
new file mode 100644
index 000000000000..445e54d4e9df
--- /dev/null
+++ b/net-misc/vde/vde-1.5.7.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/vde/vde-1.5.7.ebuild,v 1.1 2005/02/07 02:19:57 rphillips Exp $
+
+DESCRIPTION="vde is a virtual distributed ethernet emulator for emulators like qemu, bochs, and uml."
+SRC_URI="mirror://sourceforge/vde/${P}.tgz"
+HOMEPAGE="http://vde.sourceforge.net/"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86"
+IUSE=""
+
+DEPEND=""
+
+src_compile() {
+ mv Makefile Makefile.1
+ sed -e 's/ $(BIN_DIR)/ $(DESTDIR)$(BIN_DIR)/' <Makefile.1 >Makefile
+ cat Makefile
+ cd vdetaplib
+ mv Makefile Makefile.1
+ sed -e 's/ $(BIN_DIR)/ $(DESTDIR)$(BIN_DIR)/' -e 's/ $(LIB_DIR)/ $(DESTDIR)$(LIB_DIR)/' <Makefile.1 >Makefile
+ cd ..
+ cd doc
+ mv Makefile Makefile.1
+ sed -e 's/ $(MAN_DIR)/ $(DESTDIR)$(MAN_DIR)/' <Makefile.1 >Makefile
+ cd ..
+ BIN_DIR=/usr/bin LIB_DIR=/usr/lib MAN_DIR=/usr/man emake || die
+}
+
+src_install() {
+
+ BIN_DIR=/usr/bin LIB_DIR=/usr/lib MAN_DIR=/usr/man make DESTDIR=${D} install || die
+
+ dodoc COPYING INSTALL PORTS README
+}
+
+