summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Johanson <latexer@gentoo.org>2003-06-25 20:19:42 +0000
committerPeter Johanson <latexer@gentoo.org>2003-06-25 20:19:42 +0000
commitd8a41d96c8797fce8e1e317b2fbe0595460056c4 (patch)
tree55d63ca08326bc9c35555e4c571e74876e522866 /net-misc/totd
parentInitial import. Let the 6to4 fun ensue! (diff)
downloadhistorical-d8a41d96c8797fce8e1e317b2fbe0595460056c4.tar.gz
historical-d8a41d96c8797fce8e1e317b2fbe0595460056c4.tar.bz2
historical-d8a41d96c8797fce8e1e317b2fbe0595460056c4.zip
Initial import. Let the 6to4 fun ensue!
Diffstat (limited to 'net-misc/totd')
-rw-r--r--net-misc/totd/Manifest5
-rw-r--r--net-misc/totd/files/digest-totd-1.31
-rw-r--r--net-misc/totd/files/totd39
-rw-r--r--net-misc/totd/totd-1.3.ebuild35
4 files changed, 78 insertions, 2 deletions
diff --git a/net-misc/totd/Manifest b/net-misc/totd/Manifest
index b51c0e122ffe..6ff374d366a2 100644
--- a/net-misc/totd/Manifest
+++ b/net-misc/totd/Manifest
@@ -1,3 +1,4 @@
-MD5 1a06c7b8e148ca099aed171c84a0d69e totd-1.3.ebuild 781
-MD5 97d18c74b949e56bdfadd6cf3975634d files/totd 723
+MD5 b2516141ffd4600ca524c206d3d2b967 totd-1.3.ebuild 874
+MD5 4c9a32ed365e496d603a3335cd74ef01 ChangeLog 404
+MD5 44e836923bd1a6294b5bd21e2e4d4401 files/totd 811
MD5 b5d7da146bba4e657fc30595eab333b5 files/digest-totd-1.3 59
diff --git a/net-misc/totd/files/digest-totd-1.3 b/net-misc/totd/files/digest-totd-1.3
new file mode 100644
index 000000000000..ceaf3a1b4092
--- /dev/null
+++ b/net-misc/totd/files/digest-totd-1.3
@@ -0,0 +1 @@
+MD5 bc6b85a5bddb72fc3fb20fa9fe50d3a0 totd-1.3.tar.gz 82133
diff --git a/net-misc/totd/files/totd b/net-misc/totd/files/totd
new file mode 100644
index 000000000000..df0ee5abb8f1
--- /dev/null
+++ b/net-misc/totd/files/totd
@@ -0,0 +1,39 @@
+#!/sbin/runscript
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/totd/files/totd,v 1.1 2003/06/25 20:19:39 latexer Exp $
+
+depend() {
+ need net
+}
+
+checkconfig() {
+ if [ ! -f /etc/totd.conf ]
+ then
+ eerror "The config file /etc/totd.conf does not exist."
+ return 1
+ else
+ return 0
+ fi
+}
+
+start() {
+ checkconfig || return 1
+
+ ebegin "Starting totd"
+ start-stop-daemon --start --quiet --exec /usr/sbin/totd
+ eend $?
+}
+
+stop() {
+ local pid_file
+ pid_file="`grep ^pidfile /etc/totd.conf | cut -f2 -d ' '`"
+ ebegin "Stopping totd"
+ if [ -n "$pid_file" ]
+ then
+ start-stop-daemon --stop --quiet --pidfile $pid_file
+ else
+ start-stop-daemon --stop --quiet --pidfile /var/run/totd.pid
+ fi
+ eend $?
+}
diff --git a/net-misc/totd/totd-1.3.ebuild b/net-misc/totd/totd-1.3.ebuild
new file mode 100644
index 000000000000..035f7d1a9698
--- /dev/null
+++ b/net-misc/totd/totd-1.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/totd/totd-1.3.ebuild,v 1.1 2003/06/25 20:19:39 latexer Exp $
+
+DESCRIPTION="Trick Or Treat Daemon, a DNS proxy for 6to4"
+HOMEPAGE="http://www.vermicelli.pasta.cs.uit.no/ipv6/software.html"
+SRC_URI="ftp://ftp.pasta.cs.uit.no/pub/Vermicelli/${P}.tar.gz"
+LICENSE="BSD as-is"
+
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="ipv6"
+DEPEND=""
+
+S=${WORKDIR}/${P}
+
+src_compile() {
+ econf || die
+ emake || die
+}
+
+src_install() {
+ dosbin totd
+ doman totd.8
+ dodoc totd.conf.sample README INSTALL
+
+ exeinto /etc/init.d
+ doexe ${FILESDIR}/totd
+}
+
+pkg_postinst() {
+ einfo "/usr/share/doc/${P}/totd.conf.sample.gz contains"
+ einfo "a sample config file for totd. Make sure you create"
+ einfo "/etc/totd.conf with the necessary configurations"
+}