summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2009-05-22 15:58:28 +0000
committerJeroen Roovers <jer@gentoo.org>2009-05-22 15:58:28 +0000
commitbc643cbdfcbb34ee00d1966d34340c658f090f3e (patch)
treefd225b8d8c28f47ebde75b43cdd22430361d83cd /net-misc/smbc/smbc-1.2.2-r2.ebuild
parentmake PATCHES a bash array (diff)
downloadhistorical-bc643cbdfcbb34ee00d1966d34340c658f090f3e.tar.gz
historical-bc643cbdfcbb34ee00d1966d34340c658f090f3e.tar.bz2
historical-bc643cbdfcbb34ee00d1966d34340c658f090f3e.zip
Add hack to ensure docs are installed to the appropriate directory.
Package-Manager: portage-2.2_rc33/cvs/Linux i686
Diffstat (limited to 'net-misc/smbc/smbc-1.2.2-r2.ebuild')
-rw-r--r--net-misc/smbc/smbc-1.2.2-r2.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/net-misc/smbc/smbc-1.2.2-r2.ebuild b/net-misc/smbc/smbc-1.2.2-r2.ebuild
new file mode 100644
index 000000000000..04caa4a81074
--- /dev/null
+++ b/net-misc/smbc/smbc-1.2.2-r2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/smbc/smbc-1.2.2-r2.ebuild,v 1.1 2009/05/22 15:58:28 jer Exp $
+
+EAPI="2"
+
+inherit autotools
+
+DESCRIPTION="A text mode (ncurses) SMB network commander. Features: resume and UTF-8"
+HOMEPAGE="http://smbc.airm.net/en/index.php"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~hppa ~ppc ~x86"
+IUSE="nls debug"
+
+DEPEND="net-fs/samba
+ sys-libs/ncurses
+ dev-libs/popt
+ nls? ( sys-devel/gettext )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-cflags.patch
+ epatch "${FILESDIR}"/${P}-size_t.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ $(use_with debug) \
+ || die "econf failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ mkdir -p "${D}/usr/share/doc"
+ mv -v "${D}/usr/share/"{${PN},doc/${PF}}
+}