summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Portnoy <avenj@gentoo.org>2003-05-06 12:57:35 +0000
committerJon Portnoy <avenj@gentoo.org>2003-05-06 12:57:35 +0000
commitf1b241e9ce942d7586eec94f5483a5871c331a18 (patch)
tree3d4547157b35c5a03fbde5636787ee9ad93531b8 /net-misc/scponly/scponly-3.8.ebuild
parentVersion bump. (diff)
downloadhistorical-f1b241e9ce942d7586eec94f5483a5871c331a18.tar.gz
historical-f1b241e9ce942d7586eec94f5483a5871c331a18.tar.bz2
historical-f1b241e9ce942d7586eec94f5483a5871c331a18.zip
Version bump.
Diffstat (limited to 'net-misc/scponly/scponly-3.8.ebuild')
-rw-r--r--net-misc/scponly/scponly-3.8.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/net-misc/scponly/scponly-3.8.ebuild b/net-misc/scponly/scponly-3.8.ebuild
new file mode 100644
index 000000000000..98156582b2f4
--- /dev/null
+++ b/net-misc/scponly/scponly-3.8.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/scponly/scponly-3.8.ebuild,v 1.1 2003/05/06 12:57:21 avenj Exp $
+
+DESCRIPTION="A tiny psuedoshell which only permits scp and sftp"
+SRC_URI="http://www.sublimation.org/scponly/${P}.tgz"
+HOMEPAGE="http://www.sublimation.org/scponly/"
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="virtual/glibc
+ net-misc/openssh"
+
+S=${WORKDIR}/${P}
+
+src_compile() {
+
+ PATH="${PATH}:/usr/lib/misc" ./configure \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --sysconfdir=/etc \
+ || die "./configure failed"
+
+ emake || die
+}
+
+src_install () {
+
+ make prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ CONFDIR=${D}/etc/scponly \
+ install || die
+ grep -v scponly /etc/shells > ${D}/etc/shells
+ echo "/usr/bin/scponly" >> ${D}/etc/shells
+
+ dodoc AUTHOR CHANGELOG CONTRIB README TODO
+}