summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2001-11-17 07:35:22 +0000
committerDaniel Robbins <drobbins@gentoo.org>2001-11-17 07:35:22 +0000
commit42f44c394d3a4ad93e8d6afb6ac07fa10672b0ba (patch)
treea030f2890468fd79f83d4c1ac2ec9a0ea97aec20 /net-misc/openssh
parentclean out old kernel stuff (diff)
downloadhistorical-42f44c394d3a4ad93e8d6afb6ac07fa10672b0ba.tar.gz
historical-42f44c394d3a4ad93e8d6afb6ac07fa10672b0ba.tar.bz2
historical-42f44c394d3a4ad93e8d6afb6ac07fa10672b0ba.zip
new stuffs :)
Diffstat (limited to 'net-misc/openssh')
-rw-r--r--net-misc/openssh/openssh-3.0_p1-r6.ebuild17
1 files changed, 9 insertions, 8 deletions
diff --git a/net-misc/openssh/openssh-3.0_p1-r6.ebuild b/net-misc/openssh/openssh-3.0_p1-r6.ebuild
index c7997f5c0966..a034cf5e1e69 100644
--- a/net-misc/openssh/openssh-3.0_p1-r6.ebuild
+++ b/net-misc/openssh/openssh-3.0_p1-r6.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2001 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Maintainer: System Team <system@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/openssh-3.0_p1-r6.ebuild,v 1.1 2001/11/09 04:10:42 woodchip Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/openssh-3.0_p1-r6.ebuild,v 1.2 2001/11/17 07:35:22 drobbins Exp $
P=openssh-3.0p1
S=${WORKDIR}/${P}
@@ -9,13 +9,8 @@ DESCRIPTION="Port of OpenBSD's free SSH release"
SRC_URI="ftp://ftp.openbsd.org/pub/unix/OpenBSD/OpenSSH/portable/${P}.tar.gz"
HOMEPAGE="http://www.openssh.com/"
-RDEPEND="virtual/glibc
- pam? ( >=sys-libs/pam-0.73 )
- >=dev-libs/openssl-0.9.6
- sys-libs/zlib"
-
-DEPEND="${RDEPEND} sys-devel/perl sys-apps/groff
- tcpd? ( >=sys-apps/tcp-wrappers-7.6 )"
+RDEPEND="virtual/glibc pam? ( >=sys-libs/pam-0.73 ) >=dev-libs/openssl-0.9.6 sys-libs/zlib "
+DEPEND="${RDEPEND} sys-devel/perl sys-apps/groff tcpd? ( >=sys-apps/tcp-wrappers-7.6 )"
src_compile() {
@@ -35,6 +30,12 @@ src_compile() {
--with-ipv4-default \
--host=${CHOST} ${myconf} || die "bad configure"
+ if [ "`use static`" ]
+ then
+ # statically link to libcrypto -- good for the boot cd
+ perl -pi -e "s|-lcrypto|/usr/lib/libcrypto.a|g" Makefile
+ fi
+
make || die " compile problem"
}