summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-05-03 00:43:39 +0000
committerMike Frysinger <vapier@gentoo.org>2012-05-03 00:43:39 +0000
commit9b37ada77ee8cfa586284f9d8785579c761c73ed (patch)
tree6c517427297182b3d233bf39e61181a28e6b2ff4 /net-misc/openssh/openssh-6.0_p1.ebuild
parentDeclare local S in _python-distutils-ng_run_for_impl. (diff)
downloadhistorical-9b37ada77ee8cfa586284f9d8785579c761c73ed.tar.gz
historical-9b37ada77ee8cfa586284f9d8785579c761c73ed.tar.bz2
historical-9b37ada77ee8cfa586284f9d8785579c761c73ed.zip
Enable locale env var passing by default #367017 by Michael.
Package-Manager: portage-2.2.0_alpha100/cvs/Linux x86_64
Diffstat (limited to 'net-misc/openssh/openssh-6.0_p1.ebuild')
-rw-r--r--net-misc/openssh/openssh-6.0_p1.ebuild14
1 files changed, 13 insertions, 1 deletions
diff --git a/net-misc/openssh/openssh-6.0_p1.ebuild b/net-misc/openssh/openssh-6.0_p1.ebuild
index 58630932e284..e998a9fe774b 100644
--- a/net-misc/openssh/openssh-6.0_p1.ebuild
+++ b/net-misc/openssh/openssh-6.0_p1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/openssh-6.0_p1.ebuild,v 1.1 2012/04/30 22:47:40 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/openssh-6.0_p1.ebuild,v 1.2 2012/05/03 00:43:39 vapier Exp $
EAPI="2"
inherit eutils flag-o-matic multilib autotools pam systemd
@@ -198,6 +198,18 @@ src_install() {
"${D}"/etc/ssh/sshd_config || die "sed of configuration file failed"
fi
+ # Gentoo tweaks to default config files
+ cat <<-EOF >> "${D}"/etc/ssh/sshd_config
+
+ # Allow client to pass locale environment variables #367017
+ AcceptEnv LANG LC_*
+ EOF
+ cat <<-EOF >> "${D}"/etc/ssh/ssh_config
+
+ # Send locale environment variables #367017
+ SendEnv LANG LC_*
+ EOF
+
# This instruction is from the HPN webpage,
# Used for the server logging functionality
if [[ -n ${HPN_PATCH} ]] && use hpn ; then