summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2011-02-10 03:10:55 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2011-02-10 03:10:55 +0000
commit0db9b8e3e810d59712ea8a0414ec1e2e8e7a1a40 (patch)
treee96c4fc71498cc95c6936df88da8ef50ef17400d /net-misc/openssh/openssh-5.6_p1-r2.ebuild
parentDrop libmms dep since xbmc now uses ffmpeg #353919 by BT. (diff)
downloadhistorical-0db9b8e3e810d59712ea8a0414ec1e2e8e7a1a40.tar.gz
historical-0db9b8e3e810d59712ea8a0414ec1e2e8e7a1a40.tar.bz2
historical-0db9b8e3e810d59712ea8a0414ec1e2e8e7a1a40.zip
Revamp AES-CTR-MT disable comment, with explicit reference to upstream documentation and testcase reference (bug #354113, comment 6).
Package-Manager: portage-2.2.0_alpha19/cvs/Linux x86_64
Diffstat (limited to 'net-misc/openssh/openssh-5.6_p1-r2.ebuild')
-rw-r--r--net-misc/openssh/openssh-5.6_p1-r2.ebuild16
1 files changed, 11 insertions, 5 deletions
diff --git a/net-misc/openssh/openssh-5.6_p1-r2.ebuild b/net-misc/openssh/openssh-5.6_p1-r2.ebuild
index c12d854da5ea..829c5ac3b37f 100644
--- a/net-misc/openssh/openssh-5.6_p1-r2.ebuild
+++ b/net-misc/openssh/openssh-5.6_p1-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/openssh-5.6_p1-r2.ebuild,v 1.9 2011/02/10 02:30:27 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/openssh-5.6_p1-r2.ebuild,v 1.10 2011/02/10 03:10:55 robbat2 Exp $
EAPI="2"
inherit eutils flag-o-matic multilib autotools pam
@@ -99,10 +99,16 @@ src_prepare() {
# version.h patch conflict avoidence
mv version.h version.h.hpn
cp -f version.h.pristine version.h
- # The AES-CTR multithreaded variant is temporarily broken, and
- # causes random hangs when combined with the -f switch of ssh.
- # To avoid this, we change the internal table to use the non-multithread
- # version for the meantime. Do NOT remove this in new versions.
+ # The AES-CTR multithreaded variant is broken, and causes random hangs
+ # when combined background threading and control sockets. To avoid
+ # this, we change the internal table to use the non-multithread version
+ # for the meantime. Do NOT remove this in new versions. See bug #354113
+ # comment #6 for testcase.
+ # Upstream reference: http://www.psc.edu/networking/projects/hpn-ssh/
+ ## Additionally, the MT-AES-CTR mode cipher replaces the default ST-AES-CTR mode
+ ## cipher. Be aware that if the client process is forked using the -f command line
+ ## option the process will hang as the parent thread gets 'divorced' from the key
+ ## generation threads. This issue will be resolved as soon as possible
sed -i \
-e '/aes...-ctr.*SSH_CIPHER_SSH2/s,evp_aes_ctr_mt,evp_aes_128_ctr,' \
cipher.c || die