summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Koltsov <maksbotan@gentoo.org>2011-09-14 17:06:40 +0000
committerMaxim Koltsov <maksbotan@gentoo.org>2011-09-14 17:06:40 +0000
commitbce8d65f759f9cc60b5365d95820df4081f81c09 (patch)
tree08993c424c277e42d87ac7a12fccab0f9d75a63e /net-misc/leechcraft-core
parentBig leechcraft bump, 0.4.90 (diff)
downloadhistorical-bce8d65f759f9cc60b5365d95820df4081f81c09.tar.gz
historical-bce8d65f759f9cc60b5365d95820df4081f81c09.tar.bz2
historical-bce8d65f759f9cc60b5365d95820df4081f81c09.zip
Big leechcraft bump, 0.4.90
Package-Manager: portage-2.1.10.15/cvs/Linux x86_64
Diffstat (limited to 'net-misc/leechcraft-core')
-rw-r--r--net-misc/leechcraft-core/ChangeLog8
-rw-r--r--net-misc/leechcraft-core/leechcraft-core-0.4.90.ebuild66
2 files changed, 73 insertions, 1 deletions
diff --git a/net-misc/leechcraft-core/ChangeLog b/net-misc/leechcraft-core/ChangeLog
index 707f3da4f597..32e9d6b7566c 100644
--- a/net-misc/leechcraft-core/ChangeLog
+++ b/net-misc/leechcraft-core/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/leechcraft-core
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/leechcraft-core/ChangeLog,v 1.1 2011/08/22 18:28:23 maksbotan Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/leechcraft-core/ChangeLog,v 1.2 2011/09/14 17:02:07 maksbotan Exp $
+
+*leechcraft-core-0.4.90 (14 Sep 2011)
+
+ 14 Sep 2011; Maxim Koltsov <maksbotan@gentoo.org>
+ +leechcraft-core-0.4.90.ebuild:
+ Bump net-misc/leechcraft-core to 0.4.90, thanks to 0xd34df00d
*leechcraft-core-9999 (22 Aug 2011)
*leechcraft-core-0.4.85 (22 Aug 2011)
diff --git a/net-misc/leechcraft-core/leechcraft-core-0.4.90.ebuild b/net-misc/leechcraft-core/leechcraft-core-0.4.90.ebuild
new file mode 100644
index 000000000000..c3ee69cec6b9
--- /dev/null
+++ b/net-misc/leechcraft-core/leechcraft-core-0.4.90.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/leechcraft-core/leechcraft-core-0.4.90.ebuild,v 1.1 2011/09/14 17:02:07 maksbotan Exp $
+
+EAPI="2"
+
+EGIT_REPO_URI="git://github.com/0xd34df00d/leechcraft.git"
+EGIT_PROJECT="leechcraft-${PV}"
+
+inherit confutils leechcraft
+
+DESCRIPTION="Core of LeechCraft, the modular network client"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug +sqlite postgres"
+
+DEPEND=">=dev-libs/boost-1.39
+ x11-libs/qt-core
+ x11-libs/qt-gui
+ x11-libs/qt-script
+ x11-libs/qt-sql[postgres?,sqlite?]"
+RDEPEND="${DEPEND}
+ x11-libs/qt-svg"
+
+pkg_setup() {
+ confutils_require_any postgres sqlite
+}
+
+src_configure() {
+ local mycmakeargs="-DENABLE_HTTP=OFF
+ -DENABLE_POSHUKU=OFF
+ -DENABLE_TORRENT=OFF
+ -DENABLE_AGGREGATOR=OFF
+ -DENABLE_NUFELLA=OFF
+ -DENABLE_DBUSMANAGER=OFF
+ -DENABLE_DEADLYRICS=OFF
+ -DENABLE_HISTORYHOLDER=OFF
+ -DENABLE_LMP=OFF
+ -DENABLE_NETWORKMONITOR=OFF
+ -DENABLE_SEEKTHRU=OFF
+ -DENABLE_CHATTER=OFF
+ -DENABLE_FTP=OFF
+ -DENABLE_EISKALTDCPP=OFF
+ -DENABLE_YASD=OFF
+ -DENABLE_ANHERO=OFF
+ -DENABLE_KINOTIFY=OFF
+ -DENABLE_VGRABBER=OFF
+ -DENABLE_NEWLIFE=OFF
+ -DENABLE_PYLC=OFF
+ -DENABLE_POC=OFF
+ -DENABLE_AUSCRIE=OFF
+ -DENABLE_SUMMARY=OFF
+ -DENABLE_TABPP=OFF
+ -DENABLE_SECMAN=OFF
+ -DENABLE_QROSP=OFF
+ -DENABLE_POPISHU=OFF
+ -DENABLE_GLANCE=OFF
+ -DENABLE_SHELLOPEN=OFF"
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ make_desktop_entry leechcraft "LeechCraft" leechcraft.png
+}