summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <nerdboy@gentoo.org>2003-11-24 07:57:53 +0000
committerSteve Arnold <nerdboy@gentoo.org>2003-11-24 07:57:53 +0000
commite6c4226375252508ca01dcc55eb85a35df729516 (patch)
treec9b07827e9858d51f907c6e8db6a959d5adddf55 /net-misc/hylafax
parentfixed missing directories - bug 33432 (diff)
downloadhistorical-e6c4226375252508ca01dcc55eb85a35df729516.tar.gz
historical-e6c4226375252508ca01dcc55eb85a35df729516.tar.bz2
historical-e6c4226375252508ca01dcc55eb85a35df729516.zip
fixed missing directories - bug 33432
Diffstat (limited to 'net-misc/hylafax')
-rw-r--r--net-misc/hylafax/Manifest4
-rw-r--r--net-misc/hylafax/files/digest-hylafax-4.1.8-r11
-rw-r--r--net-misc/hylafax/hylafax-4.1.8-r1.ebuild84
3 files changed, 87 insertions, 2 deletions
diff --git a/net-misc/hylafax/Manifest b/net-misc/hylafax/Manifest
index fd6361f960e2..03404d9d90e7 100644
--- a/net-misc/hylafax/Manifest
+++ b/net-misc/hylafax/Manifest
@@ -1,5 +1,5 @@
-MD5 b812e440be50f07fc1ed78deecfdbfb9 ChangeLog 5172
-MD5 89f3c8989fdf06623f2a4af5fe1784c4 hylafax-4.1.8-r1.ebuild 2372
+MD5 f697ddddf34ec43c42a944a99609b3c8 ChangeLog 5171
+MD5 610629178d2d753b941cfcb721986035 hylafax-4.1.8-r1.ebuild 2374
MD5 d82acf1bcf0f7f9e181d6a2821292f2e metadata.xml 435
MD5 a86f565f756036d280f0b4770f7327ac hylafax-4.1.8.ebuild 2216
MD5 44bdb0490811a12b11a1bb69433ea7a4 files/hylafax 3765
diff --git a/net-misc/hylafax/files/digest-hylafax-4.1.8-r1 b/net-misc/hylafax/files/digest-hylafax-4.1.8-r1
new file mode 100644
index 000000000000..6a11a8f26ec5
--- /dev/null
+++ b/net-misc/hylafax/files/digest-hylafax-4.1.8-r1
@@ -0,0 +1 @@
+MD5 beaf55ad7935e3bcaa53a5ac093f61a8 hylafax-4.1.8.tar.gz 1285536
diff --git a/net-misc/hylafax/hylafax-4.1.8-r1.ebuild b/net-misc/hylafax/hylafax-4.1.8-r1.ebuild
new file mode 100644
index 000000000000..17fa8ac6b099
--- /dev/null
+++ b/net-misc/hylafax/hylafax-4.1.8-r1.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/hylafax/hylafax-4.1.8-r1.ebuild,v 1.1 2003/11/24 07:57:51 nerdboy Exp $
+
+# This is basically unchanged from the one supplied by Stephane Loeuillet
+# to Gentoo bug: http://bugs.gentoo.org/show_bug.cgi?id=28574
+# Nice job, and thanks :)
+# Now with autoreconf for new gcc, and a new gentoo init script.
+
+IUSE="jpeg"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Client-server fax package for class 1 and 2 fax modems."
+HOMEPAGE="http://www.hylafax.org"
+SRC_URI="ftp://ftp.hylafax.org/source/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="hylafax"
+KEYWORDS="x86 ppc sparc alpha mips hppa arm"
+
+DEPEND="net-dialup/mgetty
+ >=sys-libs/zlib-1.1.4
+ >=app-text/ghostscript-5.50
+ >=media-libs/tiff-3.5.5
+ jpeg? ( media-libs/jpeg )
+ sys-apps/gawk"
+
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ # no 'econf' here because does not support standard --prefix option (prehistoric autoconf v1.92 used !!!)
+ autoreconf -f
+ ./configure \
+ --with-DIR_BIN=/usr/bin \
+ --with-DIR_SBIN=/usr/sbin \
+ --with-DIR_LIB=/usr/lib \
+ --with-DIR_LIBEXEC=/usr/sbin \
+ --with-DIR_LIBDATA=/usr/lib/fax \
+ --with-DIR_LOCKS=/var/lock \
+ --with-DIR_MAN=/usr/share/man \
+ --with-DIR_SPOOL=/var/spool/fax \
+ --with-AFM=no \
+ --with-AWK=/usr/bin/gawk \
+ --with-PATH_VGETTY=/sbin/vgetty \
+ --with-PATH_GETTY=/sbin/agetty \
+ --with-HTML=no \
+ --with-PATH_DPSRIP=/var/spool/fax/bin/ps2fax \
+ --with-PATH_IMPRIP=/usr/share/fax/psrip \
+ --with-SYSVINIT=/etc/init.d \
+ --with-INTERACTIVE=no \
+ --with-OPTIMIZER="${CFLAGS}" || die
+ # no 'emake' for the same reason (might use an old automake version)
+ make || die
+}
+
+src_install() {
+
+ dodir /usr/{bin,sbin} /usr/lib/fax /usr/share/man \
+ /var/spool/fax/{archive,client,pollq,recvq,tmp}
+ chown -R uucp:uucp ${D}/var/spool/fax
+
+ make \
+ BIN=${D}/usr/bin \
+ SBIN=${D}/usr/sbin \
+ LIBDIR=${D}/usr/lib \
+ LIB=${D}/usr/lib \
+ LIBEXEC=${D}/usr/sbin \
+ LIBDATA=${D}/usr/lib/fax \
+ MAN=${D}/usr/share/man \
+ SPOOL=${D}/var/spool/fax \
+ install || die
+
+ keepdir /var/spool/fax/{archive,client,pollq,recvq,tmp}
+ keepdir /var/spool/fax/{status,sendq,recvq,log,info,doneq,docq,dev}
+
+ insinto /etc/init.d
+ insopts -m 755
+ doins ${FILESDIR}/hylafax
+
+ dodoc COPYRIGHT README TODO VERSION
+
+ dohtml -r html/
+ keepdir /usr/share/doc/${P}
+}