summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2001-11-18 19:28:48 +0000
committerMartin Schlemmer <azarah@gentoo.org>2001-11-18 19:28:48 +0000
commite9d3bdb75ebedf679e481002723470a38f8e82f8 (patch)
tree5829b566d8b96825faac10a2c9faf3c44991c3d4 /net-misc/gtm
parentclean (diff)
downloadhistorical-e9d3bdb75ebedf679e481002723470a38f8e82f8.tar.gz
historical-e9d3bdb75ebedf679e481002723470a38f8e82f8.tar.bz2
historical-e9d3bdb75ebedf679e481002723470a38f8e82f8.zip
GTM - a Gnome file transfer manager
Diffstat (limited to 'net-misc/gtm')
-rw-r--r--net-misc/gtm/files/digest-gtm-0.4.111
-rw-r--r--net-misc/gtm/gtm-0.4.11.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/net-misc/gtm/files/digest-gtm-0.4.11 b/net-misc/gtm/files/digest-gtm-0.4.11
new file mode 100644
index 000000000000..c79e064a7f07
--- /dev/null
+++ b/net-misc/gtm/files/digest-gtm-0.4.11
@@ -0,0 +1 @@
+MD5 30507d4c767c6a88534e3a57bbe7fef0 gtm-0.4.11.tar.gz 581632
diff --git a/net-misc/gtm/gtm-0.4.11.ebuild b/net-misc/gtm/gtm-0.4.11.ebuild
new file mode 100644
index 000000000000..5e0325ce3511
--- /dev/null
+++ b/net-misc/gtm/gtm-0.4.11.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Desktop Team <desktop@cvs.gentoo.org>
+# Author: Martin Schlemmer <azarah@gentoo.org>
+
+S=${WORKDIR}/${P}
+DESCRIPTION="GTM - a transfer manager"
+SRC_URI="http://download.sourceforge.net/gtm/${P}.tar.gz"
+HOMEPAGE="http://gtm.sourceforge.net/"
+
+DEPEND="virtual/glibc
+ virtual/x11
+ x11-libs/gtk+
+ gnome-base/oaf
+ gnome-base/gnome-core
+ gnome-base/gnome-libs
+ gnome? ( gnome-base/gnome-applets )
+ ssl? ( dev-libs/openssl )"
+
+RDEPEND="virtual/glibc
+ virtual/x11
+ net-misc/wget
+ >=gnome-base/gnome-libs-1.4.0.2
+ >=gnome-base/ORBit-0.5.11"
+
+
+src_unpack() {
+
+ unpack ${A}
+
+ for lang in C pt
+ do
+ cp ${S}/doc/${lang}/Makefile.in ${S}/doc/${lang}/Makefile.in.orig
+ sed -e 's: \$(gtm_helpdir): \$(DESTDIR)$(gtm_helpdir):g' \
+ ${S}/doc/${lang}/Makefile.in.orig \
+ >${S}/doc/${lang}/Makefile.in
+ done
+
+}
+
+src_compile() {
+
+ local myconf
+ use nls || myconf="--disable-nls"
+ use gnome || myconf="${myconf} --disable-applet"
+ use gnome && myconf="${myconf} --enable-applet"
+ use ssl || myconf="${myconf} --disable-ssl"
+ use ssl && myconf="${myconf} --enable-ssl"
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var/lib \
+ --sysconfdir=/etc \
+ --without-debug \
+ $myconf || die
+
+ emake || die
+}
+
+src_install() {
+
+ make DESTDIR=${D} install || die
+}
+