summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoy Marples <uberlord@gentoo.org>2007-02-21 13:08:17 +0000
committerRoy Marples <uberlord@gentoo.org>2007-02-21 13:08:17 +0000
commit8eb659a79bedb84e24ba54c48a9209197b73d0b3 (patch)
tree5913280d78b2d65855130bb9d385ac864fedfe8b /net-misc/dhcpcd/dhcpcd-3.0.12.ebuild
parentwe don't need the use x86 && [[ LIBDIR == lib32 ]] hack anymore (diff)
downloadhistorical-8eb659a79bedb84e24ba54c48a9209197b73d0b3.tar.gz
historical-8eb659a79bedb84e24ba54c48a9209197b73d0b3.tar.bz2
historical-8eb659a79bedb84e24ba54c48a9209197b73d0b3.zip
New release.
Package-Manager: portage-2.1.2-r10
Diffstat (limited to 'net-misc/dhcpcd/dhcpcd-3.0.12.ebuild')
-rw-r--r--net-misc/dhcpcd/dhcpcd-3.0.12.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/net-misc/dhcpcd/dhcpcd-3.0.12.ebuild b/net-misc/dhcpcd/dhcpcd-3.0.12.ebuild
new file mode 100644
index 000000000000..624447c3d9dc
--- /dev/null
+++ b/net-misc/dhcpcd/dhcpcd-3.0.12.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcpcd/dhcpcd-3.0.12.ebuild,v 1.1 2007/02/21 13:08:17 uberlord Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A DHCP client"
+HOMEPAGE="http://dhcpcd.berlios.de"
+SRC_URI="http://download.berlios.de/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=""
+PROVIDE="virtual/dhcpc"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Redefine the location of ntp.drift
+ sed -i -e 's,#define NTPDRIFTFILE\t.*,#define NTPDRIFTFILE\t\t\"/var/lib/ntp/ntp.drift\",' \
+ pathnames.h || die "sed failed"
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc ChangeLog
+}