summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrandon Low <lostlogic@gentoo.org>2002-06-17 04:06:48 +0000
committerBrandon Low <lostlogic@gentoo.org>2002-06-17 04:06:48 +0000
commit350756bbdd4f63bc6207bbc7917f90db68c1a01c (patch)
tree2df4e4a0deafe63222943411469dfa080bb85526 /net-misc/dhcp
parentjava USE variable fix (diff)
downloadhistorical-350756bbdd4f63bc6207bbc7917f90db68c1a01c.tar.gz
historical-350756bbdd4f63bc6207bbc7917f90db68c1a01c.tar.bz2
historical-350756bbdd4f63bc6207bbc7917f90db68c1a01c.zip
Fix configuration, see changelog
Diffstat (limited to 'net-misc/dhcp')
-rw-r--r--net-misc/dhcp/ChangeLog10
-rw-r--r--net-misc/dhcp/dhcp-3.0-r2.ebuild85
-rw-r--r--net-misc/dhcp/files/digest-dhcp-3.0-r21
3 files changed, 95 insertions, 1 deletions
diff --git a/net-misc/dhcp/ChangeLog b/net-misc/dhcp/ChangeLog
index 154f735e8003..6712abe3cd3b 100644
--- a/net-misc/dhcp/ChangeLog
+++ b/net-misc/dhcp/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-misc/dhcp
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcp/ChangeLog,v 1.2 2002/02/14 18:58:47 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcp/ChangeLog,v 1.3 2002/06/17 04:06:48 lostlogic Exp $
+
+*dhcp-3.0-r2 (16 Jun 2002)
+
+ 16 Jun 2002; Brandon Low <lostlogic@gentoo.org>: dhcp-3.0-r2.ebuild:
+
+ This moves the definition of which ethernet ports to listen on to
+ /etc/conf.d where it should be this is prettier now thank TrAns13nT
+ for making fix this bug.
*dhcp-3.0 (14 Feb 2002)
diff --git a/net-misc/dhcp/dhcp-3.0-r2.ebuild b/net-misc/dhcp/dhcp-3.0-r2.ebuild
new file mode 100644
index 000000000000..2ee8e2b1870a
--- /dev/null
+++ b/net-misc/dhcp/dhcp-3.0-r2.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcp/dhcp-3.0-r2.ebuild,v 1.1 2002/06/17 04:06:48 lostlogic Exp $
+
+#This is only needed for a release with pl1 at the end.
+P="dhcp-3.0pl1"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="ISC Dynamic Host Configuration Protocol"
+SRC_URI="ftp://ftp.isc.org/isc/dhcp/${P}.tar.gz"
+HOMEPAGE="http://www.isc.org/products/DHCP"
+LICENSE="isc-dhcp"
+
+SLOT="0"
+DEPEND="virtual/glibc sys-apps/groff"
+RDEPEND="virtual/glibc"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}/includes
+ cat <<- END >> site.h
+#define _PATH_DHCPD_CONF "/etc/dhcp/dhcpd.conf"
+#define _PATH_DHCLIENT_DB "/var/lib/dhcp/dhclient.leases"
+#define _PATH_DHCPD_DB "/var/lib/dhcp/dhcpd.leases"
+ END
+}
+
+src_compile() {
+ cat <<- END > site.conf
+CC = gcc ${CFLAGS}
+ETC = /etc/dhcp
+VARDB = /var/lib/dhcp
+ADMMANDIR = /usr/share/man/man8
+FFMANDIR = /usr/share/man/man5
+LIBMANDIR = /usr/share/man/man3
+END
+ ./configure --with-nsupdate || die
+ emake || die
+}
+
+src_install() {
+ dodir /var/lib/dhcp
+ touch ${D}/var/lib/dhcp/dhclient.leases
+
+ cd ${S}/work.linux-2.2/client
+ into / ; dosbin dhclient
+ into /usr ; doman *.5 *.8
+
+ cd ../dhcpctl ; dolib libdhcpctl.a ; doman *.3
+ insinto /usr/include ; doins dhcpctl.h
+
+ cd ../omapip ; dolib libomapi.a ; doman *.3
+ cd ../relay ; dosbin dhcrelay ; doman *.8
+ cd ../common ; doman *.5
+ cd ../server ; dosbin dhcpd ; doman *.5 *.8
+
+ cd ${S}/client
+ # admins might wanna edit dhclient-script, so /etc is proper for it.
+ dosed "s:/etc/dhclient-script:/etc/dhcp/dhclient-script:" dhclient.conf
+ insinto /etc/dhcp ; newins dhclient.conf dhclient.conf.sample
+ exeinto /etc/dhcp ; newexe scripts/linux dhclient-script.sample
+
+ cd ${S}/server
+ insinto /etc/dhcp ; newins dhcpd.conf dhcpd.conf.sample
+
+ cd ${S}/includes/omapip
+ insinto /usr/include/omapip ; doins alloc.h buffer.h omapip.h
+
+ cd ${S}/includes/isc-dhcp
+ insinto /usr/include/isc-dhcp
+ doins boolean.h dst.h int.h lang.h list.h result.h types.h
+
+ cd ${S}
+ dodoc ANONCVS CHANGES COPYRIGHT README RELNOTES
+ newdoc client/dhclient.conf dhclient.conf.sample
+ newdoc client/scripts/linux dhclient-script.sample
+ newdoc server/dhcpd.conf dhcpd.conf.sample
+ docinto doc ; dodoc doc/*
+
+ insinto /etc/conf.d
+ newins ${FILESDIR}/conf.dhcpd dhcp
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/dhcp.rc7 dhcp
+}
diff --git a/net-misc/dhcp/files/digest-dhcp-3.0-r2 b/net-misc/dhcp/files/digest-dhcp-3.0-r2
new file mode 100644
index 000000000000..6b2999d46c71
--- /dev/null
+++ b/net-misc/dhcp/files/digest-dhcp-3.0-r2
@@ -0,0 +1 @@
+MD5 85164daf66b2a46b59923750c5716fd1 dhcp-3.0pl1.tar.gz 865096