summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2011-11-13 23:39:30 +0000
committerMichael Weber <xmw@gentoo.org>2011-11-13 23:39:30 +0000
commitdd3581ab705bb1bf3feb44ce4c2bf90415ec087d (patch)
tree81a4e7f3685cd2c2950bd8287c5177376b0a4a78 /net-misc/batctl
parentx11-themes/light-themes: New package (diff)
downloadhistorical-dd3581ab705bb1bf3feb44ce4c2bf90415ec087d.tar.gz
historical-dd3581ab705bb1bf3feb44ce4c2bf90415ec087d.tar.bz2
historical-dd3581ab705bb1bf3feb44ce4c2bf90415ec087d.zip
Version bump (thanks to Franz Schrober for the report, bug 381665)
Package-Manager: portage-2.1.10.11/cvs/Linux x86_64
Diffstat (limited to 'net-misc/batctl')
-rw-r--r--net-misc/batctl/ChangeLog7
-rw-r--r--net-misc/batctl/batctl-2011.3.0.ebuild37
2 files changed, 43 insertions, 1 deletions
diff --git a/net-misc/batctl/ChangeLog b/net-misc/batctl/ChangeLog
index 3b41b4f2e7f3..564e0236e7ce 100644
--- a/net-misc/batctl/ChangeLog
+++ b/net-misc/batctl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/batctl
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/batctl/ChangeLog,v 1.2 2011/05/22 23:22:09 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/batctl/ChangeLog,v 1.3 2011/11/13 23:36:39 xmw Exp $
+
+*batctl-2011.3.0 (13 Nov 2011)
+
+ 13 Nov 2011; Michael Weber <xmw@gentoo.org> +batctl-2011.3.0.ebuild:
+ Version bump (thanks to Franz Schrober for the report, bug 381665)
22 May 2011; Michael Weber <xmw@gentoo.org> batctl-2011.1.0.ebuild:
Improved sed expression and src_compile, thanks to Emil Langrock (bug 368213)
diff --git a/net-misc/batctl/batctl-2011.3.0.ebuild b/net-misc/batctl/batctl-2011.3.0.ebuild
new file mode 100644
index 000000000000..2767d2d7af72
--- /dev/null
+++ b/net-misc/batctl/batctl-2011.3.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/batctl/batctl-2011.3.0.ebuild,v 1.1 2011/11/13 23:36:39 xmw Exp $
+
+EAPI=4
+
+inherit linux-info toolchain-funcs
+
+DESCRIPTION="BATMAN advanced control and management tool"
+HOMEPAGE="http://www.open-mesh.org/"
+SRC_URI="http://downloads.open-mesh.org/batman/stable/sources/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+pkg_setup() {
+ if ( linux_config_exists && linux_chkconfig_present BATMAN_ADV ) \
+ || ! has_version net-misc/batman-adv ; then
+ ewarn "You need the batman-adv kernel module,"
+ ewarn "either from the kernel tree or via net-misc/batman-adv"
+ fi
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" V=1
+}
+
+src_install() {
+ emake INSTALL_PREFIX="${D}" install
+ dodoc README
+ doman man/*
+}