summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorD.M.D. Ljungmark <spider@gentoo.org>2003-08-31 23:22:05 +0000
committerD.M.D. Ljungmark <spider@gentoo.org>2003-08-31 23:22:05 +0000
commit8b95200bf0365678a8271f4a43e95dadb2db2a2e (patch)
treedf412a44297fd7c77a57619b63ee2d0967134756 /net-mail
parentversionbump (diff)
downloadhistorical-8b95200bf0365678a8271f4a43e95dadb2db2a2e.tar.gz
historical-8b95200bf0365678a8271f4a43e95dadb2db2a2e.tar.bz2
historical-8b95200bf0365678a8271f4a43e95dadb2db2a2e.zip
versionbump
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/balsa/Manifest4
-rw-r--r--net-mail/balsa/balsa-2.0.14.ebuild65
-rw-r--r--net-mail/balsa/files/digest-balsa-2.0.141
3 files changed, 68 insertions, 2 deletions
diff --git a/net-mail/balsa/Manifest b/net-mail/balsa/Manifest
index cb3dcdcf09bc..96f04feeb877 100644
--- a/net-mail/balsa/Manifest
+++ b/net-mail/balsa/Manifest
@@ -2,10 +2,10 @@ MD5 d908221a6603a181bca96ddf861cb014 balsa-1.4.0-r1.ebuild 1695
MD5 2a910fa95c46c0b8205b951e61b09787 balsa-2.0.11.ebuild 1656
MD5 440329358e99cb75091d7f125d4ca6b6 balsa-2.0.10.ebuild 1732
MD5 38928b00f46180822c83d51b00c29883 balsa-1.4.3.ebuild 1714
-MD5 e65ab2f9e455b583e629129704c11acd ChangeLog 7312
+MD5 ce62043af03fd3a82f2f7e2b507f1e19 ChangeLog 7411
MD5 03ad2e6c4ab41244af1015a8bbb0b39f metadata.xml 158
MD5 075d7e3059f7c05d16015cfc48538bda balsa-2.0.12.ebuild 1741
-MD5 075d7e3059f7c05d16015cfc48538bda balsa-2.0.14.ebuild 1741
+MD5 4c46cd5f80d8c3d47718e824e7704883 balsa-2.0.14.ebuild 1739
MD5 74b12c84c9aefe5b1c457d6503a7040e files/digest-balsa-2.0.10 66
MD5 2543b736a736635b03f9b7156b2a5071 files/digest-balsa-2.0.11 66
MD5 db591d45fa09eff2d747d1cb4662a18e files/digest-balsa-1.4.0-r1 65
diff --git a/net-mail/balsa/balsa-2.0.14.ebuild b/net-mail/balsa/balsa-2.0.14.ebuild
new file mode 100644
index 000000000000..550170447c44
--- /dev/null
+++ b/net-mail/balsa/balsa-2.0.14.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-mail/balsa/balsa-2.0.14.ebuild,v 1.1 2003/08/31 23:22:01 spider Exp $
+
+inherit gnome2 eutils
+
+IUSE="ssl gtkhtml perl ldap crypt"
+DESCRIPTION="Email client for GNOME"
+SRC_URI="http://balsa.gnome.org/${P}.tar.bz2"
+HOMEPAGE="http://balsa.gnome.org"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+
+RDEPEND="net-mail/mailbase
+ >=dev-libs/glib-2
+ >=x11-libs/gtk+-2
+ >=gnome-base/libgnome-2
+ >=gnome-base/libgnomeui-2
+ >=gnome-base/gnome-vfs-2
+ >=gnome-base/libgnomeprint-2.1.4
+ >=gnome-base/libgnomeprintui-2.1.4
+ >=net-libs/libesmtp-0.8.11
+ virtual/aspell-dict
+ >=app-text/scrollkeeper-0.1.4
+ ssl? ( dev-libs/openssl )
+ perl? ( >=dev-libs/libpcre-3.4 )
+ gtkhtml? ( =gnome-extra/libgtkhtml-2* )
+ ldap? ( net-nds/openldap )
+ crypt? ( =app-crypt/gpgme-0.3.14* )"
+
+DEPEND="dev-util/pkgconfig
+ ${RDEPEND}"
+
+src_compile() {
+ local myconf
+
+ use ssl \
+ && myconf="${myconf} --with-ssl" \
+ || myconf="${myconf} --without-ssl"
+ use gtkhtml \
+ && myconf="${myconf} --enable-gtkhtml" \
+ || myconf="${myconf} --disable-gtkhtml"
+ use perl \
+ && myconf="${myconf} --enable-pcre" \
+ || myconf="${myconf} --disable-pcre"
+ use ldap \
+ && myconf="${myconf} --enable-ldap" \
+ || myconf="${myconf} --disable-ldap"
+
+ libmutt/configure \
+ --prefix=/usr \
+ --host=${CHOST} \
+ --with-mailpath=/var/mail || die "configure libmutt failed"
+
+ # threads diabled because of 17079
+ econf ${myconf} \
+ `use_with crypt gpgme` \
+ --disable-threads || die "configure balsa failed"
+
+ emake || die "emake failed"
+}
+
+DOCS="AUTHORS COPYING ChangeLog HACKING INSTALL NEWS README TODO docs/*"
diff --git a/net-mail/balsa/files/digest-balsa-2.0.14 b/net-mail/balsa/files/digest-balsa-2.0.14
new file mode 100644
index 000000000000..c54b0da4f6be
--- /dev/null
+++ b/net-mail/balsa/files/digest-balsa-2.0.14
@@ -0,0 +1 @@
+MD5 91ec11aec9f100e3ad6c02bccae2da5d balsa-2.0.14.tar.bz2 2774405