summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2002-11-10 13:10:35 +0000
committerMartin Schlemmer <azarah@gentoo.org>2002-11-10 13:10:35 +0000
commit8547e5f83b904fa8d324e4511536e73d69eb66be (patch)
tree9d63b1e9e82b9b0a6c8857a1510281ba66cb71bc /net-mail
parentversion bump, fixes #10500. (diff)
downloadhistorical-8547e5f83b904fa8d324e4511536e73d69eb66be.tar.gz
historical-8547e5f83b904fa8d324e4511536e73d69eb66be.tar.bz2
historical-8547e5f83b904fa8d324e4511536e73d69eb66be.zip
small tweaks
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/evolution/ChangeLog5
-rw-r--r--net-mail/evolution/evolution-1.1.90.ebuild64
-rw-r--r--net-mail/evolution/files/evolution-1.1.90-kde.patch23
-rw-r--r--net-mail/evolution/files/evolution-1.1.90-scrollkeeper.patch32
-rw-r--r--net-mail/evolution/files/evolution-1.1.90-subversion.patch11
5 files changed, 115 insertions, 20 deletions
diff --git a/net-mail/evolution/ChangeLog b/net-mail/evolution/ChangeLog
index 4c58c6243cbb..36823230ec40 100644
--- a/net-mail/evolution/ChangeLog
+++ b/net-mail/evolution/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-mail/evolution
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-mail/evolution/ChangeLog,v 1.27 2002/11/09 12:58:31 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/evolution/ChangeLog,v 1.28 2002/11/10 13:10:35 azarah Exp $
+
+ 10 Nov 2002; Martin Schlemmer <azarah@gentoo.org> evolution-1.1.90.ebuild :
+ Update some USE flags. Add patches from Mandrake.
*evolution-1.1.90 (9 Nov 2002)
diff --git a/net-mail/evolution/evolution-1.1.90.ebuild b/net-mail/evolution/evolution-1.1.90.ebuild
index 5ce0a1952b70..b0100d72a30a 100644
--- a/net-mail/evolution/evolution-1.1.90.ebuild
+++ b/net-mail/evolution/evolution-1.1.90.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/evolution/evolution-1.1.90.ebuild,v 1.1 2002/11/09 12:58:31 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/evolution/evolution-1.1.90.ebuild,v 1.2 2002/11/10 13:10:35 azarah Exp $
-IUSE="ssl nls mozilla ldap doc spell pda"
+IUSE="ssl nls mozilla ldap doc spell pda ipv6"
#provide Xmake and Xemake
@@ -37,10 +37,14 @@ RDEPEND="app-text/scrollkeeper
>=net-libs/soup-0.7.4-r1
doc? ( >=app-text/scrollkeeper-0.3.10-r1 )
ssl? ( >=net-www/mozilla-0.9.9 )
+ ssl? ( >=dev-libs/openssl-0.9.5 )
ldap? ( >=net-nds/openldap-2.0 )
mozilla? ( >=net-www/mozilla-0.9.9 )
pda? ( >=gnome-extra/gnome-pilot-0.1.61-r2 )
spell? ( >=app-text/gnome-spell-0.4.1-r2 )"
+# ssl? ( mozilla? ( >=net-www/mozilla-0.9.9 ) )
+# ssl? ( !mozilla? ( >=dev-libs/openssl-0.9.5 ) )
+# This is how the deps should be, but portage cannot handle it
# Added dependency on "dev-util/gob" this should fix a configure bug
@@ -53,12 +57,17 @@ DEPEND="${RDEPEND}
src_unpack() {
unpack ${A}
+ cd ${S};
+ # Mandrake patches
+ patch -p1 < ${FILESDIR}/${P}-kde.patch || die
+ patch -p1 < ${FILESDIR}/${P}-scrollkeeper.patch || die
+ patch -p1 < ${FILESDIR}/${P}-subversion.patch || die
+
# libtoolize to fix not all libs installing, and buggy .la files.
# also add the gnome-pilot.m4 to the macros directory to fix
# problems with the pilot conduct
- cd ${S}
- elibtoolize
- xml-i18n-toolize --force
+ cd ${S}; cp -f ltmain.sh ${S}/libical/
+ elibtoolize --reverse-deps
aclocal -I macros -I /usr/share/aclocal/gnome-macros
autoconf
automake --add-missing
@@ -74,12 +83,26 @@ src_unpack() {
src_compile() {
+ # *************************************************************
+ #
+ # DB3 compile...
+ #
+ # *************************************************************
+
+ einfo "Compiling DB3..."
cd ${WORKDIR}/${DB3}/build_unix
../dist/configure --prefix=${WORKDIR}/db3 || die
make || die
make prefix=${WORKDIR}/db3 install || die
+ # *************************************************************
+ #
+ # Evolution compile...
+ #
+ # *************************************************************
+
+ einfo "Compiling Evolution..."
cd ${S}
local myconf=""
@@ -97,24 +120,21 @@ src_compile() {
myconf="${myconf} --with-openldap=no"
fi
- if [ -n "`use mozilla`" ] ; then
- myconf="${myconf} --with-nspr-includes=${MOZILLA}/include/nspr \
- --with-nspr-libs=${MOZILLA}"
- else
- myconf="${myconf} --without-nspr-libs --without-nspr-includes"
- fi
-
- if [ -n "`use ssl`" ] ; then
- myconf="${myconf} --with-nss-includes=${MOZILLA}/include/nss \
- --with-nss-libs=${MOZILLA}"
+ # Use Mozilla NSS libs if 'mozilla' *and* 'ssl' in USE
+ if [ -n "`use ssl`" -a -n "`use mozilla`" ] ; then
+ myconf="${myconf} --enable-nss=static \
+ --with-nspr-includes=${MOZILLA}/include/nspr \
+ --with-nspr-libs=${MOZILLA} \
+ --with-nss-includes=${MOZILLA}/include/nss \
+ --with-nss-libs=${MOZILLA}"
else
- myconf="${myconf} --without-nss-libs --without-nss-includes"
+ myconf="${myconf} --without-nspr-libs --without-nspr-includes \
+ --without-nss-libs --without-nss-includes"
fi
- # SSL needs NSPR libs ...
+ # Else use OpenSSL if 'mozilla' not in USE ...
if [ -n "`use ssl`" ] && [ -z "`use mozilla`" ] ; then
- myconf="${myconf} --with-nspr-includes=${MOZILLA}/include/nspr \
- --with-nspr-libs=${MOZILLA}"
+ myconf="${myconf} --enable-openssl=yes"
fi
if [ -n "`use doc`" ] ; then
@@ -123,6 +143,12 @@ src_compile() {
myconf="${myconf} --disable-gtk-doc"
fi
+ if [ -n "`use ipv6`" ] ; then
+ myconf="${myconf} --enable-ipv6=yes"
+ else
+ myconf="${myconf} --enable-ipv6=no"
+ fi
+
if [ -z "`use nls`" ] ; then
myconf="${myconf} --disable-nls"
fi
diff --git a/net-mail/evolution/files/evolution-1.1.90-kde.patch b/net-mail/evolution/files/evolution-1.1.90-kde.patch
new file mode 100644
index 000000000000..af178f1210f5
--- /dev/null
+++ b/net-mail/evolution/files/evolution-1.1.90-kde.patch
@@ -0,0 +1,23 @@
+--- evolution-1.1.90/configure.in.kde 2002-11-07 13:07:41.000000000 +0100
++++ evolution-1.1.90/configure.in 2002-11-07 13:12:12.000000000 +0100
+@@ -1196,18 +1196,8 @@
+ if test -z "$with_kde_applnk_path"; then
+ with_kde_applnk_path="$prefix/share/applnk"
+ fi
+- if test -d "$with_kde_applnk_path" ; then
+- AC_DEFINE(HAVE_KDE_APPLNK)
+- KDE_APPLNK_DIR="$with_kde_applnk_path"
+- else
+- AC_PATH_PROG(KDECONFIG, kde-config)
+- if test -n "$KDECONFIG"; then
+- KDE_APPLNK_DIR=`$KDECONFIG --expandvars --install apps`
+- AC_DEFINE(HAVE_KDE_APPLNK)
+- else
+- KDE_APPLNK_DIR=""
+- fi
+- fi
++ AC_DEFINE(HAVE_KDE_APPLNK)
++ KDE_APPLNK_DIR="$with_kde_applnk_path"
+ else
+ KDE_APPLNK_DIR=""
+ fi
diff --git a/net-mail/evolution/files/evolution-1.1.90-scrollkeeper.patch b/net-mail/evolution/files/evolution-1.1.90-scrollkeeper.patch
new file mode 100644
index 000000000000..18b153bcf4e8
--- /dev/null
+++ b/net-mail/evolution/files/evolution-1.1.90-scrollkeeper.patch
@@ -0,0 +1,32 @@
+--- evolution-1.1.90/help/C/evolution-C.omf.scrollkeeper 2002-09-24 19:45:25.000000000 +0200
++++ evolution-1.1.90/help/C/evolution-C.omf 2002-11-07 13:31:58.000000000 +0100
+@@ -1,4 +1,5 @@
+-<?xml version="1.0" standalone="no"?>
++<?xml version="1.0" encoding="ISO-8859-1" standalone="no"?>
++<!DOCTYPE omf PUBLIC "-//OMF//DTD Scrollkeeper OMF Variant V1.0//EN" "http://scrollkeeper.sourceforge.net/dtds/scrollkeeper-omf-1.0/scrollkeeper-omf.dtd">
+ <omf>
+ <resource>
+ <creator>
+@@ -12,5 +13,6 @@
+ <format mime="text/html"/>
+ <identifier url="index.html"/>
+ <language code="C"/>
++ <relation seriesid="6a2207d8-8aa4-11d6-8cb4-f0bb5a765891"/>
+ </resource>
+ </omf>
+--- evolution-1.1.90/help/no/evolution-no.omf.scrollkeeper 2002-09-24 19:45:27.000000000 +0200
++++ evolution-1.1.90/help/no/evolution-no.omf 2002-11-07 13:33:03.000000000 +0100
+@@ -1,4 +1,5 @@
+-<?xml version="1.0" standalone="no"?>
++<?xml version="1.0" encoding="ISO-8859-1" standalone="no"?>
++<!DOCTYPE omf PUBLIC "-//OMF//DTD Scrollkeeper OMF Variant V1.0//EN" "http://scrollkeeper.sourceforge.net/dtds/scrollkeeper-omf-1.0/scrollkeeper-omf.dtd">
+ <omf>
+ <resource>
+ <creator>
+@@ -12,5 +13,6 @@
+ <format mime="text/sgml"/>
+ <identifier url="index.html"/>
+ <language code="no"/>
++ <relation seriesid="6a2207d8-8aa4-11d6-8cb4-f0bb5a765891"/>
+ </resource>
+ </omf>
diff --git a/net-mail/evolution/files/evolution-1.1.90-subversion.patch b/net-mail/evolution/files/evolution-1.1.90-subversion.patch
new file mode 100644
index 000000000000..83cb40fd71b0
--- /dev/null
+++ b/net-mail/evolution/files/evolution-1.1.90-subversion.patch
@@ -0,0 +1,11 @@
+--- evolution-1.1.90/mail/mail-ops.c.subversion 2002-09-24 19:45:37.000000000 +0200
++++ evolution-1.1.90/mail/mail-ops.c 2002-11-07 13:17:20.000000000 +0100
+@@ -467,7 +467,7 @@
+ int i;
+
+ camel_medium_set_header (CAMEL_MEDIUM (message), "X-Mailer",
+- "Ximian Evolution " VERSION SUB_VERSION " " VERSION_COMMENT);
++ "Ximian Evolution " VERSION "-" SUB_VERSION " " VERSION_COMMENT);
+
+ camel_mime_message_set_date (message, CAMEL_MESSAGE_DATE_CURRENT, 0);
+