summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Hadaway <raker@gentoo.org>2002-09-25 17:00:56 +0000
committerNick Hadaway <raker@gentoo.org>2002-09-25 17:00:56 +0000
commit76e31a9546a91ad9c79094978a0afe60874b79d0 (patch)
tree0b70aa55118f6f34103a6896f6e66ddf380143b6 /net-mail/vm-pop3d/vm-pop3d-1.1.6.ebuild
parentNew ipv6 patch. It squashes the ssl patch though. :~| Masked. (diff)
downloadhistorical-76e31a9546a91ad9c79094978a0afe60874b79d0.tar.gz
historical-76e31a9546a91ad9c79094978a0afe60874b79d0.tar.bz2
historical-76e31a9546a91ad9c79094978a0afe60874b79d0.zip
Fix some init script problems and changed command line parameters for
starting vm-pop3d
Diffstat (limited to 'net-mail/vm-pop3d/vm-pop3d-1.1.6.ebuild')
-rw-r--r--net-mail/vm-pop3d/vm-pop3d-1.1.6.ebuild32
1 files changed, 23 insertions, 9 deletions
diff --git a/net-mail/vm-pop3d/vm-pop3d-1.1.6.ebuild b/net-mail/vm-pop3d/vm-pop3d-1.1.6.ebuild
index a1a6c53d2b66..2738f52e3221 100644
--- a/net-mail/vm-pop3d/vm-pop3d-1.1.6.ebuild
+++ b/net-mail/vm-pop3d/vm-pop3d-1.1.6.ebuild
@@ -1,23 +1,40 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/vm-pop3d/vm-pop3d-1.1.6.ebuild,v 1.2 2002/08/14 12:05:25 murphy Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/vm-pop3d/vm-pop3d-1.1.6.ebuild,v 1.3 2002/09/25 17:00:56 raker Exp $
S=${WORKDIR}/${P}
+
DESCRIPTION="vm-pop3d - vm-pop3d is a POP3 server"
SRC_URI="http://www.ibiblio.org/pub/Linux/system/mail/pop/${P}.tar.gz"
HOMEPAGE="http://www.reedmedia.net/software/virtualmail-pop3d/"
-DEPEND="virtual/glibc"
-RDEPEND=""
-
-
SLOT="0"
LICENSE="GPL-2"
KEYWORDS="x86 sparc sparc64"
+DEPEND="virtual/glibc"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+
+ unpack ${A}
+ cd ${S}
+ patch -p1 < ${FILESDIR}/makefile.in.diff || die "patch failed"
+
+}
+
src_compile() {
- use pam || myconf=" --disable-pam "
+ local myconf
+
+ use pam && myconf="${myconf} --enable-pam" \
+ || myconf="${myconf} --disable-pam "
+
+ if [ -n "$DEBUG" ]; then
+ myconf="${myconf} --enable-debug"
+ else
+ myconf="${myconf} --disable-debug"
+ fi
econf ${myconf} || die "configure failed"
@@ -35,8 +52,5 @@ src_install () {
newexe ${FILESDIR}/vm-pop3d.rc3 vm-pop3d
insinto /etc/conf.d
newins ${FILESDIR}/vm-pop3d.confd vm-pop3d
-}
-pkg_postinst() {
- einfo "Done!"
}