summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2005-07-12 06:46:27 +0000
committerTorsten Veller <tove@gentoo.org>2005-07-12 06:46:27 +0000
commit905b773992b366485d894ad504814265ecb5aede (patch)
tree2547a50bbf206a05f1674a54b3d8aaa355cb5c9e /net-mail/t-prot/t-prot-2.0.1.ebuild
parentepatch requires eutils (diff)
downloadhistorical-905b773992b366485d894ad504814265ecb5aede.tar.gz
historical-905b773992b366485d894ad504814265ecb5aede.tar.bz2
historical-905b773992b366485d894ad504814265ecb5aede.zip
Version bump. Always apply patch for recent mutt versions. Removed BUGS from docs.
Package-Manager: portage-2.0.51.22-r1
Diffstat (limited to 'net-mail/t-prot/t-prot-2.0.1.ebuild')
-rw-r--r--net-mail/t-prot/t-prot-2.0.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/net-mail/t-prot/t-prot-2.0.1.ebuild b/net-mail/t-prot/t-prot-2.0.1.ebuild
new file mode 100644
index 000000000000..63db543e9fae
--- /dev/null
+++ b/net-mail/t-prot/t-prot-2.0.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/t-prot/t-prot-2.0.1.ebuild,v 1.1 2005/07/12 06:46:27 tove Exp $
+
+inherit eutils
+
+DESCRIPTION="TOFU protection - display filter for RFC822 messages"
+HOMEPAGE="http://www.escape.de/users/tolot/mutt/"
+SRC_URI="http://www.escape.de/users/tolot/mutt/t-prot/downloads/${P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RDEPEND="dev-lang/perl
+ dev-perl/Locale-gettext
+ dev-perl/Getopt-Mixed"
+
+src_unpack() {
+ unpack "${A}"
+ cd "${S}"
+ epatch "${S}"/contrib/t-prot-r1.*-mutt157.diff
+}
+
+src_install() {
+ dobin t-prot || die "dobin failed."
+ doman t-prot.1 || die "doman failed."
+ dodoc ChangeLog README TODO || die "dodoc failed."
+ docinto contrib
+ dodoc contrib/{README.examples,muttrc.t-prot,t-prot.sl,filter_innd.pl} \
+ || die "dodoc contrib failed"
+}