summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2003-10-23 18:48:46 +0000
committerSeemant Kulleen <seemant@gentoo.org>2003-10-23 18:48:46 +0000
commit51d38d8ba6d090692c5727de63023350444fbbca (patch)
tree5b888d877ce092ea2860be1653616c452c074744 /net-mail/sylpheed
parentrestoring gtk2 version of sylpheed-0.9.5 (diff)
downloadhistorical-51d38d8ba6d090692c5727de63023350444fbbca.tar.gz
historical-51d38d8ba6d090692c5727de63023350444fbbca.tar.bz2
historical-51d38d8ba6d090692c5727de63023350444fbbca.zip
restoring gtk2 version of sylpheed-0.9.5
Diffstat (limited to 'net-mail/sylpheed')
-rw-r--r--net-mail/sylpheed/Manifest2
-rw-r--r--net-mail/sylpheed/files/digest-sylpheed-0.9.5-r12
-rw-r--r--net-mail/sylpheed/sylpheed-0.9.5-r1.ebuild91
3 files changed, 94 insertions, 1 deletions
diff --git a/net-mail/sylpheed/Manifest b/net-mail/sylpheed/Manifest
index fb877f5d4928..ca91aa44a11e 100644
--- a/net-mail/sylpheed/Manifest
+++ b/net-mail/sylpheed/Manifest
@@ -1,4 +1,4 @@
-MD5 1f7cf096ecd1590abdf10fda1f1c7916 sylpheed-0.9.5-r1.ebuild 2323
+MD5 dc364539dbdd7d126b00e1f270498d45 sylpheed-0.9.5-r1.ebuild 2310
MD5 4fb520f688c17e8417d713c11df2f6b0 sylpheed-0.9.7.ebuild 1720
MD5 006daac5258d6d18a2ecc63fda8383ad sylpheed-0.9.4.ebuild 1687
MD5 c4302a6743c21639783c499aa00a5e99 sylpheed-0.9.4-r1.ebuild 2316
diff --git a/net-mail/sylpheed/files/digest-sylpheed-0.9.5-r1 b/net-mail/sylpheed/files/digest-sylpheed-0.9.5-r1
new file mode 100644
index 000000000000..0bdda05ac10a
--- /dev/null
+++ b/net-mail/sylpheed/files/digest-sylpheed-0.9.5-r1
@@ -0,0 +1,2 @@
+MD5 2e217d01a941e6006ffe4bf86df380d4 sylpheed-0.9.5.tar.bz2 2145795
+MD5 8d9bc0a8a9606b9021346f037377822c sylpheed-0.9.5-gtk2-20030906.diff.gz 125100
diff --git a/net-mail/sylpheed/sylpheed-0.9.5-r1.ebuild b/net-mail/sylpheed/sylpheed-0.9.5-r1.ebuild
new file mode 100644
index 000000000000..39170391d0f0
--- /dev/null
+++ b/net-mail/sylpheed/sylpheed-0.9.5-r1.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/sylpheed/sylpheed-0.9.5-r1.ebuild,v 1.3 2003/10/23 18:48:45 seemant Exp $
+
+IUSE="ssl xface ipv6 nls gnome ldap crypt pda gtk2"
+
+inherit eutils
+
+S=${WORKDIR}/${P}
+PATCHVER="20030906"
+DESCRIPTION="A lightweight email client and newsreader"
+SRC_URI="http://sylpheed.good-day.net/${PN}/${P}.tar.bz2
+ gtk2? ( mirror://sourceforge/${PN}-gtk2/${P}-gtk2-${PATCHVER}.diff.gz )"
+
+HOMEPAGE="http://sylpheed.good-day.net
+http://www.homa.ne.jp/~ashie/linux/sylpheed-gtk2.html.en"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~hppa"
+
+PROVIDE="virtual/sylpheed"
+
+DEPEND="
+ gtk2? ( >=x11-libs/gtk+-2.0 )
+ !gtk2? ( =x11-libs/gtk+-1.2* )
+ xface? ( >=media-libs/compface-1.4 )
+ ssl? ( dev-libs/openssl )
+ pda? ( app-pda/jpilot )
+ crypt? ( >=app-crypt/gnupg-1.0.6 =app-crypt/gpgme-0.3.14 )
+ ldap? ( >=net-nds/openldap-2.0.11 )
+ gnome? ( >=media-libs/gdk-pixbuf-0.11.0-r1 )
+ x11-misc/shared-mime-info"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/shared-mime.patch
+ use gtk2 && gunzip -dc ${DISTDIR}/sylpheed-${PV}-gtk2-${PATCHVER}.diff.gz >sylpheed-${PV}-gtk2-${PATCHVER}.diff
+
+# use gtk2 && patch <${FILESDIR}/gtk2-patch-fix.patch
+ use gtk2 && epatch sylpheed-${PV}-gtk2-${PATCHVER}.diff
+}
+
+src_compile() {
+ local myconf
+ if [ `use gtk2` ];
+ then
+ myconf="${myconf} --enable-gdk-pixbuf"
+ else
+ use gnome || myconf="${myconf} --disable-gdk-pixbuf --disable-imlib"
+ use nls || myconf="${myconf} --disable-nls"
+ fi
+
+
+ use ssl && myconf="${myconf} --enable-ssl"
+
+ use crypt && myconf="${myconf} --enable-gpgme"
+
+ use pda && myconf="${myconf} --enable-jpilot"
+
+ use ldap && myconf="${myconf} --enable-ldap"
+
+ use ipv6 && myconf="${myconf} --enable-ipv6"
+
+ use xface || myconf="${myconf} --disable-compface"
+
+ # build fails if this is done normally. dunno why and didn't bother to find out. : )
+ use gtk2 && ./autogen.sh
+
+ econf ${myconf}
+
+ emake || die
+}
+
+src_install () {
+ einstall
+
+ dodir /usr/share/pixmaps
+ insinto /usr/share/pixmaps
+ doins *.png
+
+ if use gnome
+ then
+ dodir /usr/share/gnome/apps/Internet
+ insinto /usr/share/gnome/apps/Internet
+ doins sylpheed.desktop
+ fi
+
+ dodoc ABOUT-NLS AUTHORS COPYING ChangeLog* NEWS README* TODO*
+}