summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2006-11-11 11:02:14 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2006-11-11 11:02:14 +0000
commit57a74aaa30b72c59e95d12fe6b585a37156472e9 (patch)
tree3c924f1c957d85d6a229aecefb55982e457d2c17 /net-mail/qmailadmin/qmailadmin-1.2.10.ebuild
parentVersion bump with updated dependencies; remove old version. Add metadata.xml (diff)
downloadhistorical-57a74aaa30b72c59e95d12fe6b585a37156472e9.tar.gz
historical-57a74aaa30b72c59e95d12fe6b585a37156472e9.tar.bz2
historical-57a74aaa30b72c59e95d12fe6b585a37156472e9.zip
Bug #153896, bump for security reasons. Also clean up some minor QA issues, and remove the strict requirement on apache - as it works with other web servers too.
Package-Manager: portage-2.1.2_rc1-r4
Diffstat (limited to 'net-mail/qmailadmin/qmailadmin-1.2.10.ebuild')
-rw-r--r--net-mail/qmailadmin/qmailadmin-1.2.10.ebuild96
1 files changed, 96 insertions, 0 deletions
diff --git a/net-mail/qmailadmin/qmailadmin-1.2.10.ebuild b/net-mail/qmailadmin/qmailadmin-1.2.10.ebuild
new file mode 100644
index 000000000000..69e54af6d3aa
--- /dev/null
+++ b/net-mail/qmailadmin/qmailadmin-1.2.10.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/qmailadmin/qmailadmin-1.2.10.ebuild,v 1.1 2006/11/11 11:02:13 robbat2 Exp $
+
+inherit eutils
+
+# TODO: convert this ebuild to use web-app.
+
+# the RESTRICT is because the vpopmail lib directory is locked down
+# and non-root can't access them.
+RESTRICT='userpriv'
+
+MY_PV="${PV/_rc/-rc}"
+MY_P="${PN}-${MY_PV}"
+DESCRIPTION="A web interface for managing a qmail system with virtual domains"
+HOMEPAGE="http://www.inter7.com/qmailadmin.html"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~sparc ~x86"
+IUSE="maildrop"
+
+DEPEND="virtual/qmail
+ >=net-mail/vpopmail-5.3
+ net-mail/autorespond
+ maildrop? ( >=mail-filter/maildrop-2.0.1 )"
+RDEPEND="${DEPEND}"
+# apache and lighttpd both work, but there's no virtual yet
+# net-www/apache"
+
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-1.2.9-maildir.patch
+}
+
+src_compile() {
+ local dir_vpopmail="/var/vpopmail"
+ local dir_vhost="/var/www/localhost"
+ local dir_htdocs="${dir_vhost}/htdocs/${PN}"
+ local dir_htdocs_images="${dir_htdocs}/images"
+ local url_htdocs_images="/${PN}/images"
+ local dir_cgibin="${dir_vhost}/cgi-bin"
+ local url_cgibin="/cgi-bin/${PN}"
+ local dir_htdocs_htmlib="/usr/share/${PN}/htmllib"
+ local dir_qmail="/var/qmail"
+ local dir_true="/bin"
+ local dir_ezmlm="/usr/bin"
+ local dir_autorespond="/var/qmail/bin"
+
+ # Pass spam stuff through $@ so we get the quoting right
+ if use maildrop ; then
+ set -- --enable-modify-spam \
+ --enable-spam-command='|preline maildrop /etc/maildroprc'
+ else
+ set --
+ fi
+
+ econf \
+ --enable-valias \
+ --enable-vpopmaildir=${dir_vpopmail} \
+ --enable-htmldir=${dir_htdocs} \
+ --enable-imageurl=${url_htdocs_images} \
+ --enable-imagedir=${dir_htdocs_images} \
+ --enable-htmllibdir=${dir_htdocs_htmlib} \
+ --enable-qmaildir=${dir_qmail} \
+ --enable-true-path=${dir_true} \
+ --enable-ezmlmdir=${dir_ezmlm} \
+ --enable-cgibindir=${dir_cgibin} \
+ --enable-cgipath=${url_cgibin} \
+ --enable-autoresponder-path=${dir_autorespond} \
+ --enable-domain-autofill \
+ --enable-modify-quota \
+ --enable-no-cache \
+ --enable-maxusersperpage=50 \
+ --enable-maxaliasesperpage=50 \
+ --enable-vpopuser=vpopmail \
+ --enable-vpopgroup=vpopmail \
+ "$@" \
+ || die "econf failed"
+ emake || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc AUTHORS INSTALL README.hooks BUGS TODO ChangeLog TRANSLATORS NEWS FAQ README contrib/*
+}
+
+pkg_postinst() {
+ einfo "If you would like support for ezmlm mailing lists inside qmailadmin,"
+ einfo "please emerge some variant of ezmlm-idx."
+}