summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrej Kacian <ticho@gentoo.org>2006-05-01 22:16:20 +0000
committerAndrej Kacian <ticho@gentoo.org>2006-05-01 22:16:20 +0000
commit4ffea80ea3ba6040585f670dbda2877d7d9d285c (patch)
treedde84d745d63b02014cfabaf8e6b108a8e050341 /net-mail/pop-before-smtp/pop-before-smtp-1.41.ebuild
parentVersion bump (diff)
downloadhistorical-4ffea80ea3ba6040585f670dbda2877d7d9d285c.tar.gz
historical-4ffea80ea3ba6040585f670dbda2877d7d9d285c.tar.bz2
historical-4ffea80ea3ba6040585f670dbda2877d7d9d285c.zip
Version bump. Closes bug #118977, reported by Alexander Schneider <A.Schneider at magicspace.de>.
Package-Manager: portage-2.1_pre9-r4
Diffstat (limited to 'net-mail/pop-before-smtp/pop-before-smtp-1.41.ebuild')
-rw-r--r--net-mail/pop-before-smtp/pop-before-smtp-1.41.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/net-mail/pop-before-smtp/pop-before-smtp-1.41.ebuild b/net-mail/pop-before-smtp/pop-before-smtp-1.41.ebuild
new file mode 100644
index 000000000000..867efd19cecb
--- /dev/null
+++ b/net-mail/pop-before-smtp/pop-before-smtp-1.41.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/pop-before-smtp/pop-before-smtp-1.41.ebuild,v 1.1 2006/05/01 22:16:20 ticho Exp $
+
+DESCRIPTION="a simple daemon to allow email relay control based on successful POP or IMAP logins"
+HOMEPAGE="http://popbsmtp.sourceforge.net"
+SRC_URI="mirror://sourceforge/popbsmtp/${P}.tar.gz"
+
+LICENSE="GPL-2 BSD Artistic"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-perl/File-Tail
+ virtual/perl-Time-HiRes
+ dev-perl/Net-Netmask
+ dev-perl/TimeDate
+ dev-perl/Unix-Syslog"
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # enable syslog
+ sed -i \
+ -e "/^=cut #============================= syslog ===========================START=$/d" \
+ -e "/^=cut #============================= syslog =============================END=$/d" \
+ pop-before-smtp-conf.pl \
+ || die "sed pop-before-smtp-conf.pl failed"
+}
+
+src_install() {
+ dosbin pop-before-smtp || die "dosbin failed"
+ dodoc README ChangeLog TODO contrib/README.QUICKSTART
+ insinto /etc
+ doins pop-before-smtp-conf.pl || die "doins failed"
+ exeinto /etc/init.d
+ newexe "${FILESDIR}/pop-before-smtp.init" pop-before.smtp \
+ || die "newexe failed"
+}