summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2005-04-17 21:42:18 +0000
committerMarinus Schraal <foser@gentoo.org>2005-04-17 21:42:18 +0000
commit8e6984dea00f89b0c318b4ced1e4473c7d99a6a7 (patch)
treed6d76ff613090b32a8c7c6204d618620d70b2ded /net-libs
parentFixed pvm configure pathing logic for sparc. (diff)
downloadhistorical-8e6984dea00f89b0c318b4ced1e4473c7d99a6a7.tar.gz
historical-8e6984dea00f89b0c318b4ced1e4473c7d99a6a7.tar.bz2
historical-8e6984dea00f89b0c318b4ced1e4473c7d99a6a7.zip
add gcc3 fix
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/soup/ChangeLog5
-rw-r--r--net-libs/soup/Manifest9
-rw-r--r--net-libs/soup/files/digest-soup-0.7.101
-rw-r--r--net-libs/soup/files/digest-soup-0.7.4-r11
-rw-r--r--net-libs/soup/files/soup-0.7.11-gcc3.patch96
-rw-r--r--net-libs/soup/soup-0.7.10.ebuild50
-rw-r--r--net-libs/soup/soup-0.7.11.ebuild20
-rw-r--r--net-libs/soup/soup-0.7.4-r1.ebuild50
8 files changed, 118 insertions, 114 deletions
diff --git a/net-libs/soup/ChangeLog b/net-libs/soup/ChangeLog
index 5da9ee5cf8c9..49607b2ff776 100644
--- a/net-libs/soup/ChangeLog
+++ b/net-libs/soup/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-libs/soup
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/soup/ChangeLog,v 1.22 2004/06/24 23:18:15 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/soup/ChangeLog,v 1.23 2005/04/17 21:42:18 foser Exp $
+
+ 17 Apr 2005; foser <foser@gentoo.org> soup-0.7.11.ebuild :
+ Add gcc3 patch (#68047)
17 Mar 2004; Gustavo Zacarias <gustavoz@gentoo.org> soup-0.7.11.ebuild:
stable on sparc
diff --git a/net-libs/soup/Manifest b/net-libs/soup/Manifest
index bf3ccc24cdad..58bf4497c96a 100644
--- a/net-libs/soup/Manifest
+++ b/net-libs/soup/Manifest
@@ -1,8 +1,5 @@
-MD5 07ca6c658555fd73dafe4de89bd856d8 ChangeLog 2166
+MD5 8cf5ba51aa3880b56dbc19090dbf87ff ChangeLog 2251
+MD5 da6b448cd03bb7e7e630feb9835cd14e soup-0.7.11.ebuild 1319
MD5 03ad2e6c4ab41244af1015a8bbb0b39f metadata.xml 158
-MD5 288e9264efbd44516cacbf1f5af19b87 soup-0.7.10.ebuild 1103
-MD5 1798061ad1815a998697dc66d38aeef9 soup-0.7.11.ebuild 1209
-MD5 0dbfc46e83ee0d40021e50732bf49f2d soup-0.7.4-r1.ebuild 1097
-MD5 a768d0192483fe394f059e4ec9c692f5 files/digest-soup-0.7.10 64
+MD5 2c257e92617c67cf1c1ec3e0f49da62c files/soup-0.7.11-gcc3.patch 3051
MD5 37f9be1ab2386e2eed241a1d0ea33dfd files/digest-soup-0.7.11 64
-MD5 291975cff852179904f6f3d1db52aead files/digest-soup-0.7.4-r1 63
diff --git a/net-libs/soup/files/digest-soup-0.7.10 b/net-libs/soup/files/digest-soup-0.7.10
deleted file mode 100644
index 571d421e3d3f..000000000000
--- a/net-libs/soup/files/digest-soup-0.7.10
+++ /dev/null
@@ -1 +0,0 @@
-MD5 baf1ecd6e14ca50544ce889ba363a9be soup-0.7.10.tar.bz2 303967
diff --git a/net-libs/soup/files/digest-soup-0.7.4-r1 b/net-libs/soup/files/digest-soup-0.7.4-r1
deleted file mode 100644
index 3fe03db237c2..000000000000
--- a/net-libs/soup/files/digest-soup-0.7.4-r1
+++ /dev/null
@@ -1 +0,0 @@
-MD5 848ccf5e7616cd897593bab72bbc9b5a soup-0.7.4.tar.bz2 309489
diff --git a/net-libs/soup/files/soup-0.7.11-gcc3.patch b/net-libs/soup/files/soup-0.7.11-gcc3.patch
new file mode 100644
index 000000000000..615cae01d002
--- /dev/null
+++ b/net-libs/soup/files/soup-0.7.11-gcc3.patch
@@ -0,0 +1,96 @@
+diff -ur soup-0.7.11.orig/src/libwsdl/wsdl-soap-memory.c soup-0.7.11/src/libwsdl/wsdl-soap-memory.c
+--- soup-0.7.11.orig/src/libwsdl/wsdl-soap-memory.c 2001-08-27 03:38:53.000000000 +0200
++++ soup-0.7.11/src/libwsdl/wsdl-soap-memory.c 2004-10-27 15:05:10.557844265 +0200
+@@ -33,14 +33,14 @@
+
+ while (param->name != NULL) {
+ if (param->typecode == NULL) {
+- g_warning (G_GNUC_FUNCTION
+- ": Parameter %s has no typecode!",
+- param->name);
++ g_warning ("%s: Parameter %s has no typecode!",
++ G_GNUC_FUNCTION,
++ param->name);
+ } else {
+ if (param->param == NULL) {
+- g_warning (G_GNUC_FUNCTION
+- ": Parameter %s has no "
++ g_warning ("%s: Parameter %s has no "
+ "memory location!",
++ G_GNUC_FUNCTION,
+ param->name);
+ } else {
+ memset (param->param,
+@@ -71,9 +71,9 @@
+
+ while (param->name != NULL) {
+ if (param->typecode == NULL) {
+- g_warning (G_GNUC_FUNCTION
+- ": Parameter %s has no typecode!",
+- param->name);
++ g_warning ("%s: Parameter %s has no typecode!",
++ G_GNUC_FUNCTION,
++ param->name);
+ } else {
+ if (param->param != NULL &&
+ *(guchar **) param->param != NULL &&
+diff -ur soup-0.7.11.orig/src/libwsdl/wsdl-soap-parse.c soup-0.7.11/src/libwsdl/wsdl-soap-parse.c
+--- soup-0.7.11.orig/src/libwsdl/wsdl-soap-parse.c 2002-05-03 22:14:27.000000000 +0200
++++ soup-0.7.11/src/libwsdl/wsdl-soap-parse.c 2004-10-27 15:02:04.000000000 +0200
+@@ -37,7 +37,7 @@
+
+ switch (wsdl_typecode_kind (typecode)) {
+ case WSDL_TK_GLIB_NULL:
+- g_warning ("Invalid typecode NULL in " G_GNUC_FUNCTION);
++ g_warning ("Invalid typecode NULL in %s", G_GNUC_FUNCTION);
+ break;
+
+ case WSDL_TK_GLIB_VOID:
+@@ -203,7 +203,7 @@
+ /* Handled elsewhere */
+ break;
+ case WSDL_TK_GLIB_MAX:
+- g_warning ("Invalid typecode MAX in " G_GNUC_FUNCTION);
++ g_warning ("Invalid typecode MAX in %s", G_GNUC_FUNCTION);
+ break;
+ }
+ }
+diff -ur soup-0.7.11.orig/src/libwsdl/wsdl-typecodes.c soup-0.7.11/src/libwsdl/wsdl-typecodes.c
+--- soup-0.7.11.orig/src/libwsdl/wsdl-typecodes.c 2002-04-05 22:46:30.000000000 +0200
++++ soup-0.7.11/src/libwsdl/wsdl-typecodes.c 2004-10-27 15:01:13.000000000 +0200
+@@ -977,7 +977,7 @@
+ {
+ switch (tc->kind) {
+ case WSDL_TK_GLIB_NULL:
+- g_warning ("Invalid typecode NULL in " G_GNUC_FUNCTION);
++ g_warning ("Invalid typecode NULL in %s", G_GNUC_FUNCTION);
+ return (0);
+ break;
+
+@@ -1082,7 +1082,7 @@
+ break;
+
+ case WSDL_TK_GLIB_MAX:
+- g_warning ("Invalid typecode MAX in " G_GNUC_FUNCTION);
++ g_warning ("Invalid typecode MAX in %s", G_GNUC_FUNCTION);
+ return (0);
+ break;
+ }
+@@ -1106,7 +1106,7 @@
+ {
+ switch (tc->kind) {
+ case WSDL_TK_GLIB_NULL:
+- g_warning ("Invalid typecode NULL in " G_GNUC_FUNCTION);
++ g_warning ("Invalid typecode NULL in %s", G_GNUC_FUNCTION);
+ return (0);
+ break;
+
+@@ -1218,7 +1218,7 @@
+ break;
+
+ case WSDL_TK_GLIB_MAX:
+- g_warning ("Invalid typecode MAX in " G_GNUC_FUNCTION);
++ g_warning ("Invalid typecode MAX in %s", G_GNUC_FUNCTION);
+ return (0);
+ break;
+ }
diff --git a/net-libs/soup/soup-0.7.10.ebuild b/net-libs/soup/soup-0.7.10.ebuild
deleted file mode 100644
index 6826f0f14ce2..000000000000
--- a/net-libs/soup/soup-0.7.10.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/soup/soup-0.7.10.ebuild,v 1.12 2004/11/09 21:26:53 mr_bones_ Exp $
-
-IUSE="ssl doc"
-
-inherit gnome.org libtool
-
-DESCRIPTION="Soup is a SOAP implementation"
-HOMEPAGE="http://www.gnome.org/"
-
-DEPEND=">=dev-util/pkgconfig-0.12.0
- =dev-libs/glib-1.2*
- dev-libs/libxml
- dev-libs/popt
- ssl? ( dev-libs/openssl )
- doc? ( >=dev-util/gtk-doc-0.9-r2 )"
-
-LICENSE="|| ( GPL-2 LGPL-2 )"
-SLOT="0"
-KEYWORDS="x86 sparc ~ppc ~alpha"
-
-src_compile() {
- elibtoolize
-
- local myconf=""
- use ssl \
- && myconf="--enable-ssl" \
- || myconf="--disable-ssl"
-
- use doc \
- && myconf="${myconf} --enable-gtk-doc" \
- || myconf="${myconf} --disable-gtk-doc"
-
- # there is a --enable-apache here.....
-
- econf \
- ${myconf} \
- --with-libxml=1 || die
- # Evolution 1.1 and 1.2 need it with libxml1
-
- # dont always work with -j4 -- <azarah@gentoo.org> 9 Nov 2002
- make || die
-}
-
-src_install() {
- einstall || die
-
- dodoc AUTHORS ABOUT-NLS COPYING* ChangeLog README* INSTALL NEWS TODO
-}
diff --git a/net-libs/soup/soup-0.7.11.ebuild b/net-libs/soup/soup-0.7.11.ebuild
index 1c50d4456fa9..100e80884429 100644
--- a/net-libs/soup/soup-0.7.11.ebuild
+++ b/net-libs/soup/soup-0.7.11.ebuild
@@ -1,10 +1,8 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/soup/soup-0.7.11.ebuild,v 1.11 2004/11/09 21:26:53 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/soup/soup-0.7.11.ebuild,v 1.12 2005/04/17 21:42:18 foser Exp $
-IUSE="ssl doc"
-
-inherit gnome.org libtool
+inherit gnome.org libtool eutils
DESCRIPTION="Soup is a SOAP implementation"
HOMEPAGE="http://www.gnome.org/"
@@ -16,10 +14,22 @@ DEPEND=">=dev-util/pkgconfig-0.12.0
ssl? ( dev-libs/openssl )
doc? ( >=dev-util/gtk-doc-0.9-r2 )"
+IUSE="ssl doc"
+
LICENSE="|| ( GPL-2 LGPL-2 )"
SLOT="0"
KEYWORDS="x86 sparc ppc ~alpha hppa"
+src_unpack() {
+
+ unpack ${A}
+
+ cd ${S}
+ # fix gcc bailing (#68047)
+ epatch ${FILESDIR}/${P}-gcc3.patch
+
+}
+
src_compile() {
elibtoolize
diff --git a/net-libs/soup/soup-0.7.4-r1.ebuild b/net-libs/soup/soup-0.7.4-r1.ebuild
deleted file mode 100644
index 6166c8905c45..000000000000
--- a/net-libs/soup/soup-0.7.4-r1.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/soup/soup-0.7.4-r1.ebuild,v 1.10 2004/11/09 21:26:53 mr_bones_ Exp $
-
-IUSE="ssl doc"
-
-inherit gnome.org libtool
-
-DESCRIPTION="Soup is a SOAP implementation"
-HOMEPAGE="http://www.gnome.org/"
-
-DEPEND=">=dev-util/pkgconfig-0.12.0
- =dev-libs/glib-1.2*
- dev-libs/libxml
- dev-libs/popt
- ssl? ( dev-libs/openssl )
- doc? ( >=dev-util/gtk-doc-0.9-r2 )"
-
-LICENSE="|| ( GPL-2 LGPL-2 )"
-SLOT="0"
-KEYWORDS="x86 sparc ppc"
-
-src_compile() {
- elibtoolize
-
- local myconf=""
- use ssl \
- && myconf="--enable-ssl" \
- || myconf="--disable-ssl"
-
- use doc \
- && myconf="${myconf} --enable-gtk-doc" \
- || myconf="${myconf} --disable-gtk-doc"
-
- # there is a --enable-apache here.....
-
- econf \
- ${myconf} \
- --with-libxml=1 || die
- # Evolution 1.1 and 1.2 need it with libxml1
-
- # dont always work with -j4 -- <azarah@gentoo.org> 9 Nov 2002
- make || die
-}
-
-src_install() {
- einstall || die
-
- dodoc AUTHORS ABOUT-NLS COPYING* ChangeLog README* INSTALL NEWS TODO
-}