summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-12-27 17:46:13 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-12-27 17:46:13 +0000
commit89eb69c9b1f02b0a043ccc4344dddedd013fa8ba (patch)
treea78e42d6b76eb65aa57fbd8f69dac73ce0e54ebb /net-libs
parentReally really really fix recv call (bug #336755). (diff)
downloadhistorical-89eb69c9b1f02b0a043ccc4344dddedd013fa8ba.tar.gz
historical-89eb69c9b1f02b0a043ccc4344dddedd013fa8ba.tar.bz2
historical-89eb69c9b1f02b0a043ccc4344dddedd013fa8ba.zip
Delete older ebuilds.
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/gnutls/files/gnutls-2.6.0-cxx-configure.in.patch20
-rw-r--r--net-libs/gnutls/gnutls-2.10.0.ebuild96
-rw-r--r--net-libs/gnutls/gnutls-2.11.0.ebuild97
-rw-r--r--net-libs/gnutls/gnutls-2.11.1.ebuild99
-rw-r--r--net-libs/gnutls/gnutls-2.11.2.ebuild99
-rw-r--r--net-libs/gnutls/gnutls-2.11.3.ebuild99
6 files changed, 0 insertions, 510 deletions
diff --git a/net-libs/gnutls/files/gnutls-2.6.0-cxx-configure.in.patch b/net-libs/gnutls/files/gnutls-2.6.0-cxx-configure.in.patch
deleted file mode 100644
index 8b884b7c6218..000000000000
--- a/net-libs/gnutls/files/gnutls-2.6.0-cxx-configure.in.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- configure.in.orig 2008-11-04 22:27:44.000000000 +1100
-+++ configure.in 2008-11-04 22:31:13.000000000 +1100
-@@ -79,7 +79,6 @@
-
- dnl Checks for programs.
- AC_PROG_CC
--AC_PROG_CXX
- AC_PROG_LN_S
- GTK_DOC_CHECK(1.1)
- AC_PATH_PROG([GAA], [gaa])
-@@ -114,6 +113,9 @@
- AC_LANG_PUSH(C++)
- AC_COMPILE_IFELSE([AC_LANG_PROGRAM([],[])], use_cxx=yes, use_cxx=no)
- AC_LANG_POP(C++)
-+ AC_PROG_CXX
-+else
-+ AM_CONDITIONAL([am__fastdepCXX], [false])
- fi
-
- AC_MSG_CHECKING([whether C99 macros are supported])
diff --git a/net-libs/gnutls/gnutls-2.10.0.ebuild b/net-libs/gnutls/gnutls-2.10.0.ebuild
deleted file mode 100644
index a754ad53a277..000000000000
--- a/net-libs/gnutls/gnutls-2.10.0.ebuild
+++ /dev/null
@@ -1,96 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/gnutls/gnutls-2.10.0.ebuild,v 1.8 2010/08/06 16:50:42 jer Exp $
-
-EAPI="3"
-
-inherit autotools libtool
-
-DESCRIPTION="A TLS 1.2 and SSL 3.0 implementation for the GNU project"
-HOMEPAGE="http://www.gnutls.org/"
-
-if [[ "${PV}" == *pre* ]]; then
- SRC_URI="http://daily.josefsson.org/${P%.*}/${P%.*}-${PV#*pre}.tar.gz"
-else
- MINOR_VERSION="${PV#*.}"
- MINOR_VERSION="${MINOR_VERSION%.*}"
- if [[ $((MINOR_VERSION % 2)) == 0 ]]; then
- #SRC_URI="ftp://ftp.gnu.org/pub/gnu/${PN}/${P}.tar.bz2"
- SRC_URI="mirror://gnu/${PN}/${P}.tar.bz2"
- else
- SRC_URI="ftp://alpha.gnu.org/gnu/${PN}/${P}.tar.bz2"
- fi
- unset MINOR_VERSION
-fi
-
-# GPL-3 for the gnutls-extras library and LGPL for the gnutls library.
-LICENSE="LGPL-2.1 GPL-3"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~sparc-fbsd ~x86-fbsd"
-IUSE="bindist +cxx doc examples guile lzo nls zlib"
-
-RDEPEND="dev-libs/libgpg-error
- >=dev-libs/libgcrypt-1.4.0
- >=dev-libs/libtasn1-0.3.4
- nls? ( virtual/libintl )
- guile? ( dev-scheme/guile[networking] )
- zlib? ( >=sys-libs/zlib-1.1 )
- !bindist? ( lzo? ( >=dev-libs/lzo-2 ) )"
-DEPEND="${RDEPEND}
- sys-devel/libtool
- doc? ( dev-util/gtk-doc )
- nls? ( sys-devel/gettext )"
-
-S="${WORKDIR}/${P%_pre*}"
-
-pkg_setup() {
- if use lzo && use bindist; then
- ewarn "lzo support was disabled for binary distribution of GnuTLS"
- ewarn "due to licensing issues. See Bug #202381 for details."
- fi
-}
-
-src_prepare() {
- sed -e 's/imagesdir = $(infodir)/imagesdir = $(htmldir)/' -i doc/Makefile.am
-
- local dir
- for dir in m4 lib/m4 libextra/m4; do
- rm -f "${dir}/lt"* "${dir}/libtool.m4"
- done
- find . -name ltmain.sh -exec rm {} \;
- for dir in . lib libextra; do
- pushd "${dir}" > /dev/null
- eautoreconf
- popd > /dev/null
- done
-
- elibtoolize # for sane .so versioning on FreeBSD
-}
-
-src_configure() {
- local myconf
- use bindist && myconf="--without-lzo" || myconf="$(use_with lzo)"
- econf --htmldir=/usr/share/doc/${P}/html \
- $(use_enable cxx) \
- $(use_enable doc gtk-doc) \
- $(use_enable guile) \
- $(use_enable nls) \
- $(use_with zlib) \
- ${myconf}
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
-
- dodoc AUTHORS ChangeLog NEWS README THANKS doc/TODO
-
- if use doc; then
- dodoc doc/gnutls.{pdf,ps}
- dohtml doc/gnutls.html
- fi
-
- if use examples; then
- docinto examples
- dodoc doc/examples/*.c
- fi
-}
diff --git a/net-libs/gnutls/gnutls-2.11.0.ebuild b/net-libs/gnutls/gnutls-2.11.0.ebuild
deleted file mode 100644
index 678de7d08549..000000000000
--- a/net-libs/gnutls/gnutls-2.11.0.ebuild
+++ /dev/null
@@ -1,97 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/gnutls/gnutls-2.11.0.ebuild,v 1.1 2010/07/22 20:13:14 arfrever Exp $
-
-EAPI="3"
-
-inherit autotools libtool
-
-DESCRIPTION="A TLS 1.2 and SSL 3.0 implementation for the GNU project"
-HOMEPAGE="http://www.gnutls.org/"
-
-if [[ "${PV}" == *pre* ]]; then
- SRC_URI="http://daily.josefsson.org/${P%.*}/${P%.*}-${PV#*pre}.tar.gz"
-else
- MINOR_VERSION="${PV#*.}"
- MINOR_VERSION="${MINOR_VERSION%.*}"
- if [[ $((MINOR_VERSION % 2)) == 0 ]]; then
- #SRC_URI="ftp://ftp.gnu.org/pub/gnu/${PN}/${P}.tar.bz2"
- SRC_URI="mirror://gnu/${PN}/${P}.tar.bz2"
- else
- #SRC_URI="ftp://alpha.gnu.org/gnu/${PN}/${P}.tar.bz2"
- SRC_URI="ftp://ftp.gnutls.org/pub/${PN}/devel/${P}.tar.bz2"
- fi
- unset MINOR_VERSION
-fi
-
-# GPL-3 for the gnutls-extras library and LGPL for the gnutls library.
-LICENSE="LGPL-2.1 GPL-3"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
-IUSE="bindist +cxx doc examples guile lzo nls zlib"
-
-RDEPEND="dev-libs/libgpg-error
- >=dev-libs/libgcrypt-1.4.0
- >=dev-libs/libtasn1-0.3.4
- nls? ( virtual/libintl )
- guile? ( dev-scheme/guile[networking] )
- zlib? ( >=sys-libs/zlib-1.1 )
- !bindist? ( lzo? ( >=dev-libs/lzo-2 ) )"
-DEPEND="${RDEPEND}
- sys-devel/libtool
- doc? ( dev-util/gtk-doc )
- nls? ( sys-devel/gettext )"
-
-S="${WORKDIR}/${P%_pre*}"
-
-pkg_setup() {
- if use lzo && use bindist; then
- ewarn "lzo support was disabled for binary distribution of GnuTLS"
- ewarn "due to licensing issues. See Bug #202381 for details."
- fi
-}
-
-src_prepare() {
- sed -e 's/imagesdir = $(infodir)/imagesdir = $(htmldir)/' -i doc/Makefile.am
-
- local dir
- for dir in m4 lib/m4 libextra/m4; do
- rm -f "${dir}/lt"* "${dir}/libtool.m4"
- done
- find . -name ltmain.sh -exec rm {} \;
- for dir in . lib libextra; do
- pushd "${dir}" > /dev/null
- eautoreconf
- popd > /dev/null
- done
-
- elibtoolize # for sane .so versioning on FreeBSD
-}
-
-src_configure() {
- local myconf
- use bindist && myconf="--without-lzo" || myconf="$(use_with lzo)"
- econf --htmldir=/usr/share/doc/${P}/html \
- $(use_enable cxx) \
- $(use_enable doc gtk-doc) \
- $(use_enable guile) \
- $(use_enable nls) \
- $(use_with zlib) \
- ${myconf}
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
-
- dodoc AUTHORS ChangeLog NEWS README THANKS doc/TODO
-
- if use doc; then
- dodoc doc/gnutls.{pdf,ps}
- dohtml doc/gnutls.html
- fi
-
- if use examples; then
- docinto examples
- dodoc doc/examples/*.c
- fi
-}
diff --git a/net-libs/gnutls/gnutls-2.11.1.ebuild b/net-libs/gnutls/gnutls-2.11.1.ebuild
deleted file mode 100644
index 6a05f71725f4..000000000000
--- a/net-libs/gnutls/gnutls-2.11.1.ebuild
+++ /dev/null
@@ -1,99 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/gnutls/gnutls-2.11.1.ebuild,v 1.2 2010/09/30 14:46:42 ssuominen Exp $
-
-EAPI="3"
-
-inherit autotools libtool
-
-DESCRIPTION="A TLS 1.2 and SSL 3.0 implementation for the GNU project"
-HOMEPAGE="http://www.gnutls.org/"
-
-if [[ "${PV}" == *pre* ]]; then
- SRC_URI="http://daily.josefsson.org/${P%.*}/${P%.*}-${PV#*pre}.tar.gz"
-else
- MINOR_VERSION="${PV#*.}"
- MINOR_VERSION="${MINOR_VERSION%.*}"
- if [[ $((MINOR_VERSION % 2)) == 0 ]]; then
- #SRC_URI="ftp://ftp.gnu.org/pub/gnu/${PN}/${P}.tar.bz2"
- SRC_URI="mirror://gnu/${PN}/${P}.tar.bz2"
- else
- SRC_URI="ftp://alpha.gnu.org/gnu/${PN}/${P}.tar.bz2"
- fi
- unset MINOR_VERSION
-fi
-
-# GPL-3 for the gnutls-extras library and LGPL for the gnutls library.
-LICENSE="LGPL-2.1 GPL-3"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
-IUSE="bindist +cxx doc examples guile lzo +nettle nls test zlib"
-
-# lib/m4/hooks.m4 says that GnuTLS uses a fork of PaKChoiS.
-RDEPEND=">=dev-libs/libtasn1-0.3.4
- nls? ( virtual/libintl )
- guile? ( dev-scheme/guile[networking] )
- nettle? ( >=dev-libs/nettle-2.1 )
- !nettle? ( >=dev-libs/libgcrypt-1.4.0 )
- zlib? ( >=sys-libs/zlib-1.1 )
- !bindist? ( lzo? ( >=dev-libs/lzo-2 ) )"
-DEPEND="${RDEPEND}
- sys-devel/libtool
- doc? ( dev-util/gtk-doc )
- nls? ( sys-devel/gettext )
- test? ( app-misc/datefudge )"
-
-S="${WORKDIR}/${P%_pre*}"
-
-pkg_setup() {
- if use lzo && use bindist; then
- ewarn "lzo support was disabled for binary distribution of GnuTLS"
- ewarn "due to licensing issues. See Bug #202381 for details."
- fi
-}
-
-src_prepare() {
- sed -e 's/imagesdir = $(infodir)/imagesdir = $(htmldir)/' -i doc/Makefile.am
-
- local dir
- for dir in m4 lib/m4 libextra/m4; do
- rm -f "${dir}/lt"* "${dir}/libtool.m4"
- done
- find . -name ltmain.sh -exec rm {} \;
- for dir in . lib libextra; do
- pushd "${dir}" > /dev/null
- eautoreconf
- popd > /dev/null
- done
-
- elibtoolize # for sane .so versioning on FreeBSD
-}
-
-src_configure() {
- local myconf
- use bindist && myconf="--without-lzo" || myconf="$(use_with lzo)"
- econf --htmldir=/usr/share/doc/${P}/html \
- $(use_enable cxx) \
- $(use_enable doc gtk-doc) \
- $(use_enable guile) \
- $(use_with !nettle libgcrypt) \
- $(use_enable nls) \
- $(use_with zlib) \
- ${myconf}
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
-
- dodoc AUTHORS ChangeLog NEWS README THANKS doc/TODO
-
- if use doc; then
- dodoc doc/gnutls.{pdf,ps}
- dohtml doc/gnutls.html
- fi
-
- if use examples; then
- docinto examples
- dodoc doc/examples/*.c
- fi
-}
diff --git a/net-libs/gnutls/gnutls-2.11.2.ebuild b/net-libs/gnutls/gnutls-2.11.2.ebuild
deleted file mode 100644
index 8eba3b5477df..000000000000
--- a/net-libs/gnutls/gnutls-2.11.2.ebuild
+++ /dev/null
@@ -1,99 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/gnutls/gnutls-2.11.2.ebuild,v 1.1 2010/10/16 00:11:43 arfrever Exp $
-
-EAPI="3"
-
-inherit autotools libtool
-
-DESCRIPTION="A TLS 1.2 and SSL 3.0 implementation for the GNU project"
-HOMEPAGE="http://www.gnutls.org/"
-
-if [[ "${PV}" == *pre* ]]; then
- SRC_URI="http://daily.josefsson.org/${P%.*}/${P%.*}-${PV#*pre}.tar.gz"
-else
- MINOR_VERSION="${PV#*.}"
- MINOR_VERSION="${MINOR_VERSION%.*}"
- if [[ $((MINOR_VERSION % 2)) == 0 ]]; then
- #SRC_URI="ftp://ftp.gnu.org/pub/gnu/${PN}/${P}.tar.bz2"
- SRC_URI="mirror://gnu/${PN}/${P}.tar.bz2"
- else
- SRC_URI="ftp://alpha.gnu.org/gnu/${PN}/${P}.tar.bz2"
- fi
- unset MINOR_VERSION
-fi
-
-# GPL-3 for the gnutls-extras library and LGPL for the gnutls library.
-LICENSE="LGPL-2.1 GPL-3"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
-IUSE="bindist +cxx doc examples guile lzo +nettle nls test zlib"
-
-# lib/m4/hooks.m4 says that GnuTLS uses a fork of PaKChoiS.
-RDEPEND=">=dev-libs/libtasn1-0.3.4
- nls? ( virtual/libintl )
- guile? ( dev-scheme/guile[networking] )
- nettle? ( >=dev-libs/nettle-2.1[gmp] )
- !nettle? ( >=dev-libs/libgcrypt-1.4.0 )
- zlib? ( >=sys-libs/zlib-1.1 )
- !bindist? ( lzo? ( >=dev-libs/lzo-2 ) )"
-DEPEND="${RDEPEND}
- sys-devel/libtool
- doc? ( dev-util/gtk-doc )
- nls? ( sys-devel/gettext )
- test? ( app-misc/datefudge )"
-
-S="${WORKDIR}/${P%_pre*}"
-
-pkg_setup() {
- if use lzo && use bindist; then
- ewarn "lzo support is disabled for binary distribution of GnuTLS due to licensing issues."
- fi
-}
-
-src_prepare() {
- sed -e 's/imagesdir = $(infodir)/imagesdir = $(htmldir)/' -i doc/Makefile.am
-
- local dir
- for dir in m4 lib/m4 libextra/m4; do
- rm -f "${dir}/lt"* "${dir}/libtool.m4"
- done
- find . -name ltmain.sh -exec rm {} \;
- for dir in . lib libextra; do
- pushd "${dir}" > /dev/null
- eautoreconf
- popd > /dev/null
- done
-
- # Use sane .so versioning on FreeBSD.
- elibtoolize
-}
-
-src_configure() {
- local myconf
- use bindist && myconf="--without-lzo" || myconf="$(use_with lzo)"
- econf --htmldir=/usr/share/doc/${P}/html \
- $(use_enable cxx) \
- $(use_enable doc gtk-doc) \
- $(use_enable guile) \
- $(use_with !nettle libgcrypt) \
- $(use_enable nls) \
- $(use_with zlib) \
- ${myconf}
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
-
- dodoc AUTHORS ChangeLog NEWS README THANKS doc/TODO
-
- if use doc; then
- dodoc doc/gnutls.{pdf,ps}
- dohtml doc/gnutls.html
- fi
-
- if use examples; then
- docinto examples
- dodoc doc/examples/*.c
- fi
-}
diff --git a/net-libs/gnutls/gnutls-2.11.3.ebuild b/net-libs/gnutls/gnutls-2.11.3.ebuild
deleted file mode 100644
index c99956b3d963..000000000000
--- a/net-libs/gnutls/gnutls-2.11.3.ebuild
+++ /dev/null
@@ -1,99 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/gnutls/gnutls-2.11.3.ebuild,v 1.1 2010/10/16 00:44:15 arfrever Exp $
-
-EAPI="3"
-
-inherit autotools libtool
-
-DESCRIPTION="A TLS 1.2 and SSL 3.0 implementation for the GNU project"
-HOMEPAGE="http://www.gnutls.org/"
-
-if [[ "${PV}" == *pre* ]]; then
- SRC_URI="http://daily.josefsson.org/${P%.*}/${P%.*}-${PV#*pre}.tar.gz"
-else
- MINOR_VERSION="${PV#*.}"
- MINOR_VERSION="${MINOR_VERSION%.*}"
- if [[ $((MINOR_VERSION % 2)) == 0 ]]; then
- #SRC_URI="ftp://ftp.gnu.org/pub/gnu/${PN}/${P}.tar.bz2"
- SRC_URI="mirror://gnu/${PN}/${P}.tar.bz2"
- else
- SRC_URI="ftp://alpha.gnu.org/gnu/${PN}/${P}.tar.bz2"
- fi
- unset MINOR_VERSION
-fi
-
-# GPL-3 for the gnutls-extras library and LGPL for the gnutls library.
-LICENSE="LGPL-2.1 GPL-3"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
-IUSE="bindist +cxx doc examples guile lzo +nettle nls test zlib"
-
-# lib/m4/hooks.m4 says that GnuTLS uses a fork of PaKChoiS.
-RDEPEND=">=dev-libs/libtasn1-0.3.4
- nls? ( virtual/libintl )
- guile? ( dev-scheme/guile[networking] )
- nettle? ( >=dev-libs/nettle-2.1[gmp] )
- !nettle? ( >=dev-libs/libgcrypt-1.4.0 )
- zlib? ( >=sys-libs/zlib-1.1 )
- !bindist? ( lzo? ( >=dev-libs/lzo-2 ) )"
-DEPEND="${RDEPEND}
- sys-devel/libtool
- doc? ( dev-util/gtk-doc )
- nls? ( sys-devel/gettext )
- test? ( app-misc/datefudge )"
-
-S="${WORKDIR}/${P%_pre*}"
-
-pkg_setup() {
- if use lzo && use bindist; then
- ewarn "lzo support is disabled for binary distribution of GnuTLS due to licensing issues."
- fi
-}
-
-src_prepare() {
- sed -e 's/imagesdir = $(infodir)/imagesdir = $(htmldir)/' -i doc/Makefile.am
-
- local dir
- for dir in m4 lib/m4 libextra/m4; do
- rm -f "${dir}/lt"* "${dir}/libtool.m4"
- done
- find . -name ltmain.sh -exec rm {} \;
- for dir in . lib libextra; do
- pushd "${dir}" > /dev/null
- eautoreconf
- popd > /dev/null
- done
-
- # Use sane .so versioning on FreeBSD.
- elibtoolize
-}
-
-src_configure() {
- local myconf
- use bindist && myconf="--without-lzo" || myconf="$(use_with lzo)"
- econf --htmldir=/usr/share/doc/${P}/html \
- $(use_enable cxx) \
- $(use_enable doc gtk-doc) \
- $(use_enable guile) \
- $(use_with !nettle libgcrypt) \
- $(use_enable nls) \
- $(use_with zlib) \
- ${myconf}
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
-
- dodoc AUTHORS ChangeLog NEWS README THANKS doc/TODO
-
- if use doc; then
- dodoc doc/gnutls.{pdf,ps}
- dohtml doc/gnutls.html
- fi
-
- if use examples; then
- docinto examples
- dodoc doc/examples/*.c
- fi
-}