summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2008-12-04 22:56:45 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2008-12-04 22:56:45 +0000
commitb5a844b3242fb5fef50648db9bfad521335e6ba6 (patch)
tree54b5a5be10ebbfc3e5ee13974a4ab732190ca0c7 /net-libs/loudmouth/loudmouth-1.4.3.ebuild
parentamd64/x86 stable, bug #249435 (diff)
downloadhistorical-b5a844b3242fb5fef50648db9bfad521335e6ba6.tar.gz
historical-b5a844b3242fb5fef50648db9bfad521335e6ba6.tar.bz2
historical-b5a844b3242fb5fef50648db9bfad521335e6ba6.zip
Bump to 1.4.3. Allow building against system libasyncns, bug #236844.
Package-Manager: portage-2.2_rc16/cvs/Linux 2.6.24-gentoo-r8-mactel x86_64
Diffstat (limited to 'net-libs/loudmouth/loudmouth-1.4.3.ebuild')
-rw-r--r--net-libs/loudmouth/loudmouth-1.4.3.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/net-libs/loudmouth/loudmouth-1.4.3.ebuild b/net-libs/loudmouth/loudmouth-1.4.3.ebuild
new file mode 100644
index 000000000000..d8bfd64e03fb
--- /dev/null
+++ b/net-libs/loudmouth/loudmouth-1.4.3.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/loudmouth/loudmouth-1.4.3.ebuild,v 1.1 2008/12/04 22:56:45 eva Exp $
+
+inherit autotools gnome2
+
+DESCRIPTION="Lightweight C Jabber library"
+HOMEPAGE="http://www.loudmouth-project.org/"
+SRC_URI="http://ftp.imendio.com/pub/imendio/${PN}/src/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="asyncns doc ssl debug test"
+
+RDEPEND=">=dev-libs/glib-2.4
+ ssl? ( >=net-libs/gnutls-1.4.0 )
+ asyncns? ( net-libs/libasyncns )"
+# FIXME:
+# openssl dropped because of bug #216705
+
+DEPEND="${RDEPEND}
+ test? ( dev-libs/check )
+ dev-util/pkgconfig
+ doc? ( >=dev-util/gtk-doc-1 )"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+pkg_setup() {
+ G2CONF="${G2CONF} $(use_enable debug)"
+
+ if use ssl; then
+ G2CONF="${G2CONF} --with-ssl=gnutls"
+ else
+ G2CONF="${G2CONF} --with-ssl=no"
+ fi
+
+ if use asyncns; then
+ G2CONF="${G2CONF} --with-asyncns=system"
+ else
+ G2CONF="${G2CONF} --without-asyncns"
+ fi
+}
+
+src_unpack() {
+ gnome2_src_unpack
+
+ # Use system libasyncns, bug #236844
+ epatch "${FILESDIR}/${P}-asyncns-system.patch"
+
+ eautoreconf
+}