summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimothy Redaelli <drizzt@gentoo.org>2007-04-04 19:59:17 +0000
committerTimothy Redaelli <drizzt@gentoo.org>2007-04-04 19:59:17 +0000
commitb61e44852424d7dd70a9e1870d68267e25ef4b12 (patch)
treece9d91bbb3816aba6d1ad90cff8e5c56e517895e /net-libs/libtorrent/libtorrent-0.11.4.ebuild
parentuse games_get_libdir (diff)
downloadhistorical-b61e44852424d7dd70a9e1870d68267e25ef4b12.tar.gz
historical-b61e44852424d7dd70a9e1870d68267e25ef4b12.tar.bz2
historical-b61e44852424d7dd70a9e1870d68267e25ef4b12.zip
Version bump (thx to Flameeyes for reporting on irc)
Package-Manager: portage-2.1.2.2
Diffstat (limited to 'net-libs/libtorrent/libtorrent-0.11.4.ebuild')
-rw-r--r--net-libs/libtorrent/libtorrent-0.11.4.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/net-libs/libtorrent/libtorrent-0.11.4.ebuild b/net-libs/libtorrent/libtorrent-0.11.4.ebuild
new file mode 100644
index 000000000000..c6d18b960799
--- /dev/null
+++ b/net-libs/libtorrent/libtorrent-0.11.4.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libtorrent/libtorrent-0.11.4.ebuild,v 1.1 2007/04/04 19:59:17 drizzt Exp $
+
+inherit eutils toolchain-funcs flag-o-matic libtool autotools
+
+DESCRIPTION="LibTorrent is a BitTorrent library written in C++ for *nix."
+HOMEPAGE="http://libtorrent.rakshasa.no/"
+SRC_URI="http://libtorrent.rakshasa.no/downloads/${P}.tar.gz"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+IUSE="debug"
+
+RDEPEND=">=dev-libs/libsigc++-2"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.11"
+
+#src_unpack() {
+# unpack ${A}
+# cd "${S}"
+
+# AT_M4DIR="scripts" eautoreconf
+#}
+
+src_compile() {
+ replace-flags -Os -O2
+
+ if [[ $(tc-arch) = "x86" ]]; then
+ filter-flags -fomit-frame-pointer -fforce-addr
+
+ # See bug #151221. It seems only to hit on GCC 4.1 and x86 architecture
+ # it could be safer to fallback to -O1, but with the high use of STL in
+ # rtorrent, that could make it too slow.
+ [[ $(gcc-major-version)$(gcc-minor-version) == "41" ]] && replace-flags -O2 -O3
+ fi
+
+ elibtoolize
+ econf \
+ $(use_enable debug) \
+ --disable-dependency-tracking \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}